JSEB7984
Contributor
Contributor

VMWare Tools installed but shared folders in Ubuntu refusing to work

Having got this initial error when trying to use Shared folders running VM on Fusion 11.5.5 with Ubuntu 20.04

"Shared folders will not be available in the virtual machine until VMware Tools is installed and running."

some other helpful threads here allowed me to install (and reinstall) VMWare Tools.

But despite successful installation I am still getting the same error.

Has anyone had this and successfully resolved?

Thank you,

15 Replies
Mikero
Community Manager
Community Manager

Are you installing Tools from the Menu, or did you just install open-vm-tools-desktop in the Ubuntu guest?

The latter is how I do things personally, everything works. 90% of Tools code is published as open source to the various distros to include in their package repos.

So I do `sudo apt-get install open-vm-tools-desktop`, reboot and we're done.

-
Michael Roy - PM/PMM: Fusion & Workstation
JSEB7984
Contributor
Contributor

Sadly they are definitely installed. I tried your command which just confirmed and uninstalled reinstalled and rebooted etc but I still get the message "Shared folders will not be available in the virtual machine until VMware Tools is installed and running."

At a bit of a loss.

0 Kudos

Did you install the open-vm-tools or the VMWare tools?  If the latter, uninstall, and try the former.

0 Kudos
gcamp0730
Contributor
Contributor

I just did a fresh install of 20.04 and had a similar issue. I was able to get shared folders working by disabling and re-enabling them from VM > Settings > Options > Shared Folders. I didn't even have to restart the VM; the act of removing and re-adding the shared folder was enough.

rbottone
Contributor
Contributor

that didn't work for me, tried this with centos as guest os on a mac.  I see the shared folder but don't have write access from the guest os (centos).  I'm able to write when I escalate privilege with sudo.  I'm using vmware fusion version 12 on macos 11.0.1.  any ideas on how I can get this shared folder writeable?

0 Kudos
ptorelli
Contributor
Contributor

Just bought VMW12 and installed Ubuntu 20.04, been chasing sites trying to figure out how get this to work. No luck.

Tried every method of fussing with CDROM Drives, uninstalling/reinstalling open-vm-tools/open-vm-tools-desktop, unclicking/clicking sharing... nothing seems to work. "Install/Reinstall" is greyed out, always has been; but if I "apt remove" tools, it switches from Reinstall to Install so VMWare is checking.

I've confirmed it is running on Ubuntu via 'service' status, I'd cut and paste but that isn't working. 🙂

What a mess. This forum is just dozens of unanswered q's or "it just magically started working".

I

ptorelli
Contributor
Contributor

So it appears vmware tools cut/paste only works with gnome desktop. I downgraded from Ubuntu 20.04 sever to Ubuntu 18.04 desktop and copy/paste worked. But sharing didn't and I still got the annoying message in sharing next to the triangle saying "Sharing will start with vmware tools are installed and running..." which they were, but the wrong ones. I removed all open-vm-tools (using purge too ... see this: https://gaunacode.com/enabling-copy-paste-on-an-ubuntu-vm-on-vmware-workstation) then installed vmware tools from the Virtual Machines menu (which was no longer greyed out), and ignored the warnings to use open-vm-tools. After that shares and copy/paste worked.

However, if I remove all gnome packages (because I hate gnome) and switch to motif window manager (my preference), cut paste stops working.

So it appears there is a relationship between the window manager and copy/paste, and both MWM and headless login console don't work. You need to run gnome. Bummer.

normanstevens58
Contributor
Contributor

Unlike using VMWare Tools to enable Linux guest capabilities, the open-vm-tools package doesn't auto-mount shared VMWare folders. This can be frustrating in various ways, but there's an easy fix.

Follow the instructions on the following page:

https://gist.github.com/darrenpmeyer/b69242a45197901f17bfe06e78f4dee3

JohnAtl
Contributor
Contributor

I think Linux should be used as an adjective.

"It's Linuxed now."

"My computer is Linuxed. I keep installing and reconfiguring and this thing won't work that everyone else says works."

"It was working fine, now it's Linuxed."

 

ACC3141
Contributor
Contributor

I'm also a relative linux newbie... I had the same issue. Here are 2 important things that I found which might help.

First (and most important) the shared folders do NOT appear in an obvious place in the File UI. You have to click Computer, then mnt, then hgfs. In here you should see the folder that was shared from the host machine. 

Likewise you can get to it from TERMINAL via 'cd /mnt/hgfs' then do 'ls' and you should see your folder.

Second. The 'will not be available' message appears EVEN IF ITS WORKING. So, instead of telling you everything is fine, someone apparently thought it would be useful to tell you that if you didnt do that thing you actually did do then it would not be working now even though it IS working, but we are not going to tell you that because if you were a REAL linux guru you would obviously already know that and if you are not a real linux guru then you deserve to suffer...  Because, as near as I can tell, thats how Linux people think... 🙂

One other thing - if your host is a MAC you MIGHT need to go to System Preferences/Security and Privacy. Select the Privacy Tab (on the right), scroll down to VMWare Fusion, and make sure any checkboxes are set.

0 Kudos
Technogeezer
Champion
Champion


@ACC3141 wrote:

First (and most important) the shared folders do NOT appear in an obvious place in the File UI. You have to click Computer, then mnt, then hgfs. In here you should see the folder that was shared from the host machine. 

Likewise you can get to it from TERMINAL via 'cd /mnt/hgfs' then do 'ls' and you should see your folder.

Yes, the shared folders don't appear automagically in either GNOME's Files application or KDE's Doiphin file manager. You don't have to perform a full navigation of the disk structure to find them each time though. You can add /mnt/hgfs to "Places" in the Dolphin file manager or drag /mnt/hgfs to the sidebar in Files to create a bookmark. Both help get to them more easily.. 

It's a function of the Linux GUIs if they don't present this in a more accessible manner. Feeback to the KDE and GNOME developers would be appropriate.

Second. The 'will not be available' message appears EVEN IF ITS WORKING. So, instead of telling you everything is fine, someone apparently thought it would be useful to tell you that if you didnt do that thing you actually did do then it would not be working now even though it IS working, but we are not going to tell you that because if you were a REAL linux guru you would obviously already know that and if you are not a real linux guru then you deserve to suffer...  Because, as near as I can tell, thats how Linux people think... 🙂

I'm not sure exactly what "will not be available" message you're talking about here. But I do understand the frustration with Linux for the uninitiated. Considering that Linux is very UNIX-y, the following saying holds true: "When asked if UNIX is a user-friendly operating system, the answer is yes it is. It's just very selective about who its friends are.".

One other thing - if your host is a MAC you MIGHT need to go to System Preferences/Security and Privacy. Select the Privacy Tab (on the right), scroll down to VMWare Fusion, and make sure any checkboxes are set.


Please don't call the Mac a "MAC". That's like fingers scraping on.a chalkboard.

The privileges you should need to grant VMware Fusion in the "Privacy" tab of the "Security & Privacy" System Preferences panel are "Camera", "Microphone", "Accessibility",  "Screen Recording", and "Files and Folders".   You do not need "Full Disk Access". Don't grant Fusion more access than it needs. 

 

0 Kudos
JohnAtl
Contributor
Contributor

Thanks!

0 Kudos
mbdconsult
Contributor
Contributor

On a CentOS server, all I had to do was remove the drives via 'Sharing Settings', toggle 'Enable Shared Folders' and re-add the drives I wanted to share.

After that, the drives should be mounted in /mnt/hgfs

0 Kudos
Technogeezer
Champion
Champion

@mbdconsult although that works, it is not a persistent solution to the shared folders not mounting in the VM at boot time problem. You will have to disable/enable shared folders every time you reboot the VM.

A persistent solution is to add the following entry in /etc/fstab of the VM

vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0

 

0 Kudos
SantaCruzDad
Contributor
Contributor

> https://gist.github.com/darrenpmeyer/b69242a45197901f17bfe06e78f4dee3

Thank you - with the above info + the addition of the `-o nonempty` option I finally got shared folders working:

$ sudo mount -t fuse.vmhgfs-fuse .host:/ /mnt/hgfs -o allow_other -o nonempty

0 Kudos