andrewharden
Contributor
Contributor

Unable to connect to network in Windows 7 using Boot Camp partition via Fusion 2.0.4

Jump to solution

I know that the Windows 7 RC isn't officially supported, but I was just wondering if anyone had any ideas with regard to my current predicament. I'm running the 32-bit RC from a Boot Camp partition via Fusion on a unibody MacBook and whenever I'm in Fusion Windows can't connect to my network. Previously I had a file-based vm and it worked normally, and in Boot Camp I can get online with no issue. I switched to Boot Camp to see if the Aero effects would work (they did after I ran the Windows Experience Test). I have tried Bridged and NAT modes and no matter what Windows does not see my Wi-Fi network.

0 Kudos
1 Solution

Accepted Solutions
WoodyZ
Immortal
Immortal

At the present time Windows 7 in any release is not supported by Apple on the Boot Camp partition nor is it supported in any manner under Fusion.

Have a look in the Virtual Machine's .vmx configuration file and make sure that the Network Adapter is showing as "e1000" as in the following example.

ethernet0.virtualDEV = "e1000"

For help with the location of the Virtual Machine's .vmx configuration file have a look at or .

Note: You should make the edit while Windows is shutdown, not suspended and Fusion closed.

You can use TextEdit to edit the target Virtual Machine's .vmx configuration file and to locate the file...

VMware Fusion (menu bar) > Help > VMware Fusion Help > Navigating VMware Fusion > Using the Virtual Machine Library Window > Determine the location of a virtual machine's files

VMware Fusion (menu bar) > Help > VMware Fusion Help > Using the VMware Fusion Interface > Working with Virtual Machine Packages

View solution in original post

0 Kudos
11 Replies
WoodyZ
Immortal
Immortal

At the present time Windows 7 in any release is not supported by Apple on the Boot Camp partition nor is it supported in any manner under Fusion.

Have a look in the Virtual Machine's .vmx configuration file and make sure that the Network Adapter is showing as "e1000" as in the following example.

ethernet0.virtualDEV = "e1000"

For help with the location of the Virtual Machine's .vmx configuration file have a look at or .

Note: You should make the edit while Windows is shutdown, not suspended and Fusion closed.

You can use TextEdit to edit the target Virtual Machine's .vmx configuration file and to locate the file...

VMware Fusion (menu bar) > Help > VMware Fusion Help > Navigating VMware Fusion > Using the Virtual Machine Library Window > Determine the location of a virtual machine's files

VMware Fusion (menu bar) > Help > VMware Fusion Help > Using the VMware Fusion Interface > Working with Virtual Machine Packages

View solution in original post

0 Kudos
andrewharden
Contributor
Contributor

I don't see that line anywhere in the .vmx file, here's all the ethernet-related stuff that I found:

ethernet0.present = "TRUE"

ethernet0.connectionType = "nat"

ethernet0.wakeOnPcktRcv = "FALSE"

ethernet0.linkStatePropagation.enable = "TRUE"

ethernet0.addressType = "generated"

ethernet0.pciSlotNumber = "33"

ethernet0.generatedAddress = "00:0c:29:31:b3:55"

ethernet0.generatedAddressOffset = "0"

Should I just re-create the VM since it's running off of my Boot Camp partition?

0 Kudos
WoodyZ
Immortal
Immortal

If the line is not there then just put it there!

0 Kudos
oferrer
Contributor
Contributor

I just ran into this same issue- a quick search brought up this thread.

Everything is up and running now! Thanks!!

0 Kudos
pm149
Contributor
Contributor

Ditto me. This advice was great. I used Bean 2.0 to add the line, saved and I was away. Thanks so much.

Peter

0 Kudos
carlsonk
Contributor
Contributor

These instructions were very helpful. I did have to do one additional step. Inside of my boot camp vmx file "ethernet.Present" was set to False. I needed to set to TRUE and now is working great. Looking forward to release of Windows 7 and VMWare continued support.

0 Kudos
tstein1954
Contributor
Contributor

Thanks for this info. It was easy to find the file and review. Unfortunately, my .vmx file contains the e1000 line. So ... any other suggestions to get this to work? Interestingly, it worked fine with the beta of Win 7, but when I upgraded to the RC the network connection doesn't work. Thanks for any help you can give me.

0 Kudos
winstonAZ
Contributor
Contributor

Make sure that your connection type configuration is set to:

ethernet0.connectionType = "nat"

I had set mine to "bridged" in the process of troubleshooting and it didn't work until I changed it back to "nat"

0 Kudos
tstein1954
Contributor
Contributor

I think I've tried that, but I appreciate the tip.

Tom

0 Kudos
profees
Contributor
Contributor

Where Would one find this file (i can see all hidden files on the mac os) but cant find the file .vmx for bootcamp.

0 Kudos
WoodyZ
Immortal
Immortal

Where Would one find this file (i can see all hidden files on the mac os) but cant find the file .vmx for bootcamp.

If you read the reply that was marked as correct in this thread you will find the answer.

Have a look at:

0 Kudos