nospamboz
Enthusiast
Enthusiast

Ubuntu 7.10 (and other) mouse/display: Problem and solution

I think I've figured out the mouse and display problems that are being

experienced with Ubuntu 7.10 and maybe other Linux distributions.

It's basically an Xorg version problem stemming from lots of sources.

One source is that Xorg has apparently changed their version numbering

scheme. If you run the command "Xorg -version" in Ubuntu 7.04, you get:

X Window System Version 7.2.0

Release Date: 22 January 2007

X Protocol Version 11, Revision 0, Release 7.2

But in Ubuntu 7.10, you get:

X Window System Version 1.3.0

Release Date: 19 April 2007

X Protocol Version 11, Revision 0, Release 1.3

This change is confusing vmware-config-tools.pl in VMware Tools.

Moreover, the code in vmware-config-tools.pl that makes all Xorg

versions above 7.0 equivalent is not consistent.

Here's how to fix it. The line numbers refer to those in vmware-config-tools.pl

that comes with Fusion 1.1 RC (build 61385).

After you've installed VMware Tools, as root you have to "chmod u+w" the

file "/usr/bin/vmware-config-tools.pl" so you can edit it. Make the following changes.

Line 4961:

Change

$major = $1;

to

$major = $1 eq 1 ? 7 : $1;

Line 5130:

Change

} elsif ($major == 7 && ($minor >= 0 && $minor <= 2) &&

to

} elsif ($major == 7 &&

Line 5135:

Change

if ($minor eq 2) {

to

if ($minor ge 2) {

Save the new version, then run it (/usr/bin/vmware-config-tools.pl). Then restart X or reboot.

I hope the final release of Fusion 1.1 addresses these issues.

0 Kudos
21 Replies
Pelodark
Contributor
Contributor

I am having a display problem and load failure when I start Ubuntu 7.10 and using Leopard (for the first time tonight). Prior to the Leopard upgrade Ubuntu 7.10 started up just fine. I get the following error:

The display server has been shut down about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again on display 0.

Any hints?

0 Kudos
mykmelez
Enthusiast
Enthusiast

Yup, this worked great for me. Thanks for the tip!

0 Kudos
rcardona2k
Immortal
Immortal

You should start a new discussion than reply to a configuration tip (or did this happen only after apply the configuration tip?)

BTW, your tip worked great for me too! I noticed the X mismatch, but I was waiting for VMware to figure out the details. Gutsy's rendering has improved nicely. Thanks Smiley Happy

0 Kudos
Mainstay
Contributor
Contributor

This worked for me as well. Specifically, it addressed the issue of mouse artifacts and scrolling.

0 Kudos
scritch
Contributor
Contributor

It fixed my problem too. Thanks a lot.

0 Kudos
PixelBitch
Contributor
Contributor

Worked perfectly for me, also.

0 Kudos
EmmEff
Contributor
Contributor

You're a genius! Thanks Smiley Happy

0 Kudos
nospamboz
Enthusiast
Enthusiast

I hope the final release of Fusion 1.1 addresses these issues.

Well, it didn't. That's... disappointing.

The patch as described works in the final Fusion 1.1 release, though.

0 Kudos
HPReg
VMware Employee
VMware Employee

Sorry guys, sounds like this one fell through the cracks Smiley Sad

I'm forwarding it to the Guest Components team at VMware to raise the awareness of the issue.

0 Kudos
Yaztromo
Enthusiast
Enthusiast

I

After you've installed VMware Tools, as root you have to "chmod u+w" the

file "/usr/bin/vmware-config-tools.pl" so you can edit it. Make the following changes.

This can be better automated with diff and patch. I've attached a unified diff to make applying this change easier.

To use this patch, download it to your home folder (or somewhere convenient), do the chmod as above, and do the following:

cd /usr/bin
patch < ~/vmware-config-tools.patch

This will apply all of the modifications you suggested in your post. I hope it helps!

Yaz.

0 Kudos
theltemes
Contributor
Contributor

I just tried this fix and it worked for me too.

0 Kudos
Barrocal
Contributor
Contributor

The patch works great !

0 Kudos
Pelodark
Contributor
Contributor

Patch works for me as well. Many thanks.

0 Kudos
scritch
Contributor
Contributor

I found that if I add vmmouse.present = "FALSE" to my .vmx file, the problems come back.

Removing it makes everything work again but well I hope that VMware engineers fix also this problem.

0 Kudos
sprotsman
Contributor
Contributor

I'm having this same problem after updating OpenSUSE 10.3:

The display server has been shut down about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again on display 0.

Worked fine before I ran the update tool. I tried the patch in hopes that it would fix my issue but it didn't.

OS: 10.4.11

VMWare Fusion: 1.1

VMWare Tools: 7.6.2-62537

Any suggestions?

0 Kudos
sprotsman
Contributor
Contributor

Yay! I found a solution. This was from a suggestion off the Parallels forum for an Ubuntu 7.10 user and this worked with my OpenSUSE 10.3 installation. I booted into text mode so that I could actually log in to my VM:

$ sudo vim /etc/X11/xorg.conf

In the 'Device' insert this line:

Option "LVDSBiosNativeMode" "false"

Save and exit. Run 'startx' from the command prompt. Re-install VMWareTools, reboot and back to the good stuff! For whatever reason, font rendering even looks better now too!

0 Kudos
nospamboz
Enthusiast
Enthusiast

The display server has been shut down

Are you absolutely sure about what you did? The "shut down" problem has

been examined in another thread, without resolution. I've added another

comment there regarding your suggestion.

http://communities.vmware.com/thread/109593

You say you re-installed VMware tools after modifying xorg.conf, but

doing so should have overwritten the file and undone your changes.

In fact, if you re-installed without re-doing the patch described above,

you effectively did nothing, since re-installing undoes the patch as well.

Are you sure you didn't simply go from "Thousands" to "Millions" of colors,

which rebooting your Mac would have done?

0 Kudos
sprotsman
Contributor
Contributor

Yes, absolutely sure. Those are the steps I followed to get a working X again on OpenSUSE 10.3. You are correct, xorg.conf did get overwritten. I've compared the last two xorg.conf files and they are different. Yes, I'm sure I didn't switch my color depth.

I also have Ubuntu 7.10 running and it is fine too.

0 Kudos
sprucio
Contributor
Contributor

Thank you so much for posting this.

I've spent about a week now with VMware support trying to figure this out. Today, I got an e-mail stating that they do not support Ubuntu 7.10 and closed the case on me without even asking.

After I got home, I installed Ubuntu 6.10 to try and and resolve the problem. Without even installing VMware-tools, I was able to use the mouse without it being choppy along with the scroll.

Again, thank you for your hard work. It's really well appreciated.

0 Kudos