mlkovacs
Contributor
Contributor

Migrating a VM from Fusion 10 to Fusion 12

I'd like to share my experience (Nov 2021), which was terrible, but with a good ending.

Challenge: Migrate a Win 10 VM from Fusion 10.1.6 on an older MacBook Air (High Sierra 10.13.6 - Intel Core i7) to a newer MacBook Pro (Big Sur 11.5.2 - Intel Core i5).

I'm fairly tech savvy - I manage a technical support department. VMWare support was awful. They would not open a case for me, despite having an enterprise account. I have such a bad taste in my mouth for VMWare after this, especially after we have spent lots of $$$ on VMWare products in the last year alone in a +20k node network.  

Solution:

1. I upgraded my old Mac from Fusion 10.1.6 to Fusion 11 using a license from our enterprise account. I went to Fusion 11.5.3 which is the highest Fusion version that is compatible with High Sierra 10.13.6. High Sierra 10.13.6 is the last version available at this writing. Note: VMWare's compatibility matrix was not detailed enough, as I needed to install multiple Fusion versions to get it right (11.5.1, 11.5.2 and finally 11.5.3).
2. I installed Fusion 11.5.3 on the destination Mac. It's important to note that I initially had Fusion 12.2.1 but it would not import any of my VMs. So, the key is to have the source and destination MACs on the same Fusion version.
3. I exported the Win 10 VM on the source Mac to OVF on an external drive. This took several tries - Fusion was very flaky. I also tried copying the VM (*.vmwarevm).
4. I imported the OVF onto the new Mac. This failed (error: VMDK). I tried again, and it worked the 2nd time.
5. The VM imported OK in Fusion 11.5.3, but even after accepting the prompts to update the VM, the VM wouldn't start nicely on Fusion 11.5.3 (OS: Big Sur 11.5.2). There were memory problems and other various issues (resolution, mitigations, BSOD, etc). I tried a recommended VMWare update to 11.5.7, but that failed because 11.5.7 is not compatible with Big Sur 11.5.2.
6. I then installed Fusion 12.2.1 on the new Mac (Big Sur 11.5.2). I think that because I made a valiant effort to start the Win 10 VM under Fusion 11.5.3, there was enough to the VM for Fusion 12.2.1 to open the VM successfully. I'm using this VM as I type this.

I hope this post helps someone.

0 Kudos
1 Reply
wila
Leadership
Leadership

Hi,

Glad to hear you got there in the end.

Can't comment on the "not able to open a support case" part, I don't work for VMware.

The "mistake" (if you can call it that) was exporting to OVF. That's a step you can skip.
The easy way would have been:

- Install VMware Fusion 12.2 on the new machine
- Shut down -not suspend- the VM at the old machine. Commit any snapshots you might have
- Copy the old VM to the new machine
- Use "File -> Open" on the new machine to register the VM
- Start the VM -> Fusion will ask "Did you copy or move" ---> answer move

Moderator note: I moved your post from a reply at "Not Enough Physical Memory" error on MacOS Big Sur Beta 1" thread to a new post.

Hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos