Arif_Datoo
Contributor
Contributor

MacBook Air and MacBook Pro Update 2.0 - Seems to break Fusion 5.0.1

I intsalled the above update this morning (http://support.apple.com/kb/DL1609) and my working copy of an Ubuntu 12.10 32bit VM has stopped working. I deleted the copy and tried installing a new one but have the same issues.

I attach a screenshot of the Error Dialog and a VMWare Dump.

Screen Shot 2012-11-09 at 13.31.45.png

Tags (1)
0 Kudos
15 Replies
avanish321
Expert
Expert

Perform the steps as described in the Article

If issue persists, reinstall latest build fusion .  Reinstalling fusion wont delete your existing vms

Cheers! Avanish
0 Kudos
WoodyZ
Immortal
Immortal

If this update is responsible then it could be a real issue for others as well so I sent a PM to a particular VMware employee that will probably follow up on this.

0 Kudos
avanish321
Expert
Expert

This error usually occurs if an update is made on the host while the guest VM was in suspended mode or if it was running.

Best practice is to ensure that guest is shut down while doing any updates on the host.

If the vm was shut down then the cause is something else.

Cheers! Avanish
0 Kudos
dariusd
Leadership
Leadership

Hi Arif Datoo, and welcome to the VMware Communities!

That looks like an ugly failure.  I don't think you'll be able to address it by reinstalling Fusion, and you've already tried creating a new VM... it sure looks like the update is incompatible with Fusion in some way, unless your hardware has just chosen that particular instant to start failing (unlikely!).  The update claims to improve graphics performance, and the crash occurs during a graphics operation, so... hmmm...

I'll pass this over to the Fusion graphics folks to investigate urgently.

Thanks for letting us know (and for including the dump)!  We'll get back to you as soon as we have more information.

Cheers,

--

Darius

0 Kudos
WoodyZ
Immortal
Immortal

Darius, thanks for following up! Smiley Wink

0 Kudos
dariusd
Leadership
Leadership

Hi again Arif Datoo,

Please try this: With your VM powered off, go into the Virtual Machine > Settings, then choose Display, and turn off the Accelerate 3D Graphics option.  Then close the Settings window and try to power on your VM.

Please let us know if that allows you to use your VM again!  (It would be without 3D acceleration, of course, until we can get the problem fixed.)

Thanks,

--

Darius

0 Kudos
dariusd
Leadership
Leadership

Thanks muchly for the heads-up, WoodyZ!  There's nothing like a good hearty crash in the guts of a host driver to get the day started!  :smileydevil:

--

Darius

0 Kudos
WoodyZ
Immortal
Immortal

Yeah, I felt bad about sending it to you so early.  However If turning off 3D acceleration doesn't work around this for the short run then I know you guys will want to address this quickly as there's nothing worse then a OS update that effectively cripples one's app.

0 Kudos
admin
Immortal
Immortal

I just applied the Apple update and reproduced this problem with Ubuntu 12.10 desktop.

Disabling 3D worked around the issue.

I'm using a 2012 15" Mac Book Pro with Retina display.

Thank you all for the notification on this one.

0 Kudos
RaddishIoW
Contributor
Contributor

Just had the same issue on running a 3D game in the VM. I created a support request before I found this thread... Uploaded my dump to the request. Request no.: 12244498911

0 Kudos
westparkguy
Contributor
Contributor

Ran into the same issue.

2012 MacBook Pro with standard display, Fusion 5.0.2., and Ubuntu 12.10

Turning off the Accelerate 3D Graphics option solved the problem for me.

0 Kudos
dlhotka
Champion
Champion

There's reports of other graphics issues with the update as well...for example:

http://www.ubergizmo.com/2012/11/retina-macbook-pros-might-be-seeing-drop-in-frame-rate-after-efi-up...

Looks like Apple released something that's not fully baked.

FWIW, I believe I'm running 5.0.2 and Update 2.0 on a Retina without experiencing the issue (as software update shows no updates available, I assume it's been installed).  This is a fresh (this week) clean 10.8 install with a Win7 guest.

0 Kudos
WoodyZ
Immortal
Immortal

Looks like Apple released something that's not fully baked.

Oh come on now, they wouldn't do that! Smiley Wink  Apple Maps, anyone! :smileygrin:

Message was edited by: WoodyZ - Originally posted, Nov 14, 2012 11:40 AM.

0 Kudos
dlhotka
Champion
Champion

LOL - yeah, pie with underdone apples just isn't quite right is it? 😉

I wonder if there's the issue is with upgraded or migrated machines and not with clean installs (some leftover bit that blows things up).

Maybe I just got lucky!

0 Kudos
asif10
Contributor
Contributor

I was also having the exact same issue. I have the 2012 15" Mac Book Pro with Retina display.

I tried the disabling 3D Graphics. The only issue I had was my ubuntu which was running in vmware was incredibly slow (I assigned the machine with 4gb memory).

So i reinstalled Mountain Lion OSX, one good thing about Apple was it didn't wipe any of my content. The installation took 20 mins from the apple store. This essentially rolled back my 2.0 mac upgrade. Now Ubuntu is running fine with 3d graphics enabled.

In case anyone else is interested in rolling back Mac 2.0 update.

Asif

0 Kudos