mckinneycm
Contributor
Contributor

Keyboard and Mouse not working in VMWare Fusion guests

Jump to solution

I installed Mac OS X Mojave Beta 5, and now when I start a VMWare Fusion guest (Windows 10) my keyboard and mouse are not working in the guest. When I was using OS X Mojave Beta 4, they worked fine. Any thoughts on a solution to get my keyboard and mouse to start working again?

1 Solution

Accepted Solutions
RickShu
VMware Employee
VMware Employee

Hi mckinneycm,

Please check System Preferences ==>Security&Privacy==>Privacy==>Accessibility, make sure you have added Fusion into the list. You need to quit and restart Fusion to take effect.

Regards,

-Rick

View solution in original post

35 Replies
RickShu
VMware Employee
VMware Employee

Hi mckinneycm,

Please check System Preferences ==>Security&Privacy==>Privacy==>Accessibility, make sure you have added Fusion into the list. You need to quit and restart Fusion to take effect.

Regards,

-Rick

mckinneycm
Contributor
Contributor

Thank you so much! You're a lifesaver.

0 Kudos
PeterSelin
Contributor
Contributor

Thanks so much, same issues on Mojave and Fusion 10.1.3.

I had to delete Fusion from the list in security and reads it with Fusion not started

kreid4
Contributor
Contributor

Thank you

0 Kudos
ITYT
Contributor
Contributor

Perfect, thank you, mine was there but had become un-ticked during the Mojave upgrade.

carlospicywiene
Contributor
Contributor

Thank you also. I thought I was looking at a downgrade from Mojave to High Sierra but found that the VMWare option had become deselected/unticked in my privacy settings after I had upgraded my Macbook Pro (host) to Mojave. For anyone else with this issue my set-up is

* Macbook Pro late 2014 (now running Mojave)

* Fusion 10.3.1

* 2 x VM's (1 x High Sierra and 1 x Windows 10) ... never at the same time Smiley Happy

Symptom was that either VM would start OK (High Sierra would present a grey screen with Admin and Guest login options and the Windows 10 VM would present the only the start screen with no login option.) The mouse would move around OK but wouldn't do anything when I clicked around nor use the keyboard.

I made the Security/Privacy changes as per this thread and now I'm back to work Smiley Happy

0 Kudos
philmcpherson
Contributor
Contributor

That is the fix! Much thanks!

0 Kudos
Mikkato
Contributor
Contributor

Hi RickShu,

I have done your recommended magic with Security/Accessibility but didn't get the full result: keyboard still unavailable.

I have copied physical PC (Windows 10 64-bit) using latest VMWare vCenter Converter and add files to VM Fusion Library by clicking on .vmx file.

In order to proper operation with VM, I've checked all hardware elements: network, memory and CPU type/core to be fit with original PC. Mouse pointer are moving and acting as usual, but KBD has no reactions. Any suggestions?

PS. VMWare Fusion Version 10.1.3 (9472307)

ramieret
Contributor
Contributor

Hi,

This is exactly this !  I did what your propose and it worked.

I had : Mac OS Moyave 10.14 and  VMWare Fusion 8.5.10.

Thanks a lot !

Tanneguy

0 Kudos
xpKay
Contributor
Contributor

I've never checked this in Security & Privacy before - why would it be necessary now?

Will I have to re-install Fusion or upgrade it?

0 Kudos
wila
Immortal
Immortal

Hi,

why would it be necessary now?

Because macOS Mojave added extra security protections that require the user to make manual changes in order for VMware Fusion to keep on working like it used to.

Normally, you don't have to re-install, but you should enable VMware Fusion under (apple menu) System Preferences -> Security & Privacy -> Accessibility

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
xpKay
Contributor
Contributor

I did check these settings and yes, sure enough everything works again - thanks and also thanks for the understanding WHY.

0 Kudos
erdemayalp
Contributor
Contributor

Great. It worked for me. Thanks a lot.

0 Kudos
Dixter2018
Contributor
Contributor

This worked great!  Upgraded to Mojave and couldn't login to my VM.  Addressed the issue as described here, worked perfectly.

0 Kudos
Thicot
Enthusiast
Enthusiast

While this solution works to solve this issue, it is not a viable and secure solution. Why on earth would it be the virtual machine which should be authorized to control the host computer instead of the opposite? There is something very wrong with this settings as it allows the virtual machine to force the host to go in hibernation when you want it to be on continuously.  So if somebody from Vmware could read this and tell us why is the guest controlling the host just to get access to the guest, I am all ears/eyes!

0 Kudos
ecombs
Contributor
Contributor

I've done the suggested, even went as far as rebooting the machine, but the problem for me still persists. Although maybe under different circumstances. We have 3 VMs running two Macs and 1 Windows. The Windows works fine, and 1 of the 2 Macs works fine. The second Mac though just refuses to detect any input from the mouse or keyboard.

0 Kudos
MyVMbroke
Contributor
Contributor

Thank this awesome. So obvious - I reinstalled; and uninstalled - DUH.

Thanks again,

0 Kudos
JackOnTheMac
Contributor
Contributor

Hi Rick,

I was having the same problem, and this seems to have fixed it.

JackOnTheMac

BrianPolka
Contributor
Contributor

Quick note just in case someone was running into the same issue as me. I noticed that VMWare Fusion was listed on the Privacy section under Accessibility, but I was still having issues. Removed and added it again with no luck . Took me longer than I care to admit to realize that it had a checkbox that had to be CHECKED. Once I checked the box and restarted the application, all was good. Thanks for the help!

0 Kudos