CyberNewbie
Contributor
Contributor

Fusion 15.5.5 Suspends in Sleep Mode

Jump to solution

Hi guys
I am experiencing after upgrading to 15.5.5 version that if my iMac goes into sleep mode then Fusion suspends the VM. I have tried to fix the problem by adding "suspend.disabled = "TRUE" in the VM vmx. file but it didn´t help at all. Any advice? I should mention that I haven´t got this problem with the older version of Fusion!

1 Solution

Accepted Solutions
CyberNewbie
Contributor
Contributor

Updating to my problem

The problem was not with the VM but with my MAC  After a restart, the "Log after....minutes of inactivity" option was turned on. This made that every time when my Mac was going into sleep mode after 5 minutes the User was logged out and therefore turning off everything Fix it by turning off the option  Now my Ubuntu server is up running in the sleep mode even if is soft or hard  all

Thank you all for taking the time to help me:)

Really appreciated

View solution in original post

0 Kudos
10 Replies
scott28tt
VMware Employee
VMware Employee

11.5.5 is the latest Fusion version.

What do you expect Fusion to be doing instead?


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
CyberNewbie
Contributor
Contributor

I have a server running in a VM so before the upgraded the VM was able to work in the background even if the iMac was sleeping. I bassically want the VM to be active even if my Mac is sleeping.

0 Kudos
dariusd
Leadership
Leadership

Interesting.

If you launch a Terminal window on the host and run caffeinate in that, does it work around the problem?  (Just press Ctrl+C to terminate the caffeinate program if you want your Mac to be able to sleep again.)

We did make some changes to the Mac host power-management aspects of Fusion in version 15.5.5, but I would not have expected a substantial change in behavior to result from the code changes that I have seen.  Weird and perplexing.

--

Darius

You can't do that - a sleeping host suspends all active processes.

What you can do is change the energy preference on the host to 'prevent sleep when screen blanks' which will do exactly what it says - blank the screen, keep the machine on, and the VM running.

CyberNewbie
Contributor
Contributor

Unfortunately that doesn´t work either Smiley Sad dariusd

0 Kudos
CyberNewbie
Contributor
Contributor

I do have made those options but still, VM goes in suspend mode. dlhotka

0 Kudos

That shouldn't be happening.  If the machine doesn't sleep, then the VM won't suspend. 

Have you fiddled with pmset via terminal?

dariusd
Leadership
Leadership

Just checking something: How does your Mac go to sleep?  Is it sleeping because it has been left idle (called a "soft sleep") or is it being sent to sleep from the menu bar's (Apple Menu) > Sleep ("hard sleep")?  A soft sleep can be blocked by applications such as "caffeinate" (by intent) or can be blocked by other applications for other reasons; A hard sleep can only be postponed for up to 30 seconds, and can not be blocked, so if you are using the Sleep menu selection, this is expected behavior.

If your Mac properly goes to sleep, the virtual machine will stop running, regardless of which version of Fusion you are running, so it sounds more like the prior version of Fusion was preventing your Mac from actually going to sleep (allowing only the display to sleep) and the newer version is no longer inhibiting system sleep.

The command pmset -g log will dump a lot of information about the recent history of the system's power-management state.  Examining that log might provide some clues.  It may help to temporarily downgrade to the older version of Fusion and compare the pmset logs from the two different versions once you reproduce the difference in behavior.

--

Darius

wila
Immortal
Immortal

Hi,

One thing I'm missing is what kind of VM you're running? Windows/Linux/macOS/something else, server version, desktop, ...?

Did you install VMware Tools and are you passing the power state to the VM?

Another thing to check also is the power settings of the VM itself. If the VM is set to go to sleep after a certain time then it will suspend as well.

That is expected behavior and can cause some confusion at times. The solution for that is to make sure the VM does not go to sleep.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
CyberNewbie
Contributor
Contributor

Updating to my problem

The problem was not with the VM but with my MAC  After a restart, the "Log after....minutes of inactivity" option was turned on. This made that every time when my Mac was going into sleep mode after 5 minutes the User was logged out and therefore turning off everything Fix it by turning off the option  Now my Ubuntu server is up running in the sleep mode even if is soft or hard  all

Thank you all for taking the time to help me:)

Really appreciated

0 Kudos