mring5150
Contributor
Contributor

Fusion 11 on Monterey 12.1

Jump to solution

Have been running VMware Fusion 11.0 w/multiple VMs on Big Sur w/o any issues.  I did my annual laptop refresh with a new version of macOS Monterey 12.1.  I haven't been successful in installing VMware Fusion 11.0.  It doesn't seem to take, and then when it does, I get the following error.  See attached photo.  Any suggestions?  

0 Kudos
1 Solution

Accepted Solutions
Technogeezer
Expert
Expert

Fusion 11 is not supported on Big Sur or Monterey. I’m surprised you haven’t had any issues.

Not surprising that Fusion 11 won’t install on Monterey since it uses deprecated kernel extensions and does not understand all the changes made to the core OS in Big Sur and later. Fusion 12 was built with these macOS changes in mind. 

You need to,upgrade to Fusion 12 which supports Monterey.  If using it for personal (non-commercial) purposes, you can register for a free personal use license of Fusion 12 Player. 

View solution in original post

4 Replies
Technogeezer
Expert
Expert

Fusion 11 is not supported on Big Sur or Monterey. I’m surprised you haven’t had any issues.

Not surprising that Fusion 11 won’t install on Monterey since it uses deprecated kernel extensions and does not understand all the changes made to the core OS in Big Sur and later. Fusion 12 was built with these macOS changes in mind. 

You need to,upgrade to Fusion 12 which supports Monterey.  If using it for personal (non-commercial) purposes, you can register for a free personal use license of Fusion 12 Player. 

View solution in original post

dlhotka
Champion
Champion

I am as well, I didn't think Fusion 11 ran at all on Big Sur.

Technogeezer
Expert
Expert

@dlhotka I'm wondering if @mring5150 had Fusion 11 installed on the Mac at the time of the upgrade to Big Sur. If so, I also wonder if  nothing was done to uninstall or invalidate the kexts at the time of the macOS upgrade. It may be pure luck that it runs even though VMware never supported or tested the kexts on Big Sur.  

mring5150
Contributor
Contributor

Sorry for taking so long to reply to all.  Yes, I did have Fusion 11 installed at the time of the upgrade to Big Sur.  I typically clean my HD and do a clean install of the OS, but didn't at that time.  I did this time, however, thus the issue.  Thanks to all for your assistance and guidance.  Now on to the downloads!

0 Kudos