Jacealot
Contributor
Contributor

Fusion 11 on 10.14 Mojave - Cannot power on virtual machine: Too many virtual machines.

Jump to solution

Hi,

I just upgraded from Fusion 10 to 11 on 10.14 Mojave. First all was working fine, but after a restart I'm not able to start any VM. I keep on getting the message "Cannot power on virtual machine: Too many virtual machines.".

Any idea how I'm able to fix this?

Thanks,

Jason

Tags (3)
1 Solution

Accepted Solutions
nancyz
VMware Employee
VMware Employee

Could you please try the following steps:

1.Uncheck 'Start Docker when you log in' under Docker -> Preferences

2.Reboot your macOS without checking 'Reopen windows when logging back in'

3.Launch Fusion and power on the VMs.

Hope that could help.

View solution in original post

29 Replies
sadcup
Enthusiast
Enthusiast

Hi, Jason

There are some kernel extensions and process are needed before running a virtual machine.

Would you please check the process and kext status by

Open Terminal

Input

ps aux | grep vm

(This would list all of the vm related process, usually several vmnet-*, VMware Fusion and etc.)

Input

  kextstat | grep vmware

(This would list all fusion kexts, usually 4 kexts will be listed.)

If the previous results does not meet the usual case, maybe the kext was blocked by macOS.

Open System Preferences > Security & Privacy > General

There may an Allow button and it's needed to be pressed.

0 Kudos
Jacealot
Contributor
Contributor

Here is the output for both inputs:

Jasons-MyLasps-MacBook-Pro:~ jhermans$ ps aux | grep vm

root              1780   0.0  0.0  4377456   6728   ??  Ss   11:49AM   0:00.28 /Library/PrivilegedHelperTools/com.vmware.VMMonHelper

root              1083   0.0  0.0  4361952   2936   ??  Ss   11:48AM   0:00.86 /Applications/VMware Fusion.app/Contents/Library/vmware-usbarbitrator

root              1081   0.0  0.0  4303996    340   ??  Ss   11:48AM   0:00.01 /Applications/VMware Fusion.app/Contents/Library/vmnet-dhcpd -s 6 -cf /Library/Preferences/VMware Fusion/vmnet8/dhcpd.conf -lf /var/db/vmware/vmnet-dhcpd-vmnet8.leases -pf /var/run/vmnet-dhcpd-vmnet8.pid vmnet8

root              1079   0.0  0.0  4299556    256   ??  Ss   11:48AM   0:00.00 /Applications/VMware Fusion.app/Contents/Library/vmnet-netifup -s 6 -d /var/run/vmnet-netif-vmnet8.pid vmnet8 vmnet8

root              1077   0.0  0.0  4351180   5080   ??  S    11:48AM   0:00.07 /Applications/VMware Fusion.app/Contents/Library/vmnet-natd -s 6 -m /Library/Preferences/VMware Fusion/vmnet8/nat.mac -c /Library/Preferences/VMware Fusion/vmnet8/nat.conf

root              1074   0.0  0.0  4296828    340   ??  Ss   11:48AM   0:00.01 /Applications/VMware Fusion.app/Contents/Library/vmnet-dhcpd -s 6 -cf /Library/Preferences/VMware Fusion/vmnet1/dhcpd.conf -lf /var/db/vmware/vmnet-dhcpd-vmnet1.leases -pf /var/run/vmnet-dhcpd-vmnet1.pid vmnet1

root              1071   0.0  0.0  4315940    256   ??  Ss   11:48AM   0:00.00 /Applications/VMware Fusion.app/Contents/Library/vmnet-netifup -s 6 -d /var/run/vmnet-netif-vmnet1.pid vmnet1 vmnet1

root              1067   0.0  0.0  4387280   6880   ??  S    11:48AM   0:00.04 /Applications/VMware Fusion.app/Contents/Library/vmnet-bridge

root               102   0.0  0.0  4291856   4160   ??  Ss   11:46AM   0:00.02 /Library/PrivilegedHelperTools/com.docker.vmnetd

jhermans          6195   0.0  0.0  4268036    816 s000  S+    2:11PM   0:00.00 grep vm

Jasons-MyLasps-MacBook-Pro:~ jhermans$ kextstat | grep vmware

   179    1 0xffffff7f84bac000 0x11000    0x11000    com.vmware.kext.vmci (90.8.1) 85083EFB-813A-3615-9B1A-D9D3D53973EB

   180    0 0xffffff7f84bbd000 0x16000    0x16000    com.vmware.kext.vmnet (1012.03.84) 7E217A8E-31B9-32C9-88E1-B6360AF8C5DD

   181    0 0xffffff7f84bd3000 0x13000    0x13000    com.vmware.kext.vmx86 (1012.03.84) 02318E44-ACC9-396B-8C1B-44C34296F355

   182    0 0xffffff7f84be6000 0x7000     0x7000     com.vmware.kext.vmioplug.18.1.0 (18.1.0) 4DFEF827-20CD-3C1B-A312-63CEE84F1C0E

Jasons-MyLasps-MacBook-Pro:~ jhermans$

This sees to be correct. I don't have any messages under "Open System Preferences > Security & Privacy > General".

0 Kudos
nancyz
VMware Employee
VMware Employee

Hi Jacealot ,

Did you install docker on you macOS? Could you disable docker and see if this issue still exists? Thanks.

0 Kudos
ufkel
Contributor
Contributor

I see the very same error message here on 10.13.6 High Sierra, after upgrading from Fusion 10 to Fusion 11. So it seems not Mojave related, but Fusion 11 related.

Jacealot
Contributor
Contributor

Yes i have docker installed on macOS. But I have disabled it and still have this problem.

In the past I found out that VirtualBox doesn't play nice with Fusion, but that has already been removed.

0 Kudos
ufkel
Contributor
Contributor

Same here. Docker is installed but not running, VirtualBox is not installed at all.

0 Kudos
Miek1967
Contributor
Contributor

Same problem, and I have not had either Virtualbox or Docker installed.

0 Kudos
Funkybob
Contributor
Contributor

Hi I get the same error message and opened a support ticket. Jus had  call with a support technician. We was able to fix the issue by adding Vmware Fusion to accesebility in the system preferences under Security -> Privacy. After a restart I was able to start my VMs. Also I need to update the VMs to version 16. Hope this helps.

Best reagrds

Robert

Miek1967
Contributor
Contributor

I already had VMware Fusion added in accessibility setting, probably added by the installer. So all I did was a reboot and it made It work Smiley Happy I don't know why I didn't hink about that.....

0 Kudos
abiggs
Contributor
Contributor

I have this same issue. I also have Docker for Mac installed. I disabled it on start up, rebooted, and now VMware 11 works. Must be low-level conflict.

Mikero
Community Manager
Community Manager

One reason for this is if there are 2 different hypervisors trying to run at once. Apple doesn't like that anymore and blocks the behavior.

Docker for Mac uses HyperKit (Apple's hypervisor framework), so when it's running it will prevent other VMs from starting.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
abiggs
Contributor
Contributor

Bummer. Smiley Sad

0 Kudos
nancyz
VMware Employee
VMware Employee

Could you please try the following steps:

1.Uncheck 'Start Docker when you log in' under Docker -> Preferences

2.Reboot your macOS without checking 'Reopen windows when logging back in'

3.Launch Fusion and power on the VMs.

Hope that could help.

View solution in original post

Jacealot
Contributor
Contributor

One reason for this is if there are 2 different hypervisors trying to run at once. Apple doesn't like that anymore and blocks the behavior.

Docker for Mac uses HyperKit (Apple's hypervisor framework), so when it's running it will prevent other VMs from starting.

That is just a pain .... why did they do that?

0 Kudos
Miek1967
Contributor
Contributor

I had to try this to see if Apple really blocks this, so I fired up VMware Fusion 11 launched Windows 10 and then I started Parallels and there I also launched Windows 10 no messages about to many virtual machines... So I wonder if docker does something else?

0 Kudos
grahamberks
Contributor
Contributor

After also getting high CPU usage on VM11 I've gone back to VM10

This has resulted in

1) no high CPU usage

2) I can run Docker For Mac at the same time ( guessing VM11 uses HypeKit ??? )

Anyway VM11 certainly ain't ready for my usage.

0 Kudos
hexagonmimosa
Contributor
Contributor

Oddly enough, one of my machines has this issue while the other does not. I'm running the same build of VMWare Fusion across both machines and they're both running the identical version of macOS Mojave.

VMWare team, please let me know if I can provide more information to help diagnose this issue. It's extremely annoying.

0 Kudos
grahamberks
Contributor
Contributor

Mine was on a 2018 MBP if that helps narrow it.

0 Kudos
Mikero
Community Manager
Community Manager

So digging into the bug on our end some more... We don't think it's deliberate on Apple's part.

What we're seeing is this:

  • If you start a HyperKit app (Docker for Mac) before starting a Fusion VM, the 'too many vms' error presents itself.
    • If you quit the HyperKit app, Fusion still fails to launch a VM
  • If you reboot, and run Fusion before starting another HyperKit app, everything is fine.
    • You can launch a HyperKit app without problems, and have it running with a Fusion VM side-by-side

So each reboot, it's a matter if hyperkit starts before a Fusion VM runs or not will determine if you'll hit the condition.

This is why NancyZ's suggestion of 'disable docker from starting at boot' is recommended while we work with Apple to sort out the root cause.

-
Michael Roy - PM/PMM: Fusion & Workstation