PuddletownJim
Contributor
Contributor

Cannot connect virtual device ide0:0

I am having trouble getting this to work.  From what I have read this is an IDE driver issue but I am not sure if I should approach this from the vmx file, drivers in vmware or from the windows side and could use some help.  Here is some relavent information:

  • I am using Fusion 4.1.1 on a 15" MacBook Pro- I have tried this on a Mac Mini and had the same error. 
  • I used the "Migrate your PC" option to import a Dell Laptop running Windows XP Pro, which completes successfully.
  • Both machines are fully patched with the latest OS updates
  • Upon launching the virtual machine from Fusion I get the error message " Cannot connect virtual device ide0:0. No corresponding device is  available on the host. Would you like an attempt to be made to connect  this virtual device every time you power on the virtual machine?"
  • The error message that Windows subsequently displays is a STOP: 0x0000007B error, here is the screen shot:
  • 2018437.png
  • Here is the vmx file:
    • .encoding = "UTF-8"
      config.version = "8"
      virtualHW.version = "8"
      memsize = "512"
      MemAllowAutoScaleDown = "FALSE"
      displayName = "Windows XP Professional"
      guestOS = "winxppro"
      sound.present = "TRUE"
      sound.filename = "-1"
      sound.autodetect = "TRUE"
      usb.present = "TRUE"
      ethernet0.present = "TRUE"
      ethernet0.addressType = "generated"
      ethernet0.connectionType = "nat"
      ethernet0.startConnected = "TRUE"
      ide0:0.present = "TRUE"
      ide0:0.autodetect = "TRUE"
      ide0:0.filename = "auto detect"
      ide0:0.deviceType = "cdrom-raw"
      scsi0.present = "TRUE"
      scsi0.virtualDev = "buslogic"
      scsi0:0.present = "TRUE"
      scsi0:0.fileName = "Windows XP Professional.vmdk"
      mks.enable3d = "TRUE"
      vmci0.present = "TRUE"
      buslogic.noDriver = "FALSE"
      ehci.present = "TRUE"
      pciBridge0.present = "TRUE"
      tools.upgrade.policy = "upgradeAtPowerCycle"
      pciBridge4.present = "TRUE"
      pciBridge4.virtualDev = "pcieRootPort"
      pciBridge5.present = "TRUE"
      pciBridge5.virtualDev = "pcieRootPort"
      pciBridge6.present = "TRUE"
      pciBridge6.virtualDev = "pcieRootPort"
      pciBridge7.present = "TRUE"
      pciBridge7.virtualDev = "pcieRootPort"
      tools.syncTime = "TRUE"
      pciBridge4.functions = "8"
      pciBridge5.functions = "8"
      pciBridge6.functions = "8"
      pciBridge7.functions = "8"
      powerType.powerOff = "soft"
      powerType.powerOn = "soft"
      powerType.suspend = "soft"
      powerType.reset = "soft"
      serial0.present = "TRUE"
      serial0.fileType = "thinprint"
      printers.enabled = "TRUE"
      extendedConfigFile = "Windows XP Professional.vmxf"
      virtualHW.productCompatibility = "hosted"
      floppy0.present = "TRUE"
      hpet0.present = "TRUE"
      usb.vbluetooth.startConnected = "TRUE"
      ide0:0.startConnected = "FALSE"
      ethernet0.generatedAddress = "00:0c:29:8b:33:fd"
      vmci0.id = "1133196285"
      uuid.location = "56 4d 54 47 72 77 34 ba-99 dc 26 6d 43 8b 33 fd"
      uuid.bios = "56 4d 54 47 72 77 34 ba-99 dc 26 6d 43 8b 33 fd"
      cleanShutdown = "FALSE"
      replay.supported = "FALSE"
      replay.filename = ""
      scsi0:0.redo = ""
      pciBridge0.pciSlotNumber = "17"
      pciBridge4.pciSlotNumber = "21"
      pciBridge5.pciSlotNumber = "22"
      pciBridge6.pciSlotNumber = "23"
      pciBridge7.pciSlotNumber = "24"
      scsi0.pciSlotNumber = "16"
      usb.pciSlotNumber = "32"
      ethernet0.pciSlotNumber = "33"
      sound.pciSlotNumber = "34"
      ehci.pciSlotNumber = "35"
      vmci0.pciSlotNumber = "36"
      usb:1.present = "TRUE"
      ethernet0.
      generatedAddressOffset = "0"
      vmotion.checkpointFBSize = "134217728"
      usb:1.speed = "2"
      usb:1.deviceType = "hub"
      usb:1.port = "1"
      usb:1.parent = "-1"
      floppy0.fileType = "file"
      floppy0.fileName = "/Users/admin/Desktop/vmscsi-1.2.0.4(1).flp"
      floppy0.clientDevice = "FALSE"
      bios.bootOrder = "HDD"
      bios.hddOrder = "scsi0:0"
      usb:0.present = "TRUE"
      usb:0.deviceType = "hid"
      usb:0.port = "0"
      usb:0.parent = "-1"
  • Here is a screen shot of the controllers in the Dell laptop:

2018437_1.png

Any help would be greatly appreciated!  TIA!

0 Kudos
4 Replies
WoodyZ
Immortal
Immortal

Since this was created from a Dell Laptop I'm assuming it's an OEM install of Windows XP and if indeed it is you are not allowed to migrate it to another system, physical or virtual, as it is not allowed by the OEM EULA.  OEM installs of Windows OSes live and die on the original system installed and are not transferable.

So even though one could manually inject the Driver and Windows Registry entries for the BusLogic SCSI Controller as the .vmx configuration file shows it's configured for, nonetheless once booted to Windows one will be faced with WPA (Windows Product Activation) and it will fail as it is no longer on the Dell Laptop it was originally installed on.

0 Kudos
bababab
Contributor
Contributor

When the VM uses a VMWare virtual SCSI controller, IDE0:0 usually refers to the Host's CD/DVD drive. Make sure you have the Host's real CD/DVD drive data and power connectors actually plugged in. If you don't you'll get the "Cannot connect virtual device ide0:0" error when you start the VM.

Never happened to me 😆

Regards . . .

0 Kudos
WoodyZ
Immortal
Immortal

The reason PuddletownJim is getting the first error message "Cannot connect virtual device ide0:0. ..." is in all likelihood because his Mac doesn't have a builtin SuperDrive or if he has an external one it's not plugged in however while that's an easy fix, just turn off "Enable CD/DVD Drive" in the Virtual Machine's Settings, nonetheless the STOP: 0x0000007B error is a different story all together.  His is attempting to create a Virtual Machine from an OEM install of Windows and this not allowed by the Windows XP OEM EULA.  OEM installs of Windows OSes live and die on the original system installed and are not transferable.  Additionally WPA will fail on a transfer from an Dell OEM system to anything other then another Dell computer, which is also not allow by the OEM EULA either! Smiley Wink  Now of course there are ways around this however discussing how to illegally circumvent OEM licensing in these forums is not permitted by the VMware Community Terms of Use.  So the bottom line is helping to resolve PuddletownJim's STOP: 0x0000007B error is not permitted.

0 Kudos
bababab
Contributor
Contributor

My Woody,

I certainly had no intention of helping anyone circumvent any license. I could care less about licensing mechanisms because I don't try to avoid them. The ONLY reason I posted a reply here is because this is the sole discussion I could find anywhere that specifically mentioned "Cannot connect virtual device ide0:0". I thought I had something to add that would help the community. Now I'm glad that I didn't spend more time giving detail on the specifics of this situation.

Please feel free to delete my 6/11/13 reply so others can spend half a day trying to correct a VMware problem that, in my recent experience, is not really caused by VMWare. Btw, did I mention "Stop error" anywhere?

Regards . . .

0 Kudos