Coach300
Enthusiast
Enthusiast

App Nap core function in OS X Mavericks

One of the new core technologies in Mavericks is called "App Nap" and as its name implies, an application that is not visible or apparently active will "nap" or go into app-specific "sleep", wakened when it's brought to the front/visible, etc.

Get Info (Finder command Command-I) has the ability to "disable app nap" in its General section near the top of the Info window, so Mavericks gives users the ability to disable the feature on an app-by-app basis. Checking the box disables the napping.

Would it be advisable to disable App Nap for Fusion, of any version? I could see use for this, say that a nap might disable something like an overnight Windows Update, Windows Backup, virus scan, or other nighttime maintenance task. Or would such a scheduled task wake the app from the nap without having to go to that end?

Tags (2)
24 Replies
Coach300
Enthusiast
Enthusiast

I'm going to reply to my own post to bump it up a bit. I detected that a couple others report having "discovered" the "Prevent App Nap" feature in Mavericks to boost performance in Fusion (this may be as applicable to Fusion 5, I don't know). But I'm wondering that this might actually become a "best practice", as Mavericks may think that a VM that's starting, resuming, pausing/suspending, or going through other tasks like Windows Update or a virus scan on a schedule might have such task slowed or stopped because of a forced Nap that we users have the ability to override.

0 Kudos
Coach300
Enthusiast
Enthusiast

Was Windows 8.1 VM behaving differently before Mavericks? Remember, Mavericks is new, but so is Win 8.1 and it might be possible that some power setting in the guest OS might need to be looked at (may have changed going 8 --> 8.1).

0 Kudos
geokaps
Contributor
Contributor

I was reading this thread and I wanted to chime in as well. I too am having the same problem as AnoopVMX - namely, I'm running a Win 8.1 virtual machine with Fusion 6.0.1 (1331545) under mavericks and if I walk away from the Mac for 30 minutes (so my displays go to sleep), the Win 8.1 VM is completely hung and unresponsive when I try to use it again. Now note that I have the Mac set up so that it never sleeps, only the displays turn off. I also do not put any hard disks to sleep - they are always powered up. Also note that the Mavericks host is also in some sort of compromised state where it is only semi-responsive and the only way to fix this mess is with a power button reset.

To Coach300 - This all worked perfectly last week under Mountain Lion before upgrading to Mavericks.

I'm now trying the "Prevent App Nap" option and I'm also going to re-install VMWare tools just for the heck of it to see if that makes any difference. I'll report back with the results.

Coach300
Enthusiast
Enthusiast

I opted to revert to Fusion 5 for similar reasons (see my separate thread on how and why I did that). Perhaps there is something within the core of Fusion 6, or that my older (mid 2010) Mac is just not up to the task, but can run it well under Fusion 5.

0 Kudos
hruan
Contributor
Contributor

My Windows 8.1 VM is exhibiting the same behaviour as geokaps describes, with what sounds like similar host and VM settings. Prior to upgrading 10.9 my VM was also stable.

geokaps: Any luck in resolving the issue? Re-installing VMware tools made no difference for my VM, neither did turning off app nap nor GPU switching. Also, are you running a Mac with a discrete GPU in addition to the integrated one?

geokaps
Contributor
Contributor

Hey hruan, I've been so busy working that I haven't had enough time yet step away from the Mac long enough to see what happens when the VM sits idle for a while. To answer your question, similar to Coach300 in terms of Mac age, I too am running on a mid 2010 Mac-mini with 8GB RAM with the NVDIA GeForce 320M GPU.

dcsoft
Contributor
Contributor

Same here - upgraded MacBook Air 2012 from Mountain Lion to Mavericks and then Fusion 6 VM of Win 8.1 started being hung after being left along for hours.  Actually, unlike geokaps, my entire VM was not hung, only certain apps were.  I could Alt+Tab to different apps and they would work.  Eventually (after 30 seconds or 1 minute) everything seemed to recover.  Anyway, I disabled Power Nap for 'VMware Fusion.app' a couple days ago and the hangs seem to have disappeared.  No negative side effects that I've noticed yet, have been running on AC so don't know about battery life.

Thanks,
David

geokaps
Contributor
Contributor

Yep, I have to say that disabling App Nap for the VMware Fusion app seems to have fixed my Win 8.1 VM hang-up woes. I've left the VM idle for extended amounts of time and it is still responsive when I come back to it later.

Coach300
Enthusiast
Enthusiast

I will say I do like seeing the feedback here - if nothing else, App Nap is something that's new and I discovered it by "playing" in the Finder (that it could be prevented app by app).

The App Nap applies as much to Fusion 5 as it does to 6 (remember, folks, I downgraded my VM). My computer is capable of running Mavericks, but not Fusion 6 at the same time. (Maybe it could have handled 6 under Mountain Lion, but I'll never know.)

0 Kudos
dcsoft
Contributor
Contributor

Ditto.  I was happy with Fusion 5 on Mountain Lion.  First recent upgrade was Fusion 6, and that was noticeably snappier.  Then came updating Win 8 VM to 8.1, which brought further perf improvement.  Then it was updating to Visual Studio 2013 in the VM, again faster.  Final one was upgrading Mountain Lion to Mavericks, and that was again faster.  The Mavericks memory compression seems to be doing wonders.  Awesome jobs all around!

Thanks,
David

0 Kudos
Coach300
Enthusiast
Enthusiast

I'm going to bring this up again. I'm beginning to think that "Prevent App Nap" isn't quite the "prevention" that Apple would want us to think that it is, or is even possible in its new operating system. Now, I did downgrade to Fusion 5 (I even went further and uninstalled VMWare Tools from v. 6 and reinstalled from v. 5 - and that was a project and three-quarters, and may have been unnecessary).

After that full downgrade, I had Fusion 5 operating Windows 7 on my mid-2010 MacBook Pro "just great" on 11/3. (I use Windows apps to help run bowling tournaments and leagues and wouldn't need Windows were it not for that). But on 11/4, it was a time when I would actually be bowling and when it came to returning to the Mac, I found a system that would just pause lengthily in place. Fusion would remember and cache every mouse click, just process all 100 of them 5 minutes later on.

I think that what I need to do is find some bowler's kid who can play Minesweeper long enough to keep Windows "fully active" between my direct uses.

Now I wonder if this is Apple's message to upgrade to a pricier (because Retina and flash drives are required now) MacBook Pro, but how will I seriously know that this App Nap (even if marked "Prevented") wouldn't have the same effect on a newer machine? That last question is a rhetorical one. I'm sure Mavericks will have some update in the future, but I want to draft an appropriate communication to Apple first. I'm happy enough to evaluate Mavericks to see what it can do on an older machine before using it on a new one, but this is a pretty high price for that "privilege".

0 Kudos
dcsoft
Contributor
Contributor

I haven't had any more lengthy pause issues with Fusion 6 and Win 8.1 VM.  Maybe you should re-upgrade to Fusion 6.

Coach300
Enthusiast
Enthusiast

Point taken, but if I read another post of yours in another thread, your machine is a couple years newer than mine.

0 Kudos
geokaps
Contributor
Contributor

I second giving Fusion 6 and another try.  vmware just rolled out another Fusion 6 patch (6.0.2). My Mac-mini (mid 2010) is the same vintage as your machine and probably not as capable as yours. I haven't had any issues since checking the "Prevent App Nap" box in Mavericks. However, I haven't checked the operating characteristics of Windows 7 under Fusion 6 and Mavericks. Only Win 8.1/Fusion 6/Mavericks. Anyway, still might be worth checking out again.

Coach300
Enthusiast
Enthusiast

I have re-upgraded. In addition to Fusion 6.02, I also disabled shared folders. Also, the software I use in Windows no longer uses a tray icon but rather a Windows Service for its database, which is more stable. I used to have a shared folder (Mac Downloads) that would be set to automatically open on Windows launch, as I would need to run a downloaded installer in repair mode because the database was always disabled on restart. With the tray icon gone, there's no need for that installer re-run, so I disabled the shared folder and also took it off the startup items (MSCONFIG). Things are running fine now. Yes, I did take hints from other threads in this forum.

0 Kudos
dcsoft
Contributor
Contributor

Glad to hear it's working for you now.  Over the past couple weeks, mine has become unresponsive twice, meaning I had to shutdown and restart the VM to recover.  This is still very stable, but for the record is not 100%.  (This is still with App Nap disabled for the Vmware app).  I went into Settings and noticed the CPU had a warning that I had selected 4 cores for the VM (and my MacBook Air has 4 cores), the recommended was at most 2 cores, so I reduced it to 2 and am monitoring to see if that made it better.

Thanks,
David

0 Kudos
QuiSait
Contributor
Contributor

Coach300 — Perhaps you might summarize all of the settings & tricks you discovered in one succinct list?

Like many others, since upgrading (OS X & Fusion) I have essentially rendered Windows unusable (bc I toggle back to Mac apps so often) and I long for the pre-upgrade(s) days when everything worked as expected using recommended/default settings in OS X, Fusion & Windows (no tricks required).  I’ve broken down to having two laptops running side by side on my desk — but that isn’t going to work the next time I have to jump on a plane.

@VMware:  Come on guys…  You should be publishing an updated KB ‘recipe for success’ — something is clearly going on here.

0 Kudos
dcsoft
Contributor
Contributor

In the past week since I assigned only half my cores (originally it was all cores) to the VM, both my host and guest have performed very, very well.  🙂

My summary is:  1) Disable App Nap for the Vmware .app file; 2) Make sure the VM setting for CPU is as recommended (don't assign too many cores).

Thanks,
David

QuiSait
Contributor
Contributor

Thanks, David

I changed the number of cores to 2 (from 1), am using the VMware recommended memory settings, and turn off App Nap for VMware.app. 

Unfortunately, this hasn’t changed anything for me Smiley Sad

0 Kudos