VirExprt
Expert
Expert

SaltStack Config Integration show Blank Page

Jump to solution

Hi ,

 

I have added StalkStack Config as the added product to the vRA 8.4.2 using LCM however, post-install/configure when I click on the "StalkStack Config" button, i get a completely blank page with no sign of anything.

 

I have installed VRSSC 8.4.2 with vRA8.4.2

VirExprt_0-1630006754752.png

 

 

Regards, MG
0 Kudos
1 Solution

Accepted Solutions
prydin
VMware Employee
VMware Employee

There's a quick and dirty workaround. Before I show it I have to make the usual disclaimer:

IT IS NEVER A GOOD IDEA TO TURN OFF CERTIFICATE VALIDATION, ESPECIALLY NOT IN PRODUCTION!

  1. Log into your salt/raas-appliance as root.
  2. Open /etc/raas/raas in an editor.
  3. Add the following lines to the end of the file:
#vra bypass validate ssl
vra:
  validate_ssl: False

4. Restart the service:

systemctl stop raas && systemctl daemon-reload && systemctl start raas

 

 

View solution in original post

7 Replies
johnbowdre
Enthusiast
Enthusiast

During the deploy from LCM, did you tick the oh-so-tempting checkbox to integrate with IDM? I found that doing so (with 8.5, at least) resulted in exactly what you're describing. Leaving that box unchecked and logging into SSC with "local" credentials works much better for me.

0 Kudos
VirExprt
Expert
Expert

@johnbowdre 🤣😂 yes i did click on "oh-so-tempting" checkbox to integrate with VIDM but i could not find any integration of VRSSC in vIDM. I am going to destroy this integration and redo without it.

Regards, MG
johnbowdre
Enthusiast
Enthusiast

@VirExprt yep, that's what I wound up doing as well. I'm not sure how much of the "integration" is actually integrated at this point. I'm still feeling my way through the SSC stuff myself.

0 Kudos
prydin
VMware Employee
VMware Employee

There's a quick and dirty workaround. Before I show it I have to make the usual disclaimer:

IT IS NEVER A GOOD IDEA TO TURN OFF CERTIFICATE VALIDATION, ESPECIALLY NOT IN PRODUCTION!

  1. Log into your salt/raas-appliance as root.
  2. Open /etc/raas/raas in an editor.
  3. Add the following lines to the end of the file:
#vra bypass validate ssl
vra:
  validate_ssl: False

4. Restart the service:

systemctl stop raas && systemctl daemon-reload && systemctl start raas

 

 

johnbowdre
Enthusiast
Enthusiast

@prydin That worked like a charm in my lab environment, thanks!

0 Kudos
VirExprt
Expert
Expert

Thanks @prydin it also worked fine for me. 

Regards, MG
0 Kudos
dgerol3
Contributor
Contributor

Actually, the issue is with the certificate chain. Install the root cert as per this article:

https://blog.ntitta.in/?p=753

 

0 Kudos