EdwinVoskamp
Contributor
Contributor

How to enter nocheckCPUIDLimit on ESX Server 3i 3.5.0 build-110271?

I installed ESXi on a Dell PowerEdge SC1420, but don't have access to the limit CPUID value in the BIOS. I installed by hitting tab on booting from CD and entering nocheckCPUIDLimit.

After the installation complete, and removing the CD, then rebooting, I am unable to get to entering the options: neither Shift+o nor tab do anything.

So, how do I get to where I can enter the advanced options?

0 Kudos
14 Replies
Dave_Mishchenko
Immortal
Immortal

Shift - O should work for you - are you trying it when the screen is at the "Loading VMware Hypervisor stage? You should then get the prompt as shown in the first attached image. Once you have the host booted, you can set the option permanently (see 2nd image).

0 Kudos
Dave_Mishchenko
Immortal
Immortal

PS - disregard the option name I used in the one image - the correct option is nocheckCPUIDLimit.

0 Kudos
EdwinVoskamp
Contributor
Contributor

Yeah, I know it should work for me. It doesn't though. Smiley Sad

I replaced the keyboard with another, checked the shift key works and that shift+o works.

I get a split-second a screen that may at the top left say something like 'Multi-boot ...' but it is gone too fast to even read, then immediately goes to the "Loading VMware Hypervisor" screen. Except for the "Loading VMware Hypervisor" title, the underline, all that is showing is the white progress bar at the bottom. Shift+o does not work. I checked the Caps Lock key isn't on, tried holding down shift and not. Nothing.

0 Kudos
EdwinVoskamp
Contributor
Contributor

And your "Shift - o" means depress the Shift key and hold it, then, at the same time hit the o (as in Oscar) key, right?

0 Kudos
Dave_Mishchenko
Immortal
Immortal

If you try Shift+R, at the loading screen do you get an error message about there not being a backup image?

As an alternative, you could boot the host with a Linux live CD, then edit the boot.cfg file on the Hypervisor0 partition. You would basically just add the same option in that file.

EdwinVoskamp
Contributor
Contributor

Yup, ShiftR got me the error message about there not being a backup image, enter continued booting, and ShiftO worked on that boot.

Edited config file to put in checkCPUIDLimit = "FALSE" and she's happy now.

0 Kudos
a13x212
Contributor
Contributor

Can someone confirm whether the option nocheckCPUIDLimit works with ESXI (the free version).

When I hit tab, I see a line like:

vmkernel.gz --- binmod.tgz --- ienviron.tgz --- cim.tgz --- oem.tgz --- license.tgz --- install.tgz

0 Kudos
J_Jab
Contributor
Contributor

I'm getting that aswell....once I type the command nocheckCPUIDLimit in the Boot menu it starts loading the ISO. Right after it's done laoding I get another error message, 'could not find kernel nocheckCPUIDLimit'

0 Kudos
avninder
Contributor
Contributor

Give the space between kernel.gz and no check like "mboot.c32 Vmkernel.gz nocheckCPUIDLimit -


"

and try to boot now. hopefully u'll not get error this time.

0 Kudos
BrennanB
Contributor
Contributor

Worked like a champ for me on a GX280. Used Shift O and then entered in adjustments to the string. Once it was loaded I was able to make the change permennant via VI client. Thanks for the info guys!!!

0 Kudos
hotwings
Contributor
Contributor

I want to load esx server 3i on my Dell gx280 but am unsuccessful. Can you elaborate more with the steps? I entered the the nocheck option on the boot menu but still getting the "cpuid is limited". error. Thanks.

0 Kudos
iben
Contributor
Contributor

confirming this worked for me with latest ESXi 3.5.0 update 4 - also note that Hard Drive SATA Operation setting needs to be "Normal" not "combination" for ESXi to detect and install correctly. This box only has 2 x 512KB DIMMs but we will try to put 4 x 1 GB or maybe 4 x 2 GB chips to upgrade RAM. Anyone know max memory config?

I b e n +14087824726 IM info: ibenrodriguez - yahoo iben.rodriguez - gmail ibenr - aol ibenrodriguez - skype Follow me on http://twitter.com/iben http://communities.vmware.com/people/iben
0 Kudos
sipero
Contributor
Contributor

Hi,

On the Desktop or Tower machines the lomit is 4 x 1Gb and you have to be careful with your selection of memory as not all DDR2 1Gb modules will work from other postings I've seen.

Jonathan Hamon

0 Kudos
BrennanB
Contributor
Contributor

  1. At the initial bootloader screen (when booting from the ISO), press TAB to edit the boot options

  2. add "nocheckCPUIDLimit" right after
    "vmkernel.gz", so that the first part of the boot options BEFORE the
    first "---" reads: "mboot.c32 vmkernel.gz nocheckCPUIDLimit ---"

  3. Press enter to finish

Now that it will load make sure to login to the machine using VI Client and set the NoCheckCPUIDLimit in the advanced settings.

1.Open the ‘Configuration’ tab of the ESXi host

2. Click on ‘Advanced Settings

3. Open the VMkernel variable and then the Boot list and there will be a checkCPUIDLimit box, make sure this is unchecked.

0 Kudos