bnb
Contributor
Contributor

Creating a quiesced snapshot failed problem

Hi, we have a problem with a script, this script runs fine but as soon as a vm undergoes a change (name change, resize of (rdm) lun, and installation of vmtools) the script stopped with the error (in vc):

Creating a quiesced snapshot failed because the (user-supplied) custom pre-freeze script in the virtual machine exited with a non-zero return code.

In the hostd log we find the following error:

2008-07-02 23:36:41.994 'vm:/vmfs/volumes/45f7da44-7eab05df-4ffc-0017a4aa63ce/droplet/droplet.vmx' 38849456 warning Could not run custom freeze/thaw operation: Guest tools is not running.

Tools are up to date we run 3 3.5 esx servers and a 2.5 virtual centre with al the patches and updates.

Soon as we migrate the vm the script runs fine again.

The only thing I can find that changes with the migration is the uuid.location in the vmx file of the problem vm. (This doesn't happen with other vm's only with vm's that undergo a change like name change, resize of (rdm) lun, installation of vmtools). It happens regardless of o.s. Linux or windows

We don't know how we can prevent it from happening, we can fix it by migrating the machine we know that. Looks like a bug to us that above water everything looks fine but under water it gives an error that guest tools are not running. With vimsh it also returns guest tools are ok.

I understand there is a patch for Solaris in the making with what looks like a similar problem/bug. (Same error in vc: "Creating a quiesced snapshot failed because etc" and partly different in hostd log: "Could not run custom freeze/thaw operation: Insufficient permissions in guest operating system")

There is a workaround with quiesce = 0 this is not an option for us. Does anybody have the same sort of troubles or experiences? We like to know Smiley Happy

0 Kudos
3 Replies
bnb
Contributor
Contributor

made another service request:

We have a vc 2.5 with all the updates and patches and 3 esx servers 3.5 with all the updates and patches and around 160 vm's with rdm with up to date tools.

We have a problem with the uuid.location in the vmx.

The uuid.location changes if something has happend to the vm like a name change of the vm or a resize of the rdm or installation of vmtools .

The change to the uuid.location is not visible in the vmx file untill the vm is migrated or the vm is powered of not if the vm is rebooted and more importent if the changes are made.

You can reproduce this problem by making a name change in vc to the vm(with rdm) in vc.

Check the uuid.location notice it doesn't change.

Now migrate the vm to another esx host and check the uuid.location again.

Why do changes to the uuid.location only change for real with a migration and not with the change itself ? It looks to us as a bug.

Because uuid.location is not correct untill a migration causes us a lot of trouble with the backup.(Creating a quiesced snapshot failed because the (user-supplied)custom pre-freezescript in the virtual machine exited with a non-zero return code) As soon as it is fixed with a migration the backup runs fine.

0 Kudos
PKaufmann
Enthusiast
Enthusiast

hi,

we got the same error...

How did you resolve? or did you resolve it by now ???

best regards,

Philipp

0 Kudos
Texiwill
Leadership
Leadership

Hello,

Moved to ESX v3.5 forum.


Best regards,

Edward L. Haletky VMware Communities User Moderator, VMware vExpert 2009, Virtualization Practice Analyst[/url]
Now Available: 'VMware vSphere(TM) and Virtual Infrastructure Security: Securing the Virtual Environment'[/url]
Also available 'VMWare ESX Server in the Enterprise'[/url]
[url=http://www.astroarch.com/wiki/index.php/Blog_Roll]SearchVMware Pro[/url]|Blue Gears[/url]|Top Virtualization Security Links[/url]|Virtualization Security Round Table Podcast[/url]

--
Edward L. Haletky
vExpert XIV: 2009-2022,
VMTN Community Moderator
vSphere Upgrade Saga: https://www.astroarch.com/blogs
GitHub Repo: https://github.com/Texiwill
0 Kudos