PetrMai
Contributor
Contributor

How to enforce Quick boot when updates are made by Powershell (Update-Entity)

Hello,

we´re using our own powershell script that automatically updates all ESXi servers of our VMware farm.

The script uses Update-Entity command.

My question is how can I ensure that the automatically reboot called by the Update-Entity command make a Quick Boot instead of standard boot. In VUM I can choose this option but in powershell not and all servers are rebooted without quick boot. It´s time consuming.

Thanks, Petr

Labels (1)
  • o

0 Kudos
5 Replies

It's not exactly the solution in powershell, but you can configure at Updage Manger level, the Host configuration and enable there the Quick boot. 

With this I assume all updates you triger will follow the parameter.

 

NicolasAlauzet_0-1631696133829.png

 

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos
PetrMai
Contributor
Contributor

Hello,

it seems this is not correct answer. I have already enabled the option in Update Manager but it seems that powershell command Update-Entity ignore this settings and enforce normal restart instead of quick boot every time when command finishes.

If I made update manually from Update Manager, the Quick boot settings is applied. From Powershell not.

PetrMai_0-1631696704356.png

 

0 Kudos

I added an edit to the other one but got lost i dont know why...

You can try this also:

To enable quick boot on each esxi:

CMDLET:

/bin/loadESXEnable -e

And  prepare the host to do so:

/usr/lib/vmware/loadesx/bin/loadESX.py

 

You can use this one to check if got enabled:

cat /scratch/vmware/loadESX/loadESX.stats

 

Also, most important, validate if your node supports the feature:

/usr/lib/vmware/loadesx/bin/loadESXCheckCompat.py
-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos
PetrMai
Contributor
Contributor

Hello,

as I wrote in my previous post, the quick boot works fine with update made from webUI.

And of course, the ESXi host is Quick boot enabled and support this function.

PetrMai_0-1631698544886.png

 

0 Kudos

I imagine tha if its enable and still doesnt work while running with commands, the order to use it is passed during update to the nodes from um.

As you mentioned, you are running with powershell. Maybe if you add the steps mentioned by me before you execute the update (with powershell) it will work.

-------------------------------------------------------------------
Triple VCIX (CMA-NV-DCV) | vExpert | MCSE | CCNA
0 Kudos