NetmanKennyChen
Contributor
Contributor

MTRRs error on installing esxi5.5 within virtualbox

Jump to solution

Hi Guys,

I encountered an MTRRs error while I was trying to install esxi 5.5 within a VirtualBox (ver 4.3.20) which runs on CentOS 6.6.

The vbox settings are:
        Type: Linux
        Version: Linux 2.6/3.x (64bit)
        RAM: 4096MB
        CPU: 2core

The iso was bootable, but hanged with purple screen and mentioned about: No variable MTTRs: assuming ESX is running in a VM.

How can I get rid of the problem? Thank you!

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

The message about the MTRRs is just a warning.  The PSOD was the result of a #GP exception.  Please boot ESXi with the additional vmkernel option "vmbASLR=FALSE" and post an image of the PSOD.

View solution in original post

0 Kudos
10 Replies
admin
Immortal
Immortal

The message about the MTRRs is just a warning.  The PSOD was the result of a #GP exception.  Please boot ESXi with the additional vmkernel option "vmbASLR=FALSE" and post an image of the PSOD.

View solution in original post

0 Kudos
NetmanKennyChen
Contributor
Contributor

Thanks Jmattson! It works now...

0 Kudos
NetmanKennyChen
Contributor
Contributor

It is strange!

I successfully created a esxi 5.5 in a virtualbox which is running on my Ubuntu Laptop, however, It failed while I tried to do the same thing in the Virtualbox on CentOS6.6...

The exact same PSOD I got. What else?

0 Kudos
admin
Immortal
Immortal

I suspect that the issue is an unimplemented MSR in VirtualBox--one that should be available on the CPU in your CentOS machine, but not on the CPU in your Ubuntu machine.

If that's the case, the two solutions that come to mind are (1) configuring VirtualBox to ignore unimplemented MSRs or (2) configuring VirtualBox to report a different CPU model, that doesn't support the MSR in question.  Based on the PSOD, I'm guessing that the MSR is 130H, CPUID1_FEATURE_MASK, described in http://www.intel.com/content/dam/www/public/us/en/documents/application-notes/virtualization-technol....

If you boot ESXi with the additional vmkernel option "vmbASLR=FALSE" and post an image of the PSOD, I can confirm my guess.

0 Kudos
NetmanKennyChen
Contributor
Contributor

Thank you very much, Jmattson!

Since I am in the vacation of the Chinese New Year holiday, I will do a try as soon as I get back to work and let you know about the result.

Thanks again, and all best wishes!

0 Kudos
NetmanKennyChen
Contributor
Contributor

Hi Jmattson,

The attachments  are the screen captures on  the Centos machine. Hope that may help on your analysis.

Thank you!

0 Kudos
admin
Immortal
Immortal

As I suspected, we are trying to read MSR 130H, and VirtualBox is raising a #GP exception on this access.  This is a bug in VirtualBox.

There may be a way to have VirtualBox report a different virtual CPU model.  Changing the CPU model to one that doesn't implement MSR 130H is one way to work around this problem.

Alternatively, it may be possible to configure VirtualBox to ignore unimplemented MSRs.  That would be another way to work around this problem.

0 Kudos
NetmanKennyChen
Contributor
Contributor


OK, Thanks Jmattson! I will give it a try... Smiley Happy

0 Kudos
Rohanil
Contributor
Contributor

Hey jmattson,

I am facing exactly same problem but I don't know how to configure VirtualBox to ignore unimplemented MSRs. So do you have any idea about it?

Thanks in advance

Rohanil

0 Kudos
admin
Immortal
Immortal

Sorry; I don't.

0 Kudos