awpudlak
Contributor
Contributor

Zebra/Symbol barcode scanner redirection issues

we have zebra and symbol USB scanners that are used to scan medicine in our hospital from both dell and igel thin clients.  Our issue is that when a thin client is rebooted with the USB scanner attached it will not work after you establish a connection to your Horizon instance until you unplug the USB scanner and plug it back in.  We have tried the following items. 

 

  • Zebra offered the two below links which I applied to our test Horizon pool.

https://supportcommunity.zebra.com/s/article/Scanners-not-booting-correctly-on-a-PC-running-Windows-...

https://supportcommunity.zebra.com/s/article/Turning-off-USB-3-0-Power-Management?language=en_US

    • Powering off the thin client and powering it back on lead to the scanner not automatically being picked up. It does seem to pick up 10-15 minutes later. I would hear two beeps and the scanner would then start to function.
    • Going from external power supply to internal laptop battery power will cause the scanner to disconnect and similar to above it will reconnect 10-15 minutes later
  • I did some research online and tinkered with a few different settings in Horizon on the test pool which did not come up with positive results and I reached a dead end. I contacted VMware support who advised to test the scenario outside of the thin client environment.
    • I tested on my laptop with the same parameters above and was unable to recreate the scenario. NOTE – that it’s not exactly the same test as the thin client laptop has an external battery whereas my laptop is connected with AC power.
    • With those results I additionally tested with a Citrix based thin client laptop and I was able to reproduce the same scenarios above with the Horizon environment and Citrix.
    • After that VMware support advised to contact Dell.

Scenarios that did not work:

  • We have tested plugging the scanner directly into the laptop using ports on both sides of the laptop
  • We have tested using a powered tripp-lite usb hub that connects to a usb port and has external power using USB ports on both sides of the laptop
  • We have tested using a powered Tobu usb hub that connects to the usb C port
  • We have tried a 90w adapter that is a usb c power model. Tested USB ports on both sides of the laptop
  • We have tried both Citrix and IGEL OS with multiple USB ports tested

 

Scenarios that did work:

  • Using my own dell precision 3550 laptop, installing the horizon agent and testing multiple usb ports on the laptop. I switched from AC power, battery power and hooked in through a dock.
  • Testing on a 5470 AIO on multiple usb ports

 

Zebra scanner model – DS8178 with the latest firmware available.

At this point we are at a loss and have reached out to Dell, Zebra, Symbol, and VMWare.  We have even tried higher powered power supplies in case it was a lack of power. 

Any help or ideas is appreciated. 

 

horizon environment = 7.13, DEM, App Volumes, FSLogix

 

Thank you,

0 Kudos
1 Reply
Mustafaince98
Contributor
Contributor

If you are using WYSE Client please remove from USB redirection and add this one there vid-05e0_pid-1200.

 

Remove vid-05e0_pid-1200  from Blast session.

Open notepad  There is bar code comes with unit you have to scan this code ( Add An Enter Key) Carriage Retrun/LIne Feed)  please scan any bar code if line  go to next line. it should work.

0 Kudos