Dave_O
Contributor
Contributor

Wyse V10L WNOS 6.3.012 and View 3

I have installed Wyse OS version 6.3.012 which supports View 3. The setting ConnectionBroker=VDM leverages the XML settings of the VDM broker.

The setup works fine other than the following two issues:-

1. The Wyse ConnectionManager does not boot straight into a desktop once a user has authenticated. This is fine if you have several pools you wish to choose from but is a pain if there is only one pool and you want to use this directly without having to select one. If anyone has any ideas how to connect to the only pool then I would be grateful

2. The default RDP connection session settings that are sent from the broker to the Wyse V10L have the desktop settings as "Window" rather than full screen. This gives access to the Wyse desktop when the XP session is running. We do not want this. If anyone has any ideas how to change the default desktop settings on the broker which are sent to the Wyse V10L that would be very useful.

Thank you for your time

Tags (1)
0 Kudos
9 Replies
LeeG9
Contributor
Contributor

Has anyone found a solution to this problem yet? I am having the same problems.

0 Kudos
olivier_dubroca
Contributor
Contributor

you can change the default layout in wnos.ini (wyse file configuration)

Fullscreen=yes

0 Kudos
Dave_O
Contributor
Contributor

Olivier

Tried this. Any attempt at creating and passing in session parameters from the wnos.ini file fails. Even if you give the session the same name as the pool (which is passed back to the connection manager) the view broker creates a session instance with the same name. The session passed by the broker is read only, it seems, not able to be changed subsequently.

0 Kudos
olivier_dubroca
Contributor
Contributor

According to the wyse os admin guide, you can put additionnal information to RDP.ini file. The parameters must be automaticly appended to the default

parameter send by broker.

0 Kudos
cgagliardi
Contributor
Contributor

There is a command line tool that may help, it assigns the default pool to a user when using a thin client. It is on the view server, "vdmadmin.exe". I am attempting to attach the reference pdf as I do not have the link handy. I never tried this myself but have read somewhere that this is it....

Good Luck!

0 Kudos
hmartin
Enthusiast
Enthusiast

I believe we have this working. I'll test tomorrow and post the results.

0 Kudos
WyseGuy
Contributor
Contributor

This issue has been corrected and validated with View 3.1. It is important to remember to work with the latest firmware for the V10L as it will include the latest client side dependencies for the View product. If you have WTOS software maint from Wyse then you should be able to login and download the latest firmware which has this issue resolved.

0 Kudos
alelondon
Enthusiast
Enthusiast

We have Wyse ThinOS and View 3.1 working fine.

On the broker we have the following setting for the desktop pool(s):

Broker Web Admin page > Configuration > Servers > View Servers > Select your server > Edit:

Direct connection to desktop: Selected

Our Wyse terminals are 6.3.0_22

For the Wyse devices (both V10L and S10) we have an FTP server holding the WNOS.ini file centrally. Here is how our WNOS.ini file is configured:

AutoLoad=201

DesktopColorDepth=32

DomainList=MYDOMAIN

EnableLocal=yes

Dualhead=no Mainscreen=1 Orientation=horizontal Taskbar=wholescreen

Resolution=1280X1024 Refresh=60

FormURL=mylogo.bmp

Desktop=mylogo.jpg

Language=uk

Timeserver=MYIPADDRESS Timeformat="24-hour format" Dateformat=dd/mm/yyyy

NoReducer=yes

LowBand=no

ConnectionBroker=VDM

VDIBroker=https://mybroker

connection=RDP WyseVDA=yes

FixLicense=factory

TCXLicense=MYTCXLICENSE

SessionConfig=ALL UnmapPrinters=no UnmapSerials=no Smartcards=yes MapDisks=yes

Hope this helps

0 Kudos
mnasir
Enthusiast
Enthusiast

(Since I already answered this on another post - I am just copying it ove here)

I just deployed Wyse S10 and V 10 with VMware view 3.1.1, and

everything is working as planned – if you are considering deploying it

in production. I strongly recommend not just follow my instructions

outlined below. You should consider reviewing many helpful documents

and best practices/How TOs’ on the VMware and Wyse websites.

Tip 1: You should use Wyse Firmware code 6.4._12. This code is supported with VMware view 3.1.X. See the following link: [http://www.vmware.com/resources/compatibility/search.php?action=search&deviceCategory=vdm&productId=2&advancedORbasic=advanced&maxDisplayRows=50&key=&release%5D%5B]=68&datePosted=-1&partnerId[]=192&rorre=0

Tip 2: You should download the rapport (Wyse Device Manager) server

from the link below , this is free from Wyse. This way you can

centrally manage update all your Wyse devices from a central console.

Tip 3:I recomend using ConfGen to generate wnos.ini file . This utility

gives you a nice graphical user interface to create advanced ini file

for Wyse devices. I am pasting my sample configuration.

bq. ;*************************************************************
~ ;* ~
* ~ ;* This wnos.ini file was generated with the ~
* ~ ;* Configuration File Generator 5.0.05 ~
* ~ ;* Copyright by Thomas Moellerbernd ~
* ~ ;* ~
* ~ ;* http://www.technicalhelp.de ~
* ~ ;* ~
~ ;
***********************************************************~
~ ;
***********************************************************~
~ ;
General 1 ~
~ ;
***********************************************************~
~ autoload=1~
~ AdminMode=yes Username=XXXX Password=XXXXX~
~ Privilege=None ShowDisplaySettings=Yes~
~ ;
***********************************************************~
~ ;
General 2 ~
~ ;
************************************************************~
~ DisableButton=yes~
~ ;FormURL=logon_logo.bmp * NOT SURE YET~
~ ;************************************************************~
~ ;
General 3 ~
~ ;
***********************************************************~
~ Autopower=yes~
~ AutoSignoff=yes~
~ ;
***********************************************************~
~ ;
Display ~
~ ;
***********************************************************~
~ DeskColor="0 0 32"~
~ Screensaver="5" LockTerminal=no Type=2 Image=XXXXXX.jpg~
~ ShutDownInfo=yes~
~ ;
***********************************************************~
~ ;
Time ~
~ ;
***********************************************************~
~ Timeserver=XXX.XXXX.com Timeformat="12-hour format" Dateformat=mm/dd/yyyy~
~ TimeZone='GMT - 05:00' ManualOverride=yes Daylight=yes Start=030507 End=100507 TimeZoneName="US Eastern Standard Time"~
~ DayLightName="US Eastern Daylight Time"~
~ ;
***********************************************************~
~ ;
Network ~
~ ;
************************************************************~
~ Device=Ethernet Speed="100M FD"~
~ VDIBroker=https://View manager Server name.com~
~ ConnectionBroker=VDM~
~ SignOn=yes enableok=yes disableyes=yes~
~ MaxVNCD=1~
~ VncPassword="MDAHMLACNDBDJCHH" Encrypt=yes~
~ VncPrompt=No~

Setup Wyse Environment:

Use WDM installation manual to setup your WDM server. Copy the wnos.ini

and the current firmware code to the WNOS folder and add dhcp scope

option 186 on you DHCP scope. After you set the proper DHCP scope, all

you need to do is reboot your Wyse. It will download the new firmware

code from WDM server and give you nice VMware View login window.

If you find this post helpful, please consider awarding points.

0 Kudos