bharris9
Contributor
Contributor

View 4.6 Windows 7 "Connect desktop failed"

When I try and connect to my windows 7 vm from my desktop that is running the 4.6 client I get the following error "Connect desktop failed".  I have a pool with Windows 7 desktops that are linked clones running WIN 7 64-bit,  a pool with Windows 7 desktops that are linked clones running WIN 7 64-bit SP1, a poll that is a manual VM WIN 7 32-bit, and none of them will connect.  If I use a Wyse-P20 they all connect and are happy.  I have uninstalled and re-installed the agent and the video drivers.  Still I have had no success, any thoughts?

Connection Servers - Windows Server 2008R2 - 4.6

Security Server - - Windows Server 2008R2 - 4.6

VMware View Client - 4.6

VMware Agent - 4.6

0 Kudos
8 Replies
andrew_axon
Enthusiast
Enthusiast

Do you have a firewall on your desktop that may be dropping traffic?

0 Kudos
idle-jam
Immortal
Immortal

perhaps your windows firewall .. try to disable all security softwares ..

0 Kudos
bharris9
Contributor
Contributor

The Windows firewall has been disabled since the begining.  I have another user that I set up access to the same pools that I have and they receive just a black screen and then it disconnects.  If I use XP it works fine, but Win7 is killing me.

0 Kudos
andrew_axon
Enthusiast
Enthusiast

Can you connect using RDP? If so then the issue is with PCoIP port being blocked or else the View agent needs to be uninstalled and reinstalled in the parent VM.

I have had the black screen/disconnect issue recently and the View agent needed uninstalling/reinstalling.

I find this sometimes occurs if you add or update software in the parent VM which corrupts the View agent.

Andrew

0 Kudos
bharris9
Contributor
Contributor

I cannot connect using RDP either I receive the error " The connection to the remote computer failed.  There was an unexpected RDP disconnection. Microsoft RDP error code = 2825"

I have also uninstalled re-installed the agent.

Thanks

0 Kudos
j_brookbanks
Contributor
Contributor

Are you connecting from a Windows 7 client, or is it XP (or anything else, OSX, etc)?

If it's XP, make sure that you're not using NLA for RDP connections. So in the Remote Desktop properties on the VDs, make sure that "Allow connections from computers running any version of Remote Desktop (less secure)" is selected.

0 Kudos
andrew_axon
Enthusiast
Enthusiast

Does View Manager show the desktop as being available?

0 Kudos
bharris9
Contributor
Contributor

Thanks for the reply's everyone.  I was connecting from Windows 7 desktops and once I installed SP1 on all the machines that were having issues they worked fine.

0 Kudos