warana
Contributor
Contributor

Horizon 7.4 and USB support

I feel like such a newbie asking this...

But am I the only one who is constantly having issues with USB support and Horizon View?

We are currently running version 7.0.3 and really want to upgrade to 7.4 or higher. The biggest problem we have is that the moment we test out 7.4 or higher we lose most USB support. USB printers are not detected, thumb drives are not shown. We have tested it on multiple hardware platform, teradici or wyse. Same thing.

Am I missing something?

We are talking basic thumb drives.

Epson TMU-88 printers.

Any USB devices!

Any clues or insights would gladly be appreciated.

0 Kudos
12 Replies
PaulMurphyCO
Enthusiast
Enthusiast

When you installed the VMware Horizon Agent 7.4 on your gold image / parent vm, did you make sure to enable USB Redirection?

0 Kudos
warana
Contributor
Contributor

Yes. That is one of the first things we checked.

Everything works fine for us with version 7.0.3 but the moment we change over to a higher version, 7.4 or higher, we can not seem to get USB devices to detect.

Do you have USB devices working correctly for you with a higher version? All you did was enable USB redirection?

0 Kudos
scoop
Enthusiast
Enthusiast

We've been getting "USB redirection not supported for this desktop" in the USB drop down when the user logs in.

If they disconnect and reconnect (not logout/login), then it works.

Support can't seem to figure it out. Only seems to occur when both UEM and Appvolumes are used.

Other than that (which is huge), when it's working, USB seems OK.

0 Kudos
lucasitteam
Enthusiast
Enthusiast

Hallo,

This is not going to help you but might give you some different thoughts.

USB is messed it when it comes to VDI.

I have several times tried and failed for various reasons.

I have spent so many hours of life in doing something which is by design not properly developed.

One might not believe my bold statement, just search USB redirection software. There are at least 10 vendors who are making business out of it.

I'm using one in house and found highly reliable. It just works everything.

0 Kudos
MrCheesecake
Enthusiast
Enthusiast

Take a look at this:  VMware Knowledge Base

It's not very clear but I've run into this in the past when machines have been cloned/renamed.  There are multiple certificates (based on machine name) that are generated and saved in the Computer Cert store within Windows.  Cleaning out the "VMware View" store and rebooting may help.

If you're using Linked/Instant clones, you'll have to do this on your parent/baseline VM.

0 Kudos
warana
Contributor
Contributor

Thanks for the comment. Maybe we can talk out of here and you can recommend me something. I am so frustrated with this situation.

0 Kudos
sjesse
Leadership
Leadership

If its only when UEM and appvolumes are used, try moving this to the UEM section first, I think I may have seen this there before UEMdev​?

0 Kudos
DEMdev
VMware Employee
VMware Employee

Thanks, sjesse, for looping me in – I've been busy on other things last week, and did not pay a lot of attention to the forum (as you might have noticed 🙂

warana​, there have indeed been issues between Horizon's USB redirection and UEM. These have been addressed in UEM 9.5 and Horizon agent 7.6.

However, I think these issues started with Horizon 7.4, so I'm not sure that this is what you're running into, given that you're on

7.0.3...

(EDITED to say "Horizon agent 7.6" rather than "9.6"...)

0 Kudos
warana
Contributor
Contributor

Well I am actually testing out 7.4 with Windows 10 in my environment and I have been having issues.

So you recommend I try running 7.6 with Windows 10? This is also dealing with the Agent and not the client software.

0 Kudos
BenFB
Virtuoso
Virtuoso

There are a number of known issues in 7.4 unrelated to USB support. I would recommend 7.8 or at a minimum 7.7.

0 Kudos
Kharibids
Contributor
Contributor

Have you tried adding this to your gold image?

HKLM\SOFTWARE\Immidio\Flex Profiles\  DWORD RegName: HorizonLogic RegValue: 0

We have also been fighting with USB redirect. If your using UEM then try that out if support haven't told you to already. From there we had to update to a new firmware on our zero clients. Its still not perfect but things that are plugged in when logging into a desktop work, hot plugging things while in the OS is still hit and miss. We are on 7.5.

0 Kudos
DEMdev
VMware Employee
VMware Employee

Hi warana,

Well I am actually testing out 7.4 with Windows 10 in my environment and I have been having issues.

So you recommend I try running 7.6 with Windows 10? This is also dealing with the Agent and not the client software.

Given that the USB redirection issue has only been fixed in Horizon agent 7.6+ (requiring UEM 9.5+), I would indeed not recommend 7.4.

And, as BenFB also recommended, it's maybe better to pick a more recent release anyway?

0 Kudos