gunnarb
Expert
Expert

Full 3D Video over VMware View... it's here!!!

http://www.amd.com/us/products/workstation/graphics/ati-firepro-3d/rg220/Pages/rg220-highlights.aspx

This is actually a little behind as this announcement was made two months ago but oh well I'm excited about it. Check out the datasheet, specifically page 2 which shows this:

Direct mapping from the VM to the GPU on this card. Not sure if View is capable of doing this yet, but you know VMware will be the first to adopt this technology; its using the PCoIP chipset so it was built for View. I can't seem to find a legit reseller yet so I don't think it's hit the streets, let me know if you know of one or have one of these cards.

This is different from the standard Teradici card that already exists because this card puts the GPU on the same card as the PCoIP Chip, thus eliminating the DVI cable coming out of your video card into the PCoIP chip, very cool.

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
29 Replies
SWCS833
Enthusiast
Enthusiast

This looks so promising but it sounds like from their documentation (who knows if it is accurate) that it may still be 1 to 1 with Virtual Machines.

Maybe VMWare can somehow make it 1 to Many Virtual Machines with this card. Time will only tell (I hope soon) or maybe an announcement at VMWorld 2010.

0 Kudos
Linjo
Leadership
Leadership

I got to look at one of these cards at a joint AMD - VMware event a few weeks ago, have not have the chance to play with it in my lab yet but AMD have promised to send me a few.

And yes (according to AMD) with VT-D (Directpath IO) these can be dedicated to virtual machines and get full 3D hardware accelerated graphics, compared to the HDX3D this is a far better approach.

Best regards,

Linjo

If you find this information useful, please award points for "correct" or "helpful".

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
gunnarb
Expert
Expert

That would be the ultimate goal but at least they can do a 1 to 1 with

a VM. It used to be 1 to 1 with a physical box, so that's a huge

step.

On Wed, Jun 23, 2010 at 4:40 PM, Defiant365

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
JesseF
Contributor
Contributor

Very interested in this topic, I have the card in my hands, just need to get it working. What is a good PCoIP thin client to use with it?

0 Kudos
gunnarb
Expert
Expert

You have a card! Where did you get it, how much was it?

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
JesseF
Contributor
Contributor

Not sure where my manager acquired it, but he was not sure how to use it an gave it to me. 5-600$?

0 Kudos
JesseF
Contributor
Contributor

Can anyone reccommend a portal to use for PCoIP?

  • PCoIP portal required, sold separately.

http://www.amd.com/us/products/workstation/graphics/ati-firepro-3d/rg220/Pages/rg220-highlights.aspx

0 Kudos
gunnarb
Expert
Expert

Hardware Devices: $400-$600

Samsung NC240

Samsung NC190

Dell FX100

Wyse P20

Software: Free-$20

View Client for Windows

View Client for Mac

Devon IT

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
JesseF
Contributor
Contributor

I am skeptical a Software viewer would work well for what I am trying to do (flash/video etc). I'll order up a Samsung monitor, seems like a decent form factor as opposed to a seperate thin client and monitor.

Thanks for the info!

0 Kudos
JesseF
Contributor
Contributor

So I just received the Wyse P20, I put the ATI RG220 in my workstation (wanted to test it w/o a VM first), loaded the Firepro drivers. Box came up fine, drivers loaded fine. I put the Wyse P20 on my switch, it got a DHCP address. I connected the Output RJ45 connection from the RG220 to my switch.

When I hit connect on the Wyse P20 is does not find any PCoIP devices. How do I figure out what my RG220 video card IP address is so I can try to manually connect? The Wyse tells me its IP, so no issue on that device.

Thanks!

0 Kudos
gunnarb
Expert
Expert

Pretty sure you need to use the PCoIP Management Console, this way you

can tell they device to connect to the host. However, you should be

able to do this manually on the P20.

Gunnar Berger http://www.gunnarberger.com http://www.endusercomputing.com
0 Kudos
JesseF
Contributor
Contributor

I looked at the switch and the Wyse has an address no problem, but the RG220 is not getting an address, it has link, but no IP.

I must need to configure something on the VGA Card?

0 Kudos
Linjo
Leadership
Leadership

Have you plugged in the correct port on the RG220? I think there are 2...

I would also upgrade to the latest firmware on both the portal and the RG220.

Best regards,

Linjo

If you find this information useful, please award points for "correct" or "helpful".

Best regards, Linjo Please follow me on twitter: @viewgeek If you find this information useful, please award points for "correct" or "helpful".
0 Kudos
AlfredL
Contributor
Contributor

Hi JesseF

The RG220 is configured to DHCP mode by default, so it should be able to obtain an IP address from your router. Did you connect theRG220 to your router before powering it up? If not, try this:




1) Power down your workstation

<span class="636450800-14082010">2) Check to ensure the RG220 is connected to the router. Also check to ensure the P20 is connected to the same router.

3) Power up your workstation.


4) Wait for about 15 secons for the RG220 to boot up and obtain an IP address from your router.


5) On the P20, check to see if thehost discovery feature is enabled. Hit the Connect button.


6) The P20 should list all PCoIP host on your network.




If that doesn't work, it is possible the RG220 network setting has been modified from its default setting. Perhaps to a static IP address. To fix this, you can perform a factory default reset. To do this:




1) Power down the workstation.


2) Short the RG220 factory default reset jumper (labelled JU3200), it is located at the lower right corner of the card.


3) Power up the workstation and wait for about 15 seconds.


4) Power down the workstation and remove the jumper




This should set the RG220 back to DHCP mode.




Thanks,




Alfred

0 Kudos
JesseF
Contributor
Contributor

Thanks!! The factory reset worked. Got an IP, connected from my Wyse P20. Works pretty well!

Played some video files and its pretty flawless.

The debate now is do I put my old video card back in the machine in addition to this card.

0 Kudos
JesseF
Contributor
Contributor

Also, audio is not working. I wonder what device should show up on my host machine.

0 Kudos
AlfredL
Contributor
Contributor

Audio is disabled by default. You can enable it via the RG220 web interface. Just enter the IP address of the RG220 using a web brower, go to the permission --&gt; audio tab and check the Enable Audio box.

If your host is using Windows XP, you will need to install the Realtek HD Audio Codec driver. http://www.realtek.com/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTyp...

For Vista and 7, the Windows native driver will work.

Thanks,

Alfred

0 Kudos
JesseF
Contributor
Contributor

Thanks again! This worked!

0 Kudos
JesseF
Contributor
Contributor

Also, how do I use VMware view to connect to this device, without a "View Connection Server".

Basically, I want to test out PCoIP without a zero client to see how the performance compares.

0 Kudos