admin275
Contributor
Contributor

VmWare does not allocate CPU for VM or VM doesn't request memory and CPU, therefore VM working slowly

There are big understanding questions, please see screen below. This VmWare server has big capacity. Anything VM and server has no restrictions or reservation, commonly all server is inde. But most loaded VM (inside it show 100% of processor loading) does not request a memory and CPU and therefore working very slowly. Why? What way to solve this problem?

0 Kudos
4 Replies
SureshKumarMuth
Commander
Commander

1.What slowness you are experiencing inside the VM ?

2.Is it slow only when you try to access from network ?

3.How does the VM behaves when you try operation from the VM console ?

Slowness always not necessarily caused due to CPU or memory. It could be due to many factors.

Regards, Suresh https://vconnectit.wordpress.com/
0 Kudos
Stanley_
Enthusiast
Enthusiast

first few questions.. could you please provide more details about the HW. how many pCPU/pCores frequency, RAM. Storage is local/NFS/FC/?

how many vCPU have the other VM's.

output from "esxtop"   wait , ready times?  or at least performance of storage counters (latency) and cpu, but counter (Wait, Ready) for memory (swap in, swap out), network packet loss

do you have deployed vROPs or vCOPs?

good place to start:

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=10083...

https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=20010...

0 Kudos
admin275
Contributor
Contributor

this is first small info about HW, more details little bit later

0 Kudos
admin275
Contributor
Contributor

strangeness that inside VM processor standing about 100%, in this VM working MS SQL Server, but outside VM (ie in Harwdare server on VmWare), server is standing without working,

nothing anything restrictions of this VM, I want to give maximum of hardware CPU performance, but my hardware CPU loading less than 10% of its capacity, so sql-server and web-site working slowly

0 Kudos