sc_2111
Enthusiast
Enthusiast

VMA 5.0 ip address pool required ?

Hi ,

I've downloaded and imported the VMA 5.0  472630

While importing it I noticed a warning about the fact that it requires an IP POOL but gave it no much importance as I wanted to assign a fixed IP.

So after the import I tried to start the VM but it fails with the error the no IP ADDRESS POOL was associated to the virtual lan.

So I created an IP POOL and associated it to the lan and have the VM booted.

after booting I was prompted for the initial network configuration .

I set a static IP , so I hoped to get rid off the IP POOL . But removing the association prevented again the VM from booting.

So my question is :

What the use for IP POOL if I want to use a static IP ?

Can I get rid of such requirement ?

thanks

0 Kudos
14 Replies
jslarouche
Enthusiast
Enthusiast

I am getting the same issue.. With no workaround as of yet. 

0 Kudos
jslarouche
Enthusiast
Enthusiast

if you right click your vMA 5.0 vm and edit it's settings.. Go to the Options Tab and disable vApp Options.. Once i did that on mine then i was able to boot the appliance. try that.. 

0 Kudos
marktbreaux
Contributor
Contributor

thanks jslarouche I was able to find the culprit because of you suggesting to turn off vApp. It is a setting in Advanced Property Configuration. You can get there by going to the vMA app > Edit settings> Options Tab > Under vApp Options > Select Advanced. From there you will see a Properties box. The top key listed in the culprit. Its labeled "vami.DNS0.<nameofyourappliance>"

Not sure its function. Maybe someone else can explain but deleting that key will prevent the error. Also disabled vApp will too but I thought that I should keep it as original as possible.

Edit: Looks like any of the dynamic keys in there will through it for a loop. I changed to static and filled in my static entries.

0 Kudos
BenjaminTroch
Contributor
Contributor

I had the same error. If you go into Edit Settings\Options\Advanced\IP Allocation and under IP Allocation Scheme tick "OVF environment" it does the trick and the VMA boots with vAPP options enabled.

Cheers,

Benjamin

0 Kudos
1q2w3e4r
Contributor
Contributor

I had a similar issue, I have the vCloud Usage Meter which is an appliance from vmware. I rebooted it to update the virtual machine hardware from 7 to 8, but not sure whether it was this upgrade or the fact that I needed an IP pool to deploy the appliance which I had subsequently deleted (since I don't use DHCP for my VMs), and then the reboot was looking for this and couldn't find it?

In any case I could no longer boot the vm with the vami.dns0.. error which was a bit shitty, so I just disabled the vApp options (edit settings->options tab->vApp options->disable), and now I'm back in business.

0 Kudos
AnthonyChow
Hot Shot
Hot Shot

sc_2111@vmtn wrote:

So I created an IP POOL and associated it to the lan and have the VM booted.

after booting I was prompted for the initial network configuration .

I set a static IP , so I hoped to get rid off the IP POOL . But removing the association prevented again the VM from booting.

I am seeing the same problem and I see from the other posting how to fix it.

I have created the IP pool at the Datacenter level.  Just wanted to know how do you associate the IP pool to the vm port group?

thanks for the information,

anthony.

0 Kudos
JoyYu
Contributor
Contributor

Hi, jslarouche

thanks!  Your sugguestion works perfectly for me!!  Thanks!

Smiley Happy

Joy

0 Kudos
sanjai2k
Enthusiast
Enthusiast

Thanks, It worked like a charm for vMA 5.0 Smiley Happy

0 Kudos
rogue33
Contributor
Contributor

Disabling the vApp options worked for me too.

Jeff Jones
0 Kudos
CJConnell
Contributor
Contributor

In vma 5.0, disabling the vApp options worked here also.

Chris

0 Kudos
billdossett
Enthusiast
Enthusiast

Just wanted to flag that this is also a problem with VMA 5.1 - it complains about the address pool when installing - but then it won't start and it claims that it is because there is no network protocol profile associated with the network... so even more confusing.. Luckily I remembered the address pool message, typed that in and found this post again as it fixed the problem!  Thanks

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.
0 Kudos
vvv850
Contributor
Contributor

I am experiencing the same with vMA 5.1.

0 Kudos
keltm
Contributor
Contributor

+1 for disabling the vApp options.  vMA-5.0.0.2-724898.

0 Kudos
JoyYu
Contributor
Contributor

I will be out of the office from 4/2 - 4/5. If you need assistance, please contact Centralized Systems on-call at 703-299-2964 or email winops@pbs.org<mailto:winops@pbs.org>.

Thanks!

Joy Yu

0 Kudos