3APA3A
Contributor
Contributor

TIP: for those affected by 'microcode levels not supported' pink screen at installation (cpu stepping mismatch, tlb bug, etc.)

Here is the solution I have found:

  • at installation boot press Shift-o

  • type in the kernel advanced option: skipMicrocodeCompatCheck

  • to make it permanent after installation type at command line: esxcfg-advcfg -k TRUE skipmicrocodecompatcheck

Works for me on Dell PE SC1435 with dual quad-core AMD Opteron 2350 and ESXi 4.0

Enjoy!

0 Kudos
19 Replies
eharvill
Enthusiast
Enthusiast

At what point exactly do you hit shift-o? Which version of ESX are we talking about here? I've tried with ESX4i and ESX4 classic and shift-o does nothing at their respective boot menus. In ESX4 classic I hit F2 and added "skipMicrocodeCompatCheck" to the boot options to no avail. Any thoughts?

0 Kudos
eharvill
Enthusiast
Enthusiast

sorry, doublepost

Message was edited by: eharvill

0 Kudos
3APA3A
Contributor
Contributor

The post was for those who experience 'pink screen' problem during the installation, i.e. they could not install because of the 'microcode levels not supported' error. Shift-o works when you see a progress bar during boot. If you are able to boot and install ESXi 4.0 then you seem not to be affected.

0 Kudos
Roshando
Contributor
Contributor

Hi, Please help me out, I can't figure the Shift-o. I tried several ways on ESXi but keep getting the pink screen. When do hit shift-o? Tried it before and after the menu screen install ESXi or boot to local disk screen choice. I tried hitting tab and tried typing it in the command line. I also tried to add it to the existing command line listed.

Besides hitting tab, I cannot get to any command line. I can't figure out the Shift-o (o for oscar) part.

Btw I can disable the 298 TLB problem with my board, it's currently disabled and it doesnt make a difference.

Thanks in advance.

-R

0 Kudos

You use the tab key when you're installing ESXi and shift+o when booting it up. http://www.vm-help.com/esx40i/vmkernel_boot_options.php




Dave

VMware Communities User Moderator

New book in town - vSphere Quick Start Guide -http://www.yellow-bricks.com/2009/08/12/new-book-in-town-vsphere-quick-start-guide/.

Do you have a system or PCI card working with VMDirectPath? Submit your specs to the Unofficial VMDirectPath HCL - http://www.vm-help.com/forum/viewforum.php?f=21.

0 Kudos
Roshando
Contributor
Contributor

Thanks for the super fast reply. That helped a lot. The key is to type it after vmkboot.gz. My problem is I tried typing it after the other gz entries.

Much Thanks!

-R

0 Kudos
3APA3A
Contributor
Contributor

Sorry for the confusion. Dave is right, Shift-O works on boot, TAB on install. I almost never install ESXi, I just use pre-built USB drive to boot a new server right away.

0 Kudos
eku1
Contributor
Contributor

Thank you very much - you saved the day for me. I've been struggling with this for almost a year - gave up on it for most of the time until now.

0 Kudos
eku1
Contributor
Contributor

Is there a trick to making the boot argument permanent? I have to enter "esxcfg-advcfg -k TRUE skipmicrocodecompatcheck`` every time I reboot the machine. This isn`t the practical in case the power goes out and I want it to reboot automatically.

0 Kudos
3APA3A
Contributor
Contributor

That command actually makes it permanent. The fact that you are able to boot without the pink screen proves that the setting is there.

0 Kudos
eku1
Contributor
Contributor

Perhaps we were talking about 2 different "permanent" settings. I'm trying to prevent me having to type those settings in every time the physical machine is rebooted/power-cycled. Right now if I don't type those commands in at boot progress bar (shift-o ....), I do get the purple screen complaining about the CPU. If I do enter those parameters as the advanced boot arguments, everything works fine until the next time the physical machine is rebooted.

0 Kudos
3APA3A
Contributor
Contributor

Try to change the second line of /bootbank/boot.cfg to read:

kernelopt=skipMicrocodeCompatCheck=TRUE

0 Kudos

If the setting is properly changed then it will survive a reboot.

To check that the command actually made a change, download esx.conf with vifs from the vCLI and you should see the setting there. You can also change this in the vSphere client by going to Advanced Settings in the vSphere client - http://vm-help.com/esx/esx3i/esx_3i_rcli/vicfg-advcfg.php. It'll be under VMkernel\boot. If you do change it in /bootbank also make sure to change /altbootbank. But if using the vCLI or client isn't working for you then you may have an issue with the configuration backup process.






Dave

VMware Communities User Moderator

Now available - vSphere Quick Start Guide

Do you have a system or PCI card working with VMDirectPath? Submit your specs to the Unofficial VMDirectPath HCL.

0 Kudos
3APA3A
Contributor
Contributor

You are right. On my server it is present as /vmkernel/skipMicrocodeCompatCheck = "TRUE" at the end of /etc/vmware/esx.conf

0 Kudos
eku1
Contributor
Contributor

I probably should have mentioned this earlier - I`m currently using ESXi 4.0.0 build-208167. There is no such setting under VMKernel\boot in vSphere client. I`ll try the alternate suggested solutions and post observations. Thanks.

Update - I did get the esx.conf file:

vifs.pl --config c:\VMs\myconfig.txt --get /host/esx.conf c:\VMs\esx.conf

Downloaded file to c:\VMs\esx.conf successfully.

and it does NOT have the skipMicrocodeCompatCheck setting even though I typed it at boot-up. I tried to upload the file after modification with:

/vmkernel/skipMicrocodeCompatCheck = "TRUE"

but no luck:

vifs.pl --config c:\VMs\myconfig.txt --put c:\VMs\esx.conf /host/esx.conf

Error: File c:\VMs\esx.conf can not be uploaded to esx.conf.

I also tried uploading the same file I downloaded with same rejection.

0 Kudos

Are you using the free edition of ESXi? You might just try editing the file or running esxcfg-advcfg at the console or via SSH.




Dave

VMware Communities User Moderator

Now available - vSphere Quick Start Guide

Do you have a system or PCI card working with VMDirectPath? Submit your specs to the Unofficial VMDirectPath HCL.

0 Kudos
eku1
Contributor
Contributor

Yes, I`m using ESXi. When I use esxcfg-advcfg on the physical machine I have success; however, via the VMware vSphere CLI I have no luck:

esxcfg-advcfg.pl --config c:\VMs\myconfig.txt -k TRUE skipmicrocodecompatcheck

Option VMkernel.Boot.skipmicrocodecompatcheck not found.

0 Kudos
eku1
Contributor
Contributor

Success.

Following these steps:

1) At the console of the ESXi host, press ALT-F1 to access the console window.

2) Enter unsupported in the console and then press Enter. You will not see the text you type in.

3) If you typed in unsupported correctly, you will see the Tech Support Mode warning and a password prompt. Enter the password for the root login.

4) You should then see the prompt of ~ #.

5) Type esxcfg-advcfg -k TRUE skipmicrocodecompatcheck.

The setting is now saved on reboot. I tried editing the esx.conf file manually and the setting was rewritten upon reboot. Also, I am not sure why it is not saved when the same esxcfg-advcfg command is entered upon bootup. Either way, thank you very much experts. You have been very helpful on this at times very painful journey.

0 Kudos
mrdvmware
Contributor
Contributor

-After installing ESXi  press:- shift o, while it's booting up.

-then type:- skipMicrocodeCompatCheck

-At the menu hit F2 and select troubleshooting options

-Enable ESXi shell

-ALT F1, and put your username and password in or just type:- root and hit enter, if you haven't already set the password up.

type:- esxcfg-advcfg -k TRUE skipmicrocodecompatcheck

-Then check that the change has been made using vi, type:- vi /etc/vmware/esx.conf   look for this line in the file:-

/vmkernel/skipMicrocodeCompatCheck = "TRUE"

-If it is great, now we have to save the change from memory to disk, type:-

/sbin/auto-backup.sh /etc/vmware/esx.conf and hit enter.

-then type:- reboot (the machine will reboot eventually and no more entering the skipmicrocodecompatcheck at bootup.

reference this article on how the esxi shell operates:-

http://www.virtuallyghetto.com/2011/08/how-to-persist-configuration-changes-in.html:-

So why does editing files in ESXi filesystem not persisted across system reboots? The reason for this is ESXi uses an in-memory filesystem. For more details, check out The

Architecture of VMware ESXi whitepaper by VMware. As I mentioned earlier, the persistence of files will depend on what was updated as there are exceptions to the rules.

0 Kudos