jfraslin
Contributor
Contributor

PowerCLI script remove/create snapshot in ESXi5.5

Jump to solution

Good Morning,

Last week i have upgrated one of my host from esxi5.1 to 5.5

everythink works exepted one of my powerCLI script.

On my host 5.5 i cannot run anymore a remove/create snapshots:

Remove-Snapshot : 14/11/2013 13:45:37Remove-Snapshot    Current license

or ESXi version prohibits execution of the requested operation.

At line:1 char:92

+ Get-VM | Get-Snapshot | Where {$_.Created -lt ((Get-Date).AddHours(-46))} | R

emove-Snapshot <<<<  -Confirm:$false

+ CategoryInfo      : NotSpecified: (:) [Remove-Snapshot], RestrictedV

   ersion

+ FullyQualifiedErrorId : Client20_VMServiceImpl_RemoveSnapshot_ViError,VM

   ware.VimAutomation.ViCore.Cmdlets.Commands.RemoveSnapshot

Some feature has been remove en 5.5?

Thank you

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

I suppose that's not possible. This has been already discussed in the communities. Please have a look at this thread. https://communities.vmware.com/message/2211533

~dGeorgey

View solution in original post

0 Kudos
6 Replies
admin
Immortal
Immortal

The error is self explanatory.  "Current license or ESXi version prohibits execution of the requested operation."

~dGeorgey

0 Kudos
jfraslin
Contributor
Contributor

Thank you but that was not the case in 5.1.

That means is not possible anymore to run command through powerCLI in 5.5 (API).

I'm looking into the documentation and this restriction was not mentioned.

Thank you

0 Kudos
admin
Immortal
Immortal

I think  you are running a free version of ESXi.

PowerCLI can not run against the free version of ESXi. Unfortunately remote management tools are not supported on the free version. That is why you’re getting that error.

~dGEorgey

0 Kudos
jfraslin
Contributor
Contributor

Thank you for your help.

That is correct i m using the free version.

Do you know if is possible to buy just a kind of "api module" to be able to use the remote management tools?

Have a good day

0 Kudos
admin
Immortal
Immortal

I suppose that's not possible. This has been already discussed in the communities. Please have a look at this thread. https://communities.vmware.com/message/2211533

~dGeorgey

View solution in original post

0 Kudos
jfraslin
Contributor
Contributor

Thank you, so to resume, it was enabled by error in 5.1 and that has been corrected by Vmware in 5.5.

Thank you for your help.

0 Kudos