NLDPHUONG
Contributor
Contributor

Module Disk power on failed

Jump to solution

Hi there,

I have an vmware with two harddrive (200GB and 400GB). I did a snapshot.

Today, I want to move that vmware to other vcenter (6.0) by use vmware converter 6.0. The source vmware was stopped. It took too much time so I canceled that job. After that, I got "Module Disk power on failed" when start the current vmware.

Please help me restore this. I can't find any .lck file.

I want to restore my last snapshoot but I afraid the problem will be worse.

Many thanks.

0 Kudos
1 Solution

Accepted Solutions
NLDPHUONG
Contributor
Contributor

I think I find the problem

vmkvsitools lsof | grep <vmware-name>

13638802    cp                    DIR                         3   <vmware-name>

13638802    cp                    FILE                        4   <vmware-name>/<vmware-name>_2-flat.vmdk

7400038     vpxa-worker           FILE                       17   /vmfs/volumes/<storage-id>/<vmware-name>/<vmware-name>_2-000001-delta.vmdk

7400038     vpxa-worker           FILE                       22   /vmfs/volumes/<storage-id>/<vmware-name>/<vmware-name>_2-flat.vmdk

7400038     vpxa-worker           FILE                       25   /vmfs/devices/deltadisks/c03b895-<vmware-name>_2-000001-delta.vmdk

ps | grep 7400038

7816797   7400038  vpxa-worker

7400038   7400038  vpxa-worker

7400049   7400038  vpxa-worker

7400050   7400038  vpxa-worker

7400051   7400038  vpxa-worker

7334516   7400038  vpxa-worker

7400053   7400038  vpxa-poll

7400055   7400038  vpxa-worker

7400058   7400038  vpxa

7400282   7400038  vpxa-worker

7400558   7400038  vpxa-worker

7400559   7400038  vpxa-worker

7400635   7400038  vpxa-worker

7400636   7400038  vpxa-worker

I think if I kill that process or restart the host, the problem will gone. Wait a minute for complete the backup, I'll be back.

View solution in original post

0 Kudos
2 Replies
NLDPHUONG
Contributor
Contributor

Anyone help me, please!

The picture is all files in vmware folder

0 Kudos
NLDPHUONG
Contributor
Contributor

I think I find the problem

vmkvsitools lsof | grep <vmware-name>

13638802    cp                    DIR                         3   <vmware-name>

13638802    cp                    FILE                        4   <vmware-name>/<vmware-name>_2-flat.vmdk

7400038     vpxa-worker           FILE                       17   /vmfs/volumes/<storage-id>/<vmware-name>/<vmware-name>_2-000001-delta.vmdk

7400038     vpxa-worker           FILE                       22   /vmfs/volumes/<storage-id>/<vmware-name>/<vmware-name>_2-flat.vmdk

7400038     vpxa-worker           FILE                       25   /vmfs/devices/deltadisks/c03b895-<vmware-name>_2-000001-delta.vmdk

ps | grep 7400038

7816797   7400038  vpxa-worker

7400038   7400038  vpxa-worker

7400049   7400038  vpxa-worker

7400050   7400038  vpxa-worker

7400051   7400038  vpxa-worker

7334516   7400038  vpxa-worker

7400053   7400038  vpxa-poll

7400055   7400038  vpxa-worker

7400058   7400038  vpxa

7400282   7400038  vpxa-worker

7400558   7400038  vpxa-worker

7400559   7400038  vpxa-worker

7400635   7400038  vpxa-worker

7400636   7400038  vpxa-worker

I think if I kill that process or restart the host, the problem will gone. Wait a minute for complete the backup, I'll be back.

0 Kudos