kendzi87
Enthusiast
Enthusiast

Intel network card I219-LM not working with ESXi 6.5

I have platform with  I219-LM network controller:

lspci -v | grep "Class 0200" -B 1

0000:00:1f.6 Ethernet controller Network controller: Intel Corporation Ethernet Connection (3) I219-LM [vmnic0]

         Class 0200: 8086:15b9

It is recognize as vmnic0, but when I list NIC there it is not there:

esxcli network nic list

Name    PCI Device    Driver  Admin Status  Link Status  Speed  Duplex  MAC Address         MTU  Description

------  ------------  ------  ------------  -----------  -----  ------  -----------------  ----  ---------------------------------------------------------------------------

I have also esxi 6.0 u3 where the same card is visible :

lspci -v | grep "Class 0200" -B 1

0000:00:1f.6 Ethernet controller Network controller: Intel Corporation Ethernet Connection (3) I219-LM [vmnic0]

         Class 0200: 8086:15b9

esxcli network nic list

Name    PCI Device    Driver  Admin Status  Link Status  Speed  Duplex  MAC Address         MTU  Description

------  ------------  ------  ------------  -----------  -----  ------  -----------------  ----  -------------------------------------------------

vmnic0  0000:00:1f.6  e1000e  Up            Up            1000  Full    90:49:fa:00:de:7d  1500  Intel Corporation Ethernet Connection (3) I219-LM

Further investigation of Esxi 6.5 dmesg gives:

WARNING: Device: 2223: Failed to start device 0x4303459d49e0 p0000:00:1f.6 808615b980860000020000


In release notes there is only information "Intel i219 NIC might hang and lose networking connectivity", so I assume it should work.

Is there a way to make it work with esxi 6.5? Or to extract e1000e driver from esxi6.0 ISO (or system) andinstalll it on 6.5?

0 Kudos
4 Replies
MattiasN81
Hot Shot
Hot Shot

Hi

This problem is widley known by the community and the I219 seriers isn't the only cards having problem with the new ne1000 and e1000e drivers in 6.5

You can try to follow my workaround in this thread and see if it solves the issue, its written for the Intel 82577LM NIC but these cards have the exact same problems as the i219 cards

Re: Intel 82577LM should work out-of-the-box on esxi 6.5 but doesn't. Ideas, why?

VMware Certified Professional 6 - DCV VMware VTSP Software Defined Storage Dell Blade Server Solutions - EMEA Certified Dell PowerEdge Server Solutions - EMEA Certfied Dell Certified Storage Deployment Professional Dell EMC Proven Professional If you found my answers useful please consider marking them as Helpful or Correct
0 Kudos
kendzi87
Enthusiast
Enthusiast

Hi,

I tried your workaround, unfortunately it didn't work for me Smiley Sad

0 Kudos
MattiasN81
Hot Shot
Hot Shot

It seems that VMware made a misktake putting the kaby lake on the HCL, they will remove the cards from the HCL shortly.

Still, the NUCs are quite popular to run as a homelab so im sure v-front will dig in to this and make a modified driver Smiley Happy

http://www.virtuallyghetto.com/2017/02/update-on-intel-nuc-7th-gen-kaby-lake-esxi-6-x.html

VMware Certified Professional 6 - DCV VMware VTSP Software Defined Storage Dell Blade Server Solutions - EMEA Certified Dell PowerEdge Server Solutions - EMEA Certfied Dell Certified Storage Deployment Professional Dell EMC Proven Professional If you found my answers useful please consider marking them as Helpful or Correct
kendzi87
Enthusiast
Enthusiast

Thanks, virtuallygheto lead me to Heads Up – ESXi not working on 7th Gen (Kaby Lake) Intel NUC7 | Virten.net so I am going to keep an eye on the topic.

0 Kudos