fradp97
Contributor
Contributor

ESXi intel 219-v ASUS PRIME B560M-A

I came from here. But only now I can see the old date of the post so I write a new one.

I buy this motherboard specifically for the reason that it have a native compatible integration with esxi apparently, in fact I search for Intel I219-V on HCL and see multiple results:

Model Device Type Brand Name Number Of Ports VID DID SVID SSID 
Ethernet Connection (4) I219-VNetworkIntel Corporation0808615d800000000
Ethernet Connection (5) I219-VNetworkIntel Corporation0808615d600000000
Ethernet Connection (6) I219-VNetworkIntel Corporation0808615be00000000
Ethernet Connection (7) I219-VNetworkIntel Corporation0808615bc00000000
Intel Ethernet Connection (2) I219-VNetworkIntel Corporation0808615b800000000
Intel Ethernet Connection I219-VNetworkIntel Corporation08086157000000000


and I thought I was okay. But when I tried to install ESXi 7.0.2 it was not found so I'm sadly here.

I buy (in really I already have) a USB-NIC like this and follow this and succesfully installed the esxi. But now I wish I can use the integrated NIC because I bought it specifically for the compatibility 😞

I also use from cli:
lspci -v | grep -A1 -i ethernet
0000:00:1f.6 Network controller Ethernet controller: Intel Corportation Ethernet Connection (14) I219-V
Class 0200: 8086:15fa

but if I use esxcli network nic list I can see the adapter only.

So:
VID = 8086
DID = 15fa
SVID = 0000
SDID = 0000

I don't know if I need the same number before the I219-V word but it seems a little too much precise to understand if it is compatible before buying the MoBo with the integrated NIC. After installing all the system I have evicence of VID and DID (that doesn't exist inside HCL) but before seems impossible. Is there something I can do with this integrated NIC?

_____

Integrations and help for who need:
The istructions linked before are not very precise and functional so these are the powershell commands I used to create the custom image for the nic:

 

 

Install-Module -Name VMware.PowerCLI -Scope CurrentUser -AllowClobber
powershell -ep bypass
Import-Module VMware.ImageBuilder
Add-EsxSoftwareDepot https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
Get-EsxImageProfile
'''
...
ESXi-7.0U2d-18538813-standard
...
'''
Export-ESXImageProfile -ImageProfile "ESXi-7.0U2d-18538813-standard" -ExportToBundle -filepath ESXi-7.0U2d-18538813-standard.zip
Remove-EsxSoftwareDepot https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
Add-EsxSoftwareDepot .\ESXi-7.0U2d-18538813-standard.zip
Add-EsxSoftwareDepot .\ESXi702-VMKUSB-NIC-FLING-47140841-component-18150468.zip
New-EsxImageProfile -CloneProfile "ESXi-7.0U2d-18538813-standard" -name "ESXi-7.0.2-18150468-USBNIC" -Vendor "virten.net"
Add-EsxSoftwarePackage -ImageProfile "ESXi-7.0.2-18150468-USBNIC" -SoftwarePackage "vmkusb-nic-fling"

# for instal
Export-ESXImageProfile -ImageProfile "ESXi-7.0.2-18150468-USBNIC" -ExportToIso -filepath ESXi-7.0.2-18150468-USBNIC.iso

# for upgrade
Export-ESXImageProfile -ImageProfile "ESXi-7.0.2-18150468-USBNIC" -ExportToBundle -filepath ESXi-7.0.2-18150468-USBNIC.zip

 

 

0 Kudos
1 Reply
fradp97
Contributor
Contributor

Finally, after hours of searches, it seems I find the solution:
Install this VIB:
https://flings.vmware.com/community-networking-driver-for-esxi

But after reboot I not have nic warnings, I can set the IP but it cannot talk to anyone 😞

Update: i can ping 127.0.0.1 but no others, now I suspect this past it's my fault but I can't find the problem. I'm like in this situation.
Final solution: I follow the OP suggestion of situation link and I can't belive that it really works! Enabling WoL and network stack (no PXE required) from bios and boot anyway from disk fix this non-sense issue!

Tags (1)
0 Kudos