ESXI 6.0 on Cenerlon n3150 (Braswell platform)


I am attempting to assemble a cheap vm box for my amusement and learning. if everything works, it may become the pfsense / xpenology nas / vpn gateway box at my parents house...

I purchased an Asrock n3150m matx board for $100 cdn (ASRock > N3150M

basically a lower clocked pentium n3700. It was in stock, while the n3700 variant was not. For $20 more I would have taken the n3700 variant if available.

this is the new braswell series of 14nm el'cheapo atoms chips: ARK | Intel® Celeron® Processor N3150 (2M Cache, up to 2.08 GHz)

I got the matx version versus itx due to the extra pcie slots; I have some spare intel dual lan pcie cards, sil3124 sata cards,etc. Had some spare ddr3, a spare kingston 128gb ssd, and a 350w psu. bought a new case. everything is working. updated to the latest 1.10 bios.

the system is up and running. I cannot get hyper v server 2012 r2 to install as it gives me a hypervisor error upon reboot and does not finish the install. Tried server 2012 r2, which works until I install the hyper-v add-on, and the same issue. hyper v server 2016 preview 3 works flawlessly.

I could not get exsi 5.5u2 or 6.0 with u1 update to work. Both hang at " Relocating modules and starting up the kernel". I attempted to patch version 6 with the sata drivers using one of the tools I found online and also with powercli - no dice.

I tried creating custom images as per: How to fix ESXi on Intel NUC malformed Manufacturer and Model | and ESXi 6.0 Image for Intel NUC |

Recall, this cpu os basically the same thing as the braswell nuc. I have disabled parallel port and serial ports, changed onboard video ram settings, disabled the on-board realtek lan, etc. and no dice. I am at my wits end.

I installed windows 10 and installed vmware workstation 12, and it works perfectly. I would prefer to avoid this option. Any ideas how I could get esxi 6 to work on this?

15 Replies

Hi Philip and welcome to the forums!

Can you please check if you have Intel VT-d and NX/XD (Execute Disable Bit) both enabled in the system's BIOS?


Twitter: @VFrontDe, @ESXiPatches | |
0 Kudos

yes, they are enabled

if install windows 10 and install vm workstation 11 or 12, everything works

it appears that I need to patch in stat, achi, and video drivers into the iso of the installer using powercli.

what would the commands for adding drivers to such an iso be? (in the same directory)

what command creates a new iso with them in same?

0 Kudos

after much screwing around, i figured out how to patch the iso, but still not luck as it hangs on the "Relocating modules and starting up the kernel…”

I downloaded the latest iso of esxi 6.0 to c:\exsi (pardon the error) and downloaded the following drivers from here: as the nuc has similar specs to my setup (minus the dual intel lan card which is supported in version 6). I then used VMware Front Experience: ESXi-Customizer-PS (VMware Front Experience: ESXi-Customizer-PS) in Power CLI to patch the iso:

"PowerCLI C:\exsi> .\ESXi-Customizer-PS-v2.4.ps1 -pkgdir c:\exsi

Script to build a customized ESXi installation ISO or Offline bundle using the VMware PowerCLI ImageBuilder snapin
(Call with -help for instructions)

Logging to C:\Users\messe\AppData\Local\Temp\ESXi-Customizer-PS.log ...

Running with PowerShell version 5.0 and VMware vSphere PowerCLI 6.0 Release 2 build 3056836

Connecting the VMware ESXi Online depot ... [OK]

Getting Imageprofiles, please wait ... [OK]

Using Imageprofile ESXi-6.0.0-20150902001-standard ...
(dated 09/03/2015 14:04:26, AcceptanceLevel: PartnerSupported,
For more information, see

Loading Offline bundles and VIB files from c:\exsi ...
   Loading C:\exsi\ ... [OK]
      Add VIB net-e1000e [New AcceptanceLevel: CommunitySupported] [OK, replaced 2.5.4-6vmw.600.0.0.2494585]
   Loading C:\exsi\e1000e- ... [OK]
      Add VIB net-e1000e [IGNORED, already added]
   Loading C:\exsi\sata-xahci-1.27-1.x86_64.vib ... [OK]
      Add VIB sata-xahci 1.27-1 [OK, added]

Exporting the Imageprofile to 'C:\exsi\ESXi-6.0.0-20150902001-standard-customized.iso'. Please be patient ...

All done."

I get the same issue as it starts up and hangs at "Relocating modules and starting up the kernel…”

After a google search I found:

and on start up hit "shift+o" and entered "runweasel ignoreHeadless=True" and hit enter. Same issue of it hanging on  "Relocating modules and starting up the kernel…”

I can install windows 10 and use VM Workstation 12 without issue, but I would prefer to simply use esxi 6 directly.

0 Kudos


do you have got the hypervisor running on your machine?

i'm looking forward to buy the same cpu inside a zotac ZBOX CI323 nano.



0 Kudos

I found more than one statement, where someone said frustrated that it is impossible to use ESXi with these boards.

But Nelson Mandela said, “It always seems impossible until it’s done.”

So first of all the good news – I made it running!


On this platform a standard ESXi installation hangs with a last message “Relocating modules and starting up the kernel” …

I found out, that at this point the ESXI system is already working.
It can be “pinged” but login is failing due to failure completing the installation process (no password set, no management network configured, SSH disabled).

I suggest that the onboard graphics can’t be used by ESXi installer for console and there could be a switch to the serial port console.

Here are some hints from VMware documentation:

Q: What system configuration triggers ESXi to switch its console to a serial port?
A: During system boot up, if ESXi finds No VGA Present or Headless flag set in ACPI FADT table and if there is no user specified change in any of the serial services, the DCUI service will display on a serial port.

Ok, we have an unsupported and “headless” platform without graphical local console.
Give up now or find a solution?

First of all I posted a VMware feature request on their official site to support this platform in the future and in the second step I thought about a workaround for the meantime 🙂

I found three ways to get a working ESXi system on this platform and tested one of them successfully.

Option 3 / Install ESXi 6.0 on bootable USB Stick using a virtual machine with VMware player

Continue and read the documentation about this solution on my blog at:

Greetings Antonio

0 Kudos

there are any updates?

This issue still exist on Zotac CI323

0 Kudos

Well, I've got Windows Server 2012 R2 running with Hyper-V on my CI323 nano after thinkering a bit.

The obvious problem are the drivers, or at least the dirvers where the problem ( the system would crash on boot with VT turned on ).

The solution that I've used is to download all the Windows 8/8.1 drivers from the zotac site + the Intel chipset driver from JetWay site for NP591 board ( the newest inf dirver on the JetWay site is dated 02.june 2016.) and integrated the divers into the install and boot wim files using dism.

After installing the Windows Server 2012 R2 did all the possible updates, and only then I've added the Hyper-v role to the Windows. ATM I'm running a virtualised Untangle firewall on my CI323.

The next step is getting ESXI running on my CI323 or Hyper-v Server, the later could be a problem since the system crashes as soon as it's installed on first boot, so there is no possibility to update the server ( could try updating the server with VT turned off in BIOS).

Anyway, if someone is intrested I'm willing to help.

Kind regards,



Any updates on installation of ESXi 6.0 on Zotac Ci323 nano  ( 8G RAM and 120GB Samsung 750 EVO SSD )  ? 

I tried below installers and all FAILED with  same error " Relocating modules and starting up the kernel"




I'm able to install Kali linux,Redhat linux, pfSense firewall, Sopho XG firewall, Sopho UTM 9 and last but not least XenServer on Zotac Ci323 nano , I would like to know why I can't install ESXi 6.0 on this nifty hardware.

VM Ware community help is much appreciated as I can't continue with my study using ESXi.


0 Kudos

I got the same problem on my Zbox CI323

Much appricared if someone can help figure out the culprit.

0 Kudos

For those are trying to make a Celeron n3150 work the instructions are rather simple but you do need to do some work and have at least one working machine to do an install onto a USB thumb drive with.  I've also included an image snapshot of the white box ESXi server on a CI323.

Standard disclaimer VMware wont' be supporting this and you'll have to figure out how to use ESXi-Customizer.

1) Make an image using ESXi-Customizer that contains your network driver for your n3150 system and the network driver for the installing machine if different and the sata-xachi driver.

2) Install it on to the USB stick, once done reboot, let it boot on the installing machine

3) Setup the IP address information up and shutdown the machine

4) Plug the USB Stick into your n3150 system and power on the machine make sure to set up the boot device to the USB stick partition 1, and save.

5) Let it boot once you get stuck on "Relocating modules and starting up the kernel", power the n3150 system down.

6) Unplug the keyboard, and the monitor they are now useless for awhile..

7) Power on and wait about 5 to 10 minutes..  (less time really but why not right?)

😎 Connect using the client to the IP address from any computer in your network

That's it.. if you find it useful, like the post, image of the result is attached. 🙂



thanks to learningvms's post I was able to get my Zotac CI323 running with ESXi6.  I can connect to the bare metal server with my vmware client, but as far as the actual keyboard/vga console on the Zotac box, its still stuck on "Relocating modules and starting up the kernel".  Do we just not have option to use the console here?

0 Kudos

It seems that way with no options, the only console I can get is the SSH one.   Meaning if it's a real failure it's not going to be very useful to debug in real time, but can still do plenty from the vmware client.

Since it's only for "play" I'm far less concerned, but the dual network ports are nice to play with.

0 Kudos

Hi, what exact drivers did you use with the ESX Customizer to make this work? I have a CI323 and used these 2 but I still can't ping or get to the ESX when it's booted off the CI323 and If I put the USB into a laptop it boots fine and I can ping it. But in the CI323 it just doesn't respond.

0 Kudos

all the Windows 8/8.1 drivers from the zotac site + the Intel chipset driver from JetWay site for NP591 board ( the newest inf dirver on the JetWay site is dated 02.june 2016.) and integrated the divers into the install and boot wim files using dism.

Thanks for a great post. I have a few queries BrunoSmi‌ - I'd appreciate if you could help clarify a bit more.

There probably a lot more & updated drivers on there now.

I see an Intel Chipset INF update on Zotac site:

CI323 Intel INF update (Win 7 64bits, Win 8.1 64bits & Win 10 32/64bits)

OS: Windows 10


And an Intel Chipset INDF on the Jetway Site:

Drivers for NP591
Windows 7 (64 bit) Windows 8.1 (64 bit) Windows 10 (32/64 bit)

Extracted Setup file from Jetway properties/ details show Ver

Am I on the right track? I don't see any way to determine the dates of the same? Which of these is more suitable/ latest etc?

Please do share your thoughts. (PS: Also Zotac page has lots of drivers for other things as well - Did you mean all of them?)

After installing the Windows Server 2012 R2 did all the possible updates

Here, do you mean Windows Updates from Microsoft or something else? Did this include any drivers from Microsoft over writing the ones over the above Zotac/ Jetway ones?

Also, I am considering doing this with Win 8.1 x 64 if possible (since they are the same gen as Win 2012 R2) - Any pros/ cons? Thoughts?

My goal is also to run a Sophos or Untangle in a VM.

0 Kudos

Try the r8168 drivers.

0 Kudos