ShibbyB
Enthusiast
Enthusiast

AutoDeploy - Filename: tramp Could not chain image: Operation not supported

Trying to setup AutoDeploy with vSphere 5.1 on my Dell T310's utilizing the documentation for the Auto Deploy Proof of Concept Setup from the Install and Setup guide. Using Windows DHCP, specified the Auto Deploy server IP in the Boot Server Host Name and undionly.kpxe.vmw-hardwaired for the Bootfile Name. Utilizing the TFTP server from WinAgents as mentioned in the guide.

Configured the server to boot to PXE, and received the following error:

photo.JPG

I've tried updating the BIOS of the server, as well as the firmware of the Broadcom adapter, same error message. Any Suggestions?

8 Replies
ShibbyB
Enthusiast
Enthusiast

An additional note, if I go into the interactive mode on the PXE boot (ctrl-B), I can type chain tftp://vcenterIP/tramp, and the install goes as expected.

0 Kudos
peetz
Leadership
Leadership

Hello and welcome to the forums!

Are all components (vCenter, Autodeploy, TFTP service) installed and running on the same server?

The DHCP boot server option (066) should point to the IP address of the TFTP server.

Make sure that this is set up correctly.

If all is correct, and it still does not work you might have run in one of the rare cases of weird iPXE incompatibility issues.

A workaround is to use the older gPXE boot loader that is part of vSphere 5.0 Autodeploy.

See this post of Gabrie van Zanten for more information:

http://www.gabesvirtualworld.com/vmware-vsphere-5-1-ipxe-problems-with-autodeploy/

Good luck!

- Andreas

Twitter: @VFrontDe, @ESXiPatches | https://esxi-patches.v-front.de | https://vibsdepot.v-front.de
0 Kudos
banksm850
Contributor
Contributor

I had the same issue, my problem was I had option 66 defined for the DHCP scope, but I didn't have next-server define.     It seems to be option 66 defines where PXE boot goes to get the PXE boot loader, and next-server is where the tramp file is located

0 Kudos
dbutch1976
Hot Shot
Hot Shot

Hello,

I recently upgraded my vCenter to 5.1U1 and started having this problem upon reboot.  You said you fixed it by defining "Next-Server?"  Where is this setting?  Is this a DHCP scope option?  If so, what number is it?  Should this be configured with the IP of the vCenter or with the IP of the TFPT server?

0 Kudos
peetz
Leadership
Leadership

Option 66 really is next-server, so I'm not sure what is meant here.

According to VMware KB: Configuring DHCP Server for working with vSphere Auto Deploy only the options 66 and 67 (= boot filename) are needed.

Have you ever updated the PXE boot files on the tftpboot-server after upgrading (from 5.0) to 5.1? This can be easily forgotten ...

And can you please try to troubleshoot at the boot loader prompt like described here: VMware KB: Troubleshooting vSphere Auto Deploy

- Andreas

Twitter: @VFrontDe, @ESXiPatches | https://esxi-patches.v-front.de | https://vibsdepot.v-front.de
0 Kudos
banksm850
Contributor
Contributor

I am using ISC DHCPD on Linux for DHCP.    this is what the config looks like for the server I wanted to PXE boot.   (I obfuscated the addressing and names)

VMware-PXE-BOOTSRV is defined as 66

VMware-PXE-BOOTFILE is defined as 67

next-server is a built in option to the ISC DHCPD.

host servername {

     hardware ethernet xx.xx.xx.xx.xx.xx;

     fixed-address y.y.y.y;

     option vmware-PXE-BOOTSRV "z.z.z.z";

     option vmware-PXE-BOOTFILE "/vmware51/undionly.kpxe.vmw-hardwired";

     next-server z.z.z.z;

}

Doing some research, it does look like option 66 and next-server are the same, but for some reason this only worked for me when I left option 66 and next server defined.

0 Kudos
dbutch1976
Hot Shot
Hot Shot

It turns out a rogue DHCP server was handing out IPs with the wrong scope information.  Sorry for wasting your time guys!!  Thanks for the troubleshooting tips.

0 Kudos
Techstarts
Expert
Expert

thank you very much for this one. I almost spent 4 hours on it yesterday.

Note to all: If you are configuring auto deploy for home lab, just ensure DHCP service on your router is disabled

With Great Regards,