soap2003
Contributor
Contributor

Error: Failed to clone the volume mounted on '/' from 'ip address'

Jump to solution

hi ,i have a question as the title aboved.

i use vmware vcenter standalone 4 which run on windows xp,convert as4 to esx3.0.2,and i have assigned the statiic ip to helper virtual machine and dns server.

when it run to 98%,it has turned out the title.---Error: Failed to clone the volume mounted on '/' from 'ip address'.

i have searched from google,it was said by someone,converter didn't recognize the volume of software raid.but i also have tried the hardware raid of as4,the result is the same as above.

so ,who can help me. i have upload the log files all.

thank you.

0 Kudos
1 Solution

Accepted Solutions
vmweathers
Expert
Expert

The reason this is failing is that tar fails after spitting out too many of these errors:

tar: ./var: time stamp 2008-10-24 08:02:37 is 4243881.056239962 s in the future

This problem is documented in the release notes: http://www.vmware.com/support/converter/doc/releasenotes_conv40.html#76

Whenever 4.0.1 ships we'll prevent this from causing the P2V to fail, until then you'll need to fix the clocks on 1 or both of your systems.

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

View solution in original post

0 Kudos
7 Replies
vmweathers
Expert
Expert

It has nothing to do with software RAID since that only affects discovery of the source during the beginning of the Linux P2V process (whilst still in the Wizard).

Where are these logs you uploaded? (I do not see them attached to your post)

You may need to enable sparse file preservation, see this KB article:

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)
0 Kudos
soap2003
Contributor
Contributor

sorry ,i have already upload the attach file.

thank you .

0 Kudos
vmweathers
Expert
Expert

The reason this is failing is that tar fails after spitting out too many of these errors:

tar: ./var: time stamp 2008-10-24 08:02:37 is 4243881.056239962 s in the future

This problem is documented in the release notes: http://www.vmware.com/support/converter/doc/releasenotes_conv40.html#76

Whenever 4.0.1 ships we'll prevent this from causing the P2V to fail, until then you'll need to fix the clocks on 1 or both of your systems.

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)
0 Kudos
soap2003
Contributor
Contributor

how to Synchronize the clocks between the source machine and the destination ESX host if possible?

0 Kudos
vmweathers
Expert
Expert

Most likely the problem is that the ESX's clock is way off. You just configure NTP for the ESX using VI Client and it should work.

  • select ESX machine in VI client

  • select Configuration tab

  • click Time Configuration link

  • click Properties link

  • click NTP Configuration' Options button.

However it might be that the source's clock is way off in the future, and if so you can touch all the file's timestamps (this is pretty ugly):

  • cd /

  • find . -name "*" -mount | xargs touch -t 03030000

That will set the timestamps of allt he files on / to March 3rd of the current year.

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)
0 Kudos
soap2003
Contributor
Contributor

in the esx of vi ,i found the configuration,but i didn't find time to set clock option,it has hardware and software.

then ,select what to ntp server?

0 Kudos
vmweathers
Expert
Expert

I forget what version of ESX you are running, if it's 3.5+ then you can use the VI client...

if however you are running an older ESX you'll need to configure NTP manually:

All I did was search the web for that information...

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)

(If your question has been resolved please mark the answers as "Helpful" or "Correct".)
0 Kudos