coopersmith77
Enthusiast
Enthusiast

vRealize Operations Manager 7.5 Data Retriever is Not Initialized yet

Jump to solution

I am testing out this version of Operations Manager in my vSphere 6.7u3 environment.  Operations Manager was working fine before I shutdown the virtual appliance in order to save resources while I used HP's Smart Update Manager to update my three ESXi hosts firmware and drivers.  These three hosts are not clustered.  I've now booted up the Operations Manager appliance.  The appliance seems to boot up okay.  I can connect to it via https and SSH.  I can log into it via SSH.  However when I get to the login page for the website, I get the message "Data Retriever is not initialized yet.  Please wait...".  So I've waited for a day.  I've rebooted the appliance.  I've searched the docs, KBs, and communities for answers.  I've found similar requests for help in communities from 4 years ago.  Unfortunately no advice in those requests help in my situation.

Can someone help me get the data retriever to initialize successfully?

0 Kudos
1 Solution

Accepted Solutions
coopersmith77
Enthusiast
Enthusiast

Sorry for the very delayed response.  Yes, Benny Hill with GSS was very helpful in resolving this problem.  By looking at the log for Cassandra we determined that there is fatal error with that part of the vRealize Operations Manager system.  If it were critical, upon my request, he would have engaged the data management team to resolve this fatal error.  Since this is just a trial run and there wasn't much data to begin with, he and I agreed that the quickest way to get this appliance back up and running is to delete this old appliance and deploy a fresh vRealize Operations Management version 8.0.1 appliance.

Since that ticket was closed, work has taken me in other directions and I haven't had a chance to get back to deploy that new appliance yet.

Thank you again for all of your help.

View solution in original post

0 Kudos
12 Replies
coopersmith77
Enthusiast
Enthusiast

AlessandroRomeo68​ - Thank you for that blog post and the VMware Knowledge Base article.  After downloading a translation plug-in, I followed the steps in the blog post to check the status of the log folders.  The log folders weren't even close to being full.  However, I did follow the steps in the Knowlege Base article to clean up the log files.  I then rebooted the appliance.  Unfortunately, I'm still getting the "data retriever" message when going to the appliance's website.

0 Kudos

Log into the admin GUI and make sure all nodes are online and displaying the number of metrics.

If not online, what state are the nodes/cluster  displaying?

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
coopersmith77
Enthusiast
Enthusiast

RickVerstegen​ - Which admin GUI are you wanting me to log into?

When I log into the vSphere Client, go to Administration, and view System Configuration under Deployment, I see my node (the datacenter), in good health, the type, version, and up time.

0 Kudos

You can access the admin UI login page from any node in the vRealize Operations Manager analytics cluster by appending /admin to the node IP address or FQDN when you enter the URL in your browser.

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
coopersmith77
Enthusiast
Enthusiast

Okay.  Figured out how to log into the vRealize Operaions Manager Administration page.  Thank you!  The node is in an "Inaccessible" state.  Please see attached picture.  I can ping the node's IP address (hidden in the picture).  I can't get to it via https or http.

0 Kudos

Just to verify, you have only one node?

Take the cluster offline in the admin UI. When it is offline bring it online again to see if this helps.

After that check on the node(s) if all services are running via SSH with vmware-vcops status command.

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
coopersmith77
Enthusiast
Enthusiast

I do only have one node.

I have tried twice now to take the cluster offline by clicking on the "Take Offline" button.  Each time I do this I get the attached window.  It "loads" for a minute or so and then comes back to the VRealize Operations Manager Administration page with the Cluster Status still Online.

I have logged into the ssh of the vRealize Operations Manager Appliance as an administrator.

I am having trouble getting the status of vmware-vcops.

I am a beginner when it comes to Linux commands.

I was able to figure out how to see all of the processes currently running on the system.

I did enable SSH on the node via the admin UI.  However the "connection is refused".

Today when I ping the IP address of the node the "request times out".

In looking in the Support logs in the admin UI.  Looking in the collector.log I see that vRealize Ops does not respond to HB.

Do you know of any logs under Support that might help me understand what happened, or how to get the node back online?

0 Kudos
bnagabhushan
VMware Employee
VMware Employee

If the issue is still persisting. I would suggest you to open a VMware support request for deeper investigation.

0 Kudos
coopersmith77
Enthusiast
Enthusiast

I will contact VMware support today.  Thank you.

0 Kudos

Any update on this?  Were you able to get the solution from GSS?

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
coopersmith77
Enthusiast
Enthusiast

Sorry for the very delayed response.  Yes, Benny Hill with GSS was very helpful in resolving this problem.  By looking at the log for Cassandra we determined that there is fatal error with that part of the vRealize Operations Manager system.  If it were critical, upon my request, he would have engaged the data management team to resolve this fatal error.  Since this is just a trial run and there wasn't much data to begin with, he and I agreed that the quickest way to get this appliance back up and running is to delete this old appliance and deploy a fresh vRealize Operations Management version 8.0.1 appliance.

Since that ticket was closed, work has taken me in other directions and I haven't had a chance to get back to deploy that new appliance yet.

Thank you again for all of your help.

0 Kudos