Pegasjus
Contributor
Contributor

vra 7.6 and the fun and games of installing it

Hi

I have an issue with vra 7.6 and also 7.5 on my setup during installation

I have vcenter 6.7u2

esxi 6.7u2

vra version: 7.6 build 13027280

the iaas server, which I have tried with Win2k12 and up until June 2019 update as well as Win2k16 with latest July 2019 updates applied.

both vra guests are placed in the same network on the same host.

I did the following:

installed sql server (express 2014), installed iis, installed jre (8u211).

I uninstalled and installed msdtc because it can cause issues.

I go through the minimal install, sql and iis is on the same windows 2016 host (with all updates etc.)

I can go through the whole installation wizard and all is well (green the whole way, all validated steps were validated and good).

When I star the installation the first step fails with no connection between va and management agent.

So while writing this I had a bright idea... or so I thought.

I checked the manager agent status and there are two services.

1: VMwareCAFManagementAgentHost

2: VMwareCAFCommAmqpListener

These are set to manual, starting them got me past the first two steps. STep three where it checks if all services are running I am back to failed and need to check communication between va and management agent.

It seems other peolpe have had similar problems at step 1 already, I am curious if anybody got it to install and if someone has an idea on how to progress here?

Again while writing something here... the weird thing continues, I now managed to get to 70%, I notice the 2nd service keeps stopping and when I then start it again and select "retry failed" it continues a bit further.

In the end I managed to get to end of the installation, surely this can't be the way it's supposed to be though?!

//Martin

5 Replies
daphnissov
Immortal
Immortal

You've got a lot going on and it's impossible to really understand where to start. So I'll start by saying SQL Express (any version) is not supported with vRA 7.6. You need to use Standard or better. You also need to take into account the increased load that SQL box will have on your minimal IaaS server and increase the resources. Anything less than 4 x 8 is unacceptable.

I can assure you that installing vRA isn't this painful or fraught with error, but until I can see each step in your installer wizard and the values you're supplying, it's really difficult to try and help.

0 Kudos
mdraganchev
Contributor
Contributor

To diagnose connectivity problems between Management Agent and VA/VAMI/ check the following:
Log on the problematic machines and check the Management Agent service is running (in services.msc)
Go to MA installation location and check the All.log file inside the Logs folder. It should contain more details in case of connectivity issue.

Pegasjus
Contributor
Contributor

Thank you for the input, did not reveal much in the shape of errors or otherwise. It did confirm that all was green and that the installation was successful.

I used the vcac management installer that came with the appliance. I noticed afterwards that there are newer versions on my.vmware.com.

I guess I'll have to try it again and see if the errors still is there.

In any case this is a lab built.

Also minimal installation means 4x8 (cpu and memory) was followed.

0 Kudos
Sany_1973
Enthusiast
Enthusiast

I did an upgrade in my lab from vra 7.3 to vra7.6 with sql express 2012. I am not sure it will create any issues...

Anybody knows the issues of using sql express ?

0 Kudos
daphnissov
Immortal
Immortal

SQL Express is pretty crap as far as capabilities, so you may very well hit issues. You can easily get the SQL Developer edition for free, which is a full-functional SQL edition, but for non-production environments.