Commens
Contributor
Contributor

Updated certificates and now iaas-service won't start

I've gone through and re-established trusts multiple times, i'm at a loss right now. Services start except iaas-service.  The infrastructure tab and blueprints won't load.

Weird thing is the last updated date is from yesterday, so its like its not even trying to update/start?

I'm running in a distributed environment with an external postgres.

I'm seeing some errors in the repository log..

---> (Inner Exception #0) VMware.Cafe.HtmlResponseException: Forbidden (403)

Request:

PUT https://postgresserver/identity/api/authorization/tenants/vsphere.local/authorities/extended/permiss...

Response:

<html><head><title>Error report</title></head><body><h1>HTTP Status 403 - </h1></body></html>

   at VMware.Cafe.JsonRestClient.<HandleErrorResponse>d__9f`1.MoveNext()

--- End of stack trace from previous location where exception was thrown ---

   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

   at System.Runtime.CompilerServices.ConfiguredTaskAwaitable`1.ConfiguredTaskAwaiter.GetResult()

   at VMware.Cafe.JsonRestClient.<PutResource>d__3c`2.MoveNext()<---

0 Kudos
1 Reply
Kedar_D
Enthusiast
Enthusiast

Are you using external CA?

Have you imported the IaaS signed certificate and trusted root CA certificates on IaaS node/s?

After importing the certificates try restarting IaaS node/s..

Refer to below link.

vCloud Automation Center Documentation

------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Kedar http://virtualtechknow.wordpress.com/ ------------------------------------------------------------
0 Kudos