jbweber2
Enthusiast
Enthusiast

Tell vCAC not to power on machine

Is there any way that I can configure vCAC (5.2 or 6) to not power on a machine once it's created the container.

I've got a basic vSphere blueprint Server, Create, BasicVmWorkflow and I'm using it to create empty shells so I can do custom os provisioning to them at a later time.

I'd like to control power management myself (likely from vCO), but allow vCAC to create the container and mount boot media to the cdrom drive during the execution of BasicVmWorkflow.

0 Kudos
3 Replies
AlokShrivastwa
Enthusiast
Enthusiast

Actually the BasicVMWorkflow by default power's on a system. However, there are multiple ways to do this

1. Block the MachineProvisioned state, so it doesn't go to the Initial Power On State (See a blog here ClearAsCloud Blog: The State Transition Blocking Pattern.) - You can unblock this later using some CustomProperty

2. Write a simple workflow to turn off the machine once its it turned on, create a custom property here as well to track this is done only once

Let me know if you need assistance.

0 Kudos
jbweber2
Enthusiast
Enthusiast

I'm currently using pattern #1, and the issue I've run into is that the value in the Storage table for the amount of free space on a LUN is not updated until a machine gets to a state of "On". I have a specific use case where sometimes it's beneficial to allow multiple reservations to see the same storage and use the free space counter on the actual storage as a last resort for if it should be picked for placement while waiting for an external process to recalculate reservation sizes.

I was thinking I may be able to move my logic to the "On" state with PostActivityExecution and filtering on the current initator in vCAC to determine if I should run the workflow or not. I've never tried to attach a state change workflow to a state like "On" before so hopefully it works as expected.

0 Kudos
rszymczak
Hot Shot
Hot Shot

Hi jbweber2,

how did you manage to use the BasicVmWorkflow to create "empty" shells without attaching a ISO to it? For me, vRA will not finish the create workflow till it received a boot signal from the OS.

/edit: After some hours looking for the reason why this doesn't work, while all documentation sais it should work, I just noticed that I accidently selected "WimImageWorkflow" instead of "BasicVmWorkflow". And there go another couple of hours lifetime wasted by fatfingers. Doh.

0 Kudos