jimmyvandermast
Hot Shot
Hot Shot

Clean LCM deploy: PSQLException: Connection to localhost:5432 refused

Jump to solution

I have another topic where the easyinstaller fails on the LCM installation.

So now I have just deployed the LCM appliance from the OVA with all same settings that I used in the easy installer.
Again, the lcm is pingable and SSH-able, and reversed the lcm can do name resolving and pinging and things like that.

Same result here when I go to https://<lvm-ip>/vrslcm

Waiting for services to start

 

Now I see that there are not much logs. No catalina, no vrlcm-server or vrlcm-xserver.log files at all.
It seems that the installation itself fails and stops during the first installation stage?

I have found a /var/log/vrlcm/blackstone-spring.log file, which has long java messages with an error:

PSQLException: Connection to localhost:5432 refused
and after that
o.s.b.SpringApplication [reportFailure] : Application run failed
Error creating bean with name 'entityManagerFactory' defined in class path resource ...  etc etc etc

This seems odd, it's a clean new deploy and it's to the own localhost so it cannot be any firewall outside the VM.

 

# service postgres status

Failed to start VMware Postgres database server

I can see that it repeats.

1 Solution

Accepted Solutions
jimmyvandermast
Hot Shot
Hot Shot

To make a long story short, the issue kept coming back, no matter how I deployed lcm.

For now, I found a way to fix it by removing the corrupted postgres data dir and letting the firstboot scripts re-do it's thing.

View solution in original post

9 Replies
jimmyvandermast
Hot Shot
Hot Shot

To make a long story short, the issue kept coming back, no matter how I deployed lcm.

For now, I found a way to fix it by removing the corrupted postgres data dir and letting the firstboot scripts re-do it's thing.

Christiankkcc
Enthusiast
Enthusiast

Hi Jimmy,

How exactly did you remove the corrupted postgres data? SSH into vSphere of the host itself?

Also, where is the dir located?

I'm having issues with the 8.3 installation as well.

Thanks!

0 Kudos
AyoubSouihel
Contributor
Contributor

Hello , 

 

i have encountered the same issue , any solution ? , please.

0 Kudos
jimmyvandermast
Hot Shot
Hot Shot

Possible solution 1:

Run the following commands on the LCM appliance

rm -rf /storage/db/pgdata/
/etc/bootstrap/firstboot.d/02-configure-postgres.sh
/etc/bootstrap/firstboot.d/20-start-services
service vlcm-service start

 

Possible solution 2: don't disable FIPS during the installation.

AyoubSouihel
Contributor
Contributor

thank you so much for your assistance .

the above steps did not solve my issue , but i realized that the PostgreSQL user password has been expired , i changed the password ,

now i see all the services are up and running  and everything looks fine . i will update you soon .

0 Kudos
jimmyvandermast
Hot Shot
Hot Shot

@AyoubSouihel are you talking about an installation with the Easy Installer and an expired psql password?
Because you say that you have "the same issue", but I cannot imagine it is.

0 Kudos
JPmartinHQ
Contributor
Contributor

solution #2 seem to have done the trick for me... 

so just chose to enable the FIPS parameter in the config dialogs

0 Kudos
cf_arar
Contributor
Contributor

What is the relation between FIPS and the postgress database ? FIPS is not a requirement to the deployment

0 Kudos
viquarhcimca
Enthusiast
Enthusiast

my version of vRA is 8.8 
 i run the follow 

rm -rf /storage/db/pgdata/
/etc/bootstrap/firstboot.d/02-configure-postgres.sh
/etc/bootstrap/firstboot.d/20-start-services

and reboot of the vRSLCM . it worked . thank you @jimmyvandermast 

Thanks & Regards,

Mohammed Viquar Ahmed
0 Kudos