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VMware Remote Console for 
vSphere 1
VMware Remote Console for vSphere describes how to install VMware Remote Console and use it to 
access and perform operations on vSphere virtual machines.

The virtual machine and device configuration options described in this guide are not available for vRealize 
Automation. If you want to use VMware Remote Console to connect to virtual machines in vRealize 
Automation or vCloud Director, see the VMware Remote Console for vRealize Automation and vCloud 
director guide.

Intended Audience
This information is intended for administrators and users who need to access virtual machine consoles 
and connect client-side devices.

Terminology
For definitions of terms as they are used in this document, see the VMware Glossary at https://
www.vmware.com/topics/glossary.

This chapter includes the following topics:

n Installing VMware Remote Console

n Configuring and Managing Virtual Machines

n Configuring and Managing Devices

Installing VMware Remote Console
You can install VMware Remote Console on Windows, macOS, and Linux operating systems.

For a list of supported operating systems, see the release notes for your version of VMware Remote 
Console.

VMware Remote Console is a free product that does not require a license key to use.
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Install VMware Remote Console on Windows
You download the Windows installation package and run it on your local machine.

This procedure describes how to use the installation wizard to install VMware Remote Console. If you 
want to perform a silent installation, see Perform a Silent Installation of VMware Remote Console.

Prerequisites

Verify that your local machine is running a supported version of Windows. For a list of supported 
operating systems, see the release notes for your version of VMware Remote Console.

Procedure

1 Access the VMware Remote Console download page at https://www.vmware.com/go/download-vmrc 
and download VMware Remote Console for Windows.

You can also access the download page from the vSphere Client or VMware Host Client.

n In the vSphere Client, select any virtual machine, open the Summary tab, and click Launch 
Remote Console > Download Remote Console.

n In the VMware Host Client, select any virtual machine and select Console > Download VMRC.

2 Decompress the file to a temporary directory and run the installation wizard.

3 Click Next to begin installation.

4 Read and accept the terms of the license agreement and click Next.

5 Specify the installation directory and click Next.

6 Select whether to check for product updates and whether to join the Customer Experience 
Improvement Program (CEIP).

For more information about the CEIP, see Join or Leave the Customer Experience Improvement 
Program.

7 Click Install.

VMware Remote Console is installed on your local machine and is configured to open URLs that use the 
vmrc scheme.

Perform a Silent Installation of VMware Remote Console
You can perform a silent installation of VMware Remote Console on Windows machines.

Silent installation, also known as unattended installation, allows system administrators to automate the 
installation process. During a silent installation, the end user is not required to perform any actions.

Prerequisites

n Verify that the target machine is running a supported version of Windows. For a list of supported 
operating systems, see the release notes for your version of VMware Remote Console.
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n Read the VMware Remote Console End-User License Agreement (EULA) and verify that you accept 
its terms and conditions.

The EULA is not displayed during a silent installation. If you want to read the EULA, perform a 
standard installation.

Procedure

1 Access the VMware Remote Console download page at https://www.vmware.com/go/download-vmrc 
and download VMware Remote Console for Windows.

You can also access the download page from the vSphere Client or VMware Host Client.

n In the vSphere Client, select any virtual machine, open the Summary tab, and click Launch 
Remote Console > Download Remote Console.

n In the VMware Host Client, select any virtual machine and select Console > Download VMRC.

2 Transfer the file to the target machine and decompress it to a temporary directory.

3 Run Command Prompt as an administrator.

4 Run the following command to perform a silent installation.

VMware-VMRC-version-build.exe /s /v "/qn EULAS_AGREED={0 | 1} INSTALLDIR="install-directory" 

AUTOSOFTWAREUPDATE={0 | 1} DATACOLLECTION={0 | 1}" /l "log-file"

Option Description

EULAS_AGREED Enter 1 to indicate that you accept the terms and conditions of the VMware Remote 
Console EULA. You can view the EULA by performing a standard installation. 
Entering 0 will stop the installation process.

INSTALLDIR Enter the directory in which you want to install VMware Remote Console. If the 
directory does not exist, it will be created.

If you do not include the INSTALLDIR parameter, VMware Remote Console will be 
installed to the C:\Program Files (x86)\VMware\VMware Remote Console 
directory.

AUTOSOFTWAREUPDATE Enter 1 to update VMware Remote Console automatically or 0 to disable automatic 
updates.

DATACOLLECTION Enter 1 if you want to join the Customer Experience Improvement Program (CEIP) 
or 0 if you do not want to join the CEIP.

For more information about the CEIP, see Join or Leave the Customer Experience 
Improvement Program.

/l Enter the path and file name of the VMware Remote Console installation log file. If 
the file does not exist, it will be created. However, you must specify an existing 
directory.

If you do not include the /l parameter, installation log entries will be written to the 
%TEMP%\vminst.log file.

 
VMware Remote Console is installed on the target machine and is configured to open URLs that use the 
vmrc scheme.
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Install VMware Remote Console on macOS
You install VMware Remote Console from the App Store on your macOS machine. Alternatively, you can 
download an installation package and perform a manual install.

When you install a new version of VMware Remote Console from the App Store, you may be prompted to 
uninstall any previous versions that were not installed from the App Store.

Prerequisites

Verify that your local machine is running a supported version of macOS. For a list of supported operating 
systems, see the release notes for your version of VMware Remote Console.

Procedure

u To install VMware Remote Console from the App Store, perform the following steps.

Note   This procedure is supported for macOS 10.15 and later.

a Open the App Store and search for VMware Remote Console.

b Click Get > Install App.

c If prompted, sign in with your Apple ID and password.

The App Store downloads and installs VMware Remote Console.

u To manually install VMware Remote Console, perform the following steps.

a Access the VMware Remote Console download page at https://www.vmware.com/go/download-
vmrc and download VMware Remote Console for macOS.

You can also access the download page from the vSphere Client or VMware Host Client.

n In the vSphere Client, select any virtual machine, open the Summary tab, and click Launch 
Remote Console > Download Remote Console.

n In the VMware Host Client, select any virtual machine and select Console > Download 
VMRC.

b Open the installation package and double-click VMware Remote Console.

c Enter the user name and password of a system administrator.

d Read the terms of the license agreement and click Agree.

e Select whether to join the Customer Experience Improvement Program (CEIP) and click Done.

For more information about the CEIP, see Join or Leave the Customer Experience Improvement 
Program.

VMware Remote Console is installed on your local machine and is configured to open URLs that use the 
vmrc scheme.
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Install VMware Remote Console on Linux
You download the Linux installation package and run it on your local machine.

The Linux installation package includes a GUI installer and command-line installer. To force the installer 
to use command-line mode, add the --console parameter when running the installation package.

Prerequisites

Verify that your local machine is running a supported version of Linux. For a list of supported operating 
systems, see the release notes for your version of VMware Remote Console.

Procedure

1 Access the VMware Remote Console download page at https://www.vmware.com/go/download-vmrc 
and download VMware Remote Console for Linux.

You can also access the download page from the vSphere Client or VMware Host Client.

n In the vSphere Client, select any virtual machine, open the Summary tab, and click Launch 
Remote Console > Download Remote Console.

n In the VMware Host Client, select any virtual machine and select Console > Download VMRC.

2 Switch to the root user.

sudo su -

3 If necessary, grant execute permissions to the installation package.

chmod +x VMware-Remote-Console-version-build.x86_64.bundle

4 Run the installation package.

./VMware-Remote-Console-version-build.x86_64.bundle

5 To install in GUI mode, perform the following steps.

a Read and accept the terms of the license agreement and click Next.

b Select whether to check for product updates and click Next.

c Select whether to join the Customer Experience Improvement Program (CEIP) and click Next.

For more information about the CEIP, see Join or Leave the Customer Experience Improvement 
Program.

d Click Install.
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To install in command-line mode, perform the following steps.

a Press Enter and read the license agreement.

b When you reach the end of the license agreement, type yes to accept the license agreement.

You can type q to move to the end of the license agreement.

c If you want to check for product updates, type yes.

VMware Remote Console is installed on your local machine and is configured to open URLs that use the 
vmrc scheme.

Configure Proxy Settings
You can configure a proxy server through which VMware Remote Console can connect to your virtual 
machines.

Note   HTTP is the only supported protocol for proxy connections.

In previous versions of VMware Remote Console, the VMWARE_HTTPSPROXY environment variable was 
used to set a proxy server. The proxy settings configured in this procedure take precedence over the 
value of the VMWARE_HTTPSPROXY environment variable. However, if you do not configure proxy settings 
using this procedure, the VMWARE_HTTPSPROXY environment variable will continue to take effect.

If you want to use a proxy server that requires authentication, you must configure your proxy settings 
using this procedure instead of the environment variable.

Procedure

1 In a web browser, access vmrc://settings.

If VMware Remote Console is already open, you can also access the settings through the menu.

n On Windows, select VMRC > Preferences.

n On macOS, select VMware Remote Console > Preferences.

n On Linux, select File > Remote Console Preferences.

2 On Windows or Linux, perform the following steps.

a Select Enable proxy for remote virtual machine and click Connection Proxy Settings.

b Enter the hostname or IP address and port of your proxy server.

You can enter an IPv4 or IPv6 address.

c (Optional) Enter the user name and password to authenticate with your proxy server.

d Click OK.
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On macOS, perform the following steps.

a Select Enable proxy for remote virtual machine.

b Enter the hostname or IP address and port of your proxy server.

You can enter an IPv4 or IPv6 address.

c (Optional) Select Using Credentials and enter the user name and password to authenticate with 
your proxy server.

d Click Save.

e On macOS, restart VMware Remote Console so that the configured settings take effect.

After you have configured proxy settings, VMware Remote Console will send all subsequent connections 
to virtual machines through the specified proxy server.

What to do next

If VMware Remote Console displays connection-related errors, ensure that your proxy settings are 
correct.

On macOS, after disabling or changing proxy settings, you must restart the VMware Remote Console 
client.

Join or Leave the Customer Experience Improvement Program
This product participates in VMware's Customer Experience Improvement Program ("CEIP").

The CEIP provides VMware with technical information that is used to improve the quality, reliability, and 
functionality of VMware products and services. The information does not personally identify any 
individual. Details regarding the data collected through CEIP and the purposes for which it is used by 
VMware are set forth at the Trust & Assurance Center at https://www.vmware.com/solutions/trustvmware/
ceip.html.

When you start VMware Remote Console for the first time, you are prompted to select whether you want 
to participate in the CEIP. You can also choose to join or leave the CEIP at any time thereafter by 
performing the following procedure.

Procedure

1 In a web browser, access vmrc://settings.

If VMware Remote Console is already open, you can also access the settings through the menu.

n On Windows, select VMRC > Preferences.

n On macOS, select VMware Remote Console > Preferences.

n On Linux, select File > Remote Console Preferences.

2 On macOS, select Feedback.

3 Select or deselect Join the VMware Customer Experience Improvement Program.

VMware Remote Console for vSphere
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Access vSphere Virtual Machines with VMware Remote Console
You can use VMware Remote Console to access virtual machines in the vSphere Client or VMware Host 
Client.

Prerequisites

n Install VMware Remote Console on your local system.

n If necessary, configure a proxy server through which to connect to virtual machines. See Configure 
Proxy Settings.

Procedure

u To access a virtual machine from the vSphere Client, perform the following steps.

a In the vSphere Client, select the desired virtual machine.

b On the Summary tab, click Launch Remote Console.

u To access a virtual machine from the VMware Host Client, perform the following steps.

a In the VMware Host Client, select the desired virtual machine.

b Select Console > Launch remote console.

VMware Remote Console connects to the specified virtual machine.

What to do next

Click the screen of the virtual machine in VMware Remote Console to transfer mouse and keyboard input 
to the virtual machine. To release the mouse and keyboard back to your local client, press Ctrl+Alt for 
Windows and Linux or Ctrl+Command for macOS.

Configuring and Managing Virtual Machines
You can perform certain virtual machine configuration tasks directly in VMware Remote Console.

Install VMware Tools on a Virtual Machine
You can use VMware Remote Console to install VMware Tools on virtual machines.

Note   This function is not available in macOS.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Initiate the VMware Tools installation on the virtual machine.

This process mounts the VMware Tools ISO file to the first virtual CD/DVD drive on the virtual 
machine.

n On Windows, select VMRC > Manage > Install VMware Tools.

n On Linux, select Virtual Machine > Install VMware Tools.
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If VMware Tools has already been installed on the virtual machine, the menu item changes to 
Reinstall VMware Tools. If an outdated version of VMware Tools is installed on the virtual machine, 
the menu item changes to Update VMware Tools.

3 In the guest operating system, install VMware Tools.

For detailed instructions, see "Installing VMware Tools" in the VMware Tools User Guide.

4 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

5 On the Options tab, select VMware Tools and specify the desired configuration.

You can select whether to synchronize the guest and host operating system time and whether to 
update VMware Tools manually or automatically.

Change Virtual Machine Settings
You can change the display name and the operating system type of a virtual machine.

Note   Changing the operating system type is not supported in Linux. The VMware Remote Console 
Linux client cannot perform operations on powered-off virtual machines.

Changing the operating system type does not automatically change the guest operating system. This 
process changes only the configuration file for the virtual machine. You may want to change the operating 
system type of a virtual machine after you upgrade the operating system on the virtual machine or if an 
incorrect operating system type was selected for the virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 If you want to change the operating system type, power off the virtual machine.

3 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On macOS, select Virtual Machine > Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

4 Open the general virtual machine settings.

n On Windows or Linux, open the Options tab and click General.

n On macOS, click General.

5 Enter the desired name and select a guest operating system type.

The virtual machine configuration file is updated to reflect your changes.

VMware Remote Console for vSphere

VMware, Inc. 12



Control Power Settings
You can use VMware Remote Console to restart, suspend, power on, and power off your virtual 
machines.

If VMware Tools is installed on your virtual machine, VMware Remote Console provides soft shutdown 
options by default. VMware Remote Console sends a hard shutdown if VMware Tools is not installed or if 
the virtual machine is unresponsive.

Note   A hard shutdown while the virtual machine is still processing might cause data loss. Use a soft 
shutdown whenever possible.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Open the power menu in VMware Remote Console.

n On Windows, select VMRC > Power.

n On macOS, select Virtual Machine.

n On Linux, select Virtual Machine > Power.

3 Select the desired power option.

n If the virtual machine is powered off or suspended, select Power On.

n To power off a virtual machine, select Shut Down Guest (Windows), Shut Down (macOS), or 
Power Off Guest (Linux).

n To restart a virtual machine, select Restart Guest (Windows), Restart (macOS), or Reset Guest 
(Linux).

n To suspend a virtual machine, select Suspend.

Note   On macOS, you can force a hard shutdown by holding Alt while performing this step. This 
feature is not available on Windows or Linux.

Send Key Input to a Virtual Machine
If your local machine intercepts the Ctrl+Alt+Del key sequence, you can use VMware Remote Console to 
send that input to the virtual machine directly.

On macOS, you can also send other key input if necessary.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Send the desired key input to the virtual machine.

n On Windows, select VMRC > Send Ctrl+Alt+Del.

n On Linux, select Virtual Machine > Send Ctrl+Alt+Del.
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n On macOS, select Virtual Machine > Send Ctrl+Alt+Del to send the Ctrl+Alt+Del sequence or 
Virtual Machine > Send Key to send other key input.

The following keys can be sent to the virtual machine:

n Help (Insert)

n Home

n End

n Forward Delete

n Caps Lock

n Clear (Num Lock)

n Scroll Lock

n Print Screen

n Pause

n Break

n Menu

n F8 through F16

Configuring and Managing Devices
You can use VMware Remote Console to add devices to virtual machines, including hard disks, CD/DVD 
drives, and parallel and serial ports. You can also modify settings for existing devices.

Change Virtual Processor Settings
You can use VMware Remote Console to modify the number of processors or cores that are allocated to 
a virtual machine.

Note   This function is not available in Linux. The VMware Remote Console Linux client cannot perform 
operations on powered-off virtual machines.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Power off the virtual machine.

3 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On macOS, select Virtual Machine > Settings.

4 Open the processor settings.

n On Windows, open the Hardware tab and click Processors.
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n On macOS, click Processors and Memory.

5 Select the desired number of processors and cores.

On macOS, you can select only the total number of cores.

6 Configure additional virtualization settings.

n On Windows, you can select Virtualize Intel VT-x/EPT or AMD-V/RVI.

n On macOS, expand Advanced options. You can then select one or more of the following 
options:

n Enable hypervisor applications in this virtual machine

n Enable code profiling applications in this virtual machine

n Enable IOMMU in this virtual machine

The virtual machine is updated to reflect your changes.

Change Virtual Memory Settings
You can use VMware Remote Console to adjust the amount of memory that is allocated to a virtual 
machine.

Note   This function is not available in Linux. The VMware Remote Console Linux client cannot perform 
operations on powered-off virtual machines.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Power off the virtual machine.

3 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On macOS, select Virtual Machine > Settings.

4 Open the memory settings.

n On Windows, open the Hardware tab and click Memory.

n On macOS, click Processors and Memory.

5 Enter or select the desired amount of memory for the virtual machine.

The virtual machine is updated to reflect your changes.

Add a New Virtual Hard Disk
You can use VMware Remote Console to add a new virtual hard disk to a virtual machine.

Note   This function is not available in macOS.
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Procedure

1 Access the target virtual machine in VMware Remote Console.

2 If you want to add an IDE hard disk, power off the virtual machine.

Note   Adding an IDE hard disk is not supported in Linux. The VMware Remote Console Linux client 
cannot perform operations on powered-off virtual machines.

3 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

4 On the Hardware tab, click Add to start the Add Hardware Wizard.

5 Select Hard Disk and click Next.

6 Select the desired hard disk type and click Next.

Option Description

IDE Create an IDE device. This option is available only on powered-off virtual 
machines.

SCSI Create a SCSI device.

SATA Create a SATA device.

NVMe Create an NVMe device.
 

7 Select Create a new virtual disk and click Next.

8 Set the capacity for the new virtual hard disk.

9 Specify additional hard disk options.

Option Description

Allocate all disk space now Allocating all disk space when you create the virtual hard disk can enhance 
performance, but it requires all physical disk space to be available now. If you do 
not select this setting, the virtual disk starts small and expands as you add data to 
it.

Store virtual disk as a single file Select this option to store the virtual disk as a single file.

Split virtual disk into multiple files Select this option to split the virtual disk into multiple files. Splitting the disk makes 
it easier to move the virtual machine to another computer but may reduce 
performance with large disks.

Note   Creating split virtual disks for remote virtual machines is not supported.

 
10 Enter a path and filename for the virtual disk file.

11 Click Finish.

The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a new, 
blank hard disk.
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Add an Existing Virtual Hard Disk
You can use VMware Remote Console to reconnect an existing virtual hard disk that was removed from a 
virtual machine.

Note   This function is not available in macOS.

Prerequisites

Verify that the VMDK file for the existing hard disk is located on the target virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 If you want to add an IDE hard disk, power off the virtual machine.

Note   Adding an IDE hard disk is not supported in Linux. The VMware Remote Console Linux client 
cannot perform operations on powered-off virtual machines.

3 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

4 On the Hardware tab, click Add to start the Add Hardware Wizard.

5 Select Hard Disk and click Next.

6 Select the desired hard disk type and click Next.

Option Description

IDE Add an IDE device. This option is available only on powered-off virtual machines.

SCSI Add a SCSI device.

SATA Add a SATA device.

NVMe Add an NVMe device.
 

7 Select Use an existing virtual disk and click Next.

8 Select the file for the desired hard disk.

9 Click Finish.

Manage Virtual Hard Disks
You can use VMware Remote Console to remove or expand virtual hard disks and perform other 
operations.

Note   This function is not available in Linux. The VMware Remote Console Linux client cannot perform 
operations on powered-off virtual machines.
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The following operations are supported on Windows only:

n Compacting a virtual hard disk. Compacting reclaims unused space on the virtual hard disk.

n Defragmenting a virtual hard disk. Defragmenting rearranges files, programs, and unused space on 
the virtual hard disk so that programs run faster and files open more quickly.

n Mapping a virtual hard disk to a local volume.

n Changing between dependent and independent mode.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Power off the virtual machine.

3 If you want to compact or defragment a virtual hard disk, ensure that the hard disk is not mapped or 
mounted and is configured in either dependent mode or independent persistent mode.

4 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On macOS, select Virtual Machine > Settings.

5 Open the settings for the target hard disk.

n On Windows, open the Hardware tab and select the desired hard disk.

n On macOS, select the desired hard disk under Removable Devices.

6 Perform the desired operation.

On Windows, choose from the following options:

n To remove the disk, click Remove.

n To expand the disk, click Expand in the Disk utilities section. Enter the desired disk size and 
click Expand.

n To map the disk to a local volume, click Map in the Disk utilities section.

n To defragment the disk, click Defragment in the Disk utilities section.

n To compact the disk, click Compact in the Disk utilities section.

n To change the disk mode, click Advanced in the Disk utilities section and select or deselect 
Independent. If you configure the disk to use independent mode, select Persistent or 
Nonpersistent.

On macOS, choose from the following options:

n To remove the hard disk, click Remove hard disk.

n To expand the disk, drag the Disk size slider or enter the desired value.

Manage CD/DVD Drives
You can use VMware Remote Console to add and manage CD/DVD drives on your virtual machine.
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Procedure

1 Access the target virtual machine in VMware Remote Console.

2 If you want to configure a new CD/DVD drive, add it to your virtual machine.

Note   Adding a CD/DVD drive is not supported on macOS. The VMware Remote Console macOS 
client cannot add hardware to a virtual machine.

a Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

b Open the Hardware tab and click Add.

c Select CD/DVD Drive and click Finish.

3 Open the settings for the target CD/DVD drive.

n On Windows or Linux, open the Hardware tab and select the desired CD/DVD drive.

n On macOS, select the desired CD/DVD drive under Removable Devices.

4 Specify connection settings for the drive.

n To connect the drive immediately, select Connected (Windows or Linux) or Connect CD/DVD 
Drive (macOS).

n To connect the drive each time the virtual machine is powered on, select Connect at power on.

5 Select whether the drive connects to a drive or image on your local machine or on the remote server.

6 Select the desired disk drive or disk image.

What to do next

If you no longer need a configured CD/DVD drive, you can remove it from the virtual machine.

n On Windows or Linux, select the target CD/DVD drive and click Remove.

n On macOS, power off the virtual machine. Select the target CD/DVD drive and click Remove 
CD/DVD Drive.

Manage Floppy Drives
You can use VMware Remote Console to add and manage floppy drives on your virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.
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2 If you want to configure a new floppy drive, add it to your virtual machine.

Note  
n Adding a floppy drive is not supported on macOS. The VMware Remote Console macOS client 

cannot add hardware to a virtual machine.

n Adding and removing a floppy drive are not supported on Linux. The VMware Remote Console 
Linux client cannot perform operations on powered-off virtual machines.

a Power off the virtual machine.

b Select VMRC > Manage > Virtual Machine Settings.

c Open the Hardware tab and click Add.

d Select Floppy Drive and click Finish.

3 Open the settings for the target floppy drive.

n On Windows or Linux, open the Hardware tab and select the desired floppy drive.

n On macOS, select the desired floppy drive under Removable Devices.

4 Specify connection settings for the drive.

n To connect the drive immediately, select Connected (Windows or Linux) or Connect Floppy 
Drive (macOS).

n To connect the drive each time the virtual machine is powered on, select Connect at power on.

5 Select whether the drive connects to a drive or image on your local machine or on the remote server.

6 Select the desired disk drive or disk image.

7 On macOS, you can specify whether the drive is read-only.

What to do next

If you no longer need a configured floppy drive, you can remove it from the virtual machine.

n On Windows, power off the virtual machine. Select the target floppy drive and click Remove.

n On macOS, power off the virtual machine. Select the target floppy drive and click Remove Floppy 
Drive.

Manage Virtual Network Adapters
You can use VMware Remote Console to add and manage network adapters on your virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.
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2 If you want to configure a new network adapter, add it to your virtual machine.

Note   Adding a network adapter is not supported on macOS. The VMware Remote Console macOS 
client cannot add hardware to a virtual machine.

a Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

b Open the Hardware tab and click Add.

c Select Network Adapter and click Finish.

3 Open the settings for the target adapter.

n On Windows or Linux, open the Hardware tab and select the desired network adapter.

n On macOS, select the desired network adapter under Removable Devices.

4 Specify connection settings for the network adapter.

n To connect the network adapter immediately, select Connected (Windows or Linux) or Connect 
Network Adapter (macOS).

n To connect the network adapter each time the virtual machine is powered on, select Connect at 
power on.

5 From the Network Connection drop-down menu, select a virtual network to which the network 
adapter will connect.

What to do next

If you no longer need a configured network adapter, you can remove it from the virtual machine.

n On Windows or Linux, select the target network adapter and click Remove.

n On macOS, power off the virtual machine. Select the target network adapter and click Remove 
Network Adapter.

Manage USB Controllers
You can use VMware Remote Console to add and manage USB controllers on your virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 On macOS, power off the virtual machine.
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3 If you want to configure a new USB controller, add it to your virtual machine.

a Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On macOS, select Virtual Machine > Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

b Add a USB controller.

n On Windows or Linux, perform the following steps:

1 Open the Hardware tab and click Add.

2 Select USB Controller and click Finish.

n On macOS, perform the following steps:

1 Under Removable Devices, click USB.

2 Click Add USB Controller.

4 Open the settings for the USB controller.

n On Windows or Linux, open the Hardware tab and select the USB controller.

n On macOS, select USB under Removable Devices.

5 Select the USB specification from the drop-down menu.

You can choose USB 1.1, USB 2.0, or USB 3.0.

What to do next

If you no longer need a USB controller, you can remove it from the virtual machine.

n On Windows or Linux, select the USB controller and click Remove.

n On macOS, power off the virtual machine. Select the USB controller and click Remove USB 
Controller under Advanced USB options.

Connect Removable Devices
You can use VMware Remote Console to connect USB and Bluetooth devices to a virtual machine.

Prerequisites

Verify that the device has been connected to your local machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 View available removable devices.

n On Windows, open the VMRC > Removable Devices menu.

n On macOS, select Virtual Machine > USB & Bluetooth > USB & Bluetooth Settings.
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n On Linux, open the Virtual Machine > Removable Devices menu.

3 Connect the removable device to the virtual machine.

n On Windows or Linux, select the desired device from the Removable Devices menu and click 
Connect (Disconnect from Host).

n On macOS, select the desired device under Connect USB devices from your Mac.

When the device is connected to the virtual machine, a check mark appears next to the name of the 
device, and a device icon appears on the virtual machine taskbar.

If the device is connected to the client through a USB hub, the virtual machine sees only the USB device, 
not the hub.

What to do next

If you need to disconnect a removable device, perform the following steps:

n On Windows or Linux, select the desired device from the Removable Devices menu and click 
Disconnect (Connect to Host).

n On macOS, deselect the desired device under Connect USB devices from your Mac.

Manage Sound Cards
You can use VMware Remote Console to add or remove sound cards on your virtual machine.

Note   This function is not available in macOS.

Procedure

1 Access the target virtual machine in VMware Remote Console.

2 Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

3 Open the Hardware tab and click Add.

4 Select Sound Card and click Finish.

What to do next

If you no longer need a configured sound card, you can select the sound card and click Remove.

Manage Parallel Ports
You can use VMware Remote Console to attach virtual parallel ports to a virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.
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2 If you want to configure a new parallel port, add it to your virtual machine.

Note  
n Adding a parallel port is not supported on macOS. The VMware Remote Console macOS client 

cannot add hardware to a virtual machine.

n Adding and removing a parallel port are not supported on Linux. The VMware Remote Console 
Linux client cannot perform operations on powered-off virtual machines.

a Power off the virtual machine.

b Select VMRC > Manage > Virtual Machine Settings.

c Open the Hardware tab and click Add.

d Select Parallel Port and click Finish.

3 Open the settings for the target parallel port.

n On Windows or Linux, open the Hardware tab and select the desired parallel port.

n On macOS, select the desired parallel port under Removable Devices.

4 Specify connection settings for the port.

n To connect the port immediately, select Connected (Windows or Linux) or Connect Parallel Port 
(macOS).

n To connect the port each time the virtual machine is powered on, select Connect at power on.

5 Select whether the port connects to a physical port or to an output file.

What to do next

If you no longer need a configured parallel port, you can remove it from the virtual machine.

n On Windows, power off the virtual machine. Select the target parallel port and click Remove.

n On macOS, power off the virtual machine. Select the target parallel port and click Remove Parallel 
Port.

Manage Serial Ports
You can use VMware Remote Console to attach virtual serial ports to a virtual machine.

Procedure

1 Access the target virtual machine in VMware Remote Console.
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2 If you want to configure a new serial port, add it to your virtual machine.

Note  
n Adding a serial port is not supported on macOS. The VMware Remote Console macOS client 

cannot add hardware to a virtual machine.

n Adding and removing a serial port are not supported on Linux. The VMware Remote Console 
Linux client cannot perform operations on powered-off virtual machines.

a Power off the virtual machine.

b Select VMRC > Manage > Virtual Machine Settings.

c Open the Hardware tab and click Add.

d Select Serial Port and click Finish.

3 Open the settings for the target serial port.

n On Windows or Linux, open the Hardware tab and select the desired serial port.

n On macOS, select the desired serial port under Removable Devices.

4 Specify connection settings for the port.

n To connect the port immediately, select Connected (Windows or Linux) or Connect Serial Port 
(macOS).

n To connect the port each time the virtual machine is powered on, select Connect at power on.

5 Select whether the port connects to a physical port, output file, or named pipe.

The named pipe option is not available on macOS.

6 On Windows and Linux, select whether to allow the guest operating system to use the serial port in 
polled mode.

What to do next

If you no longer need a configured serial port, you can remove it from the virtual machine.

n On Windows, power off the virtual machine. Select the target serial port and click Remove.

n On macOS, power off the virtual machine. Select the target serial port and click Remove Serial Port.

Manage Generic SCSI Devices
You can use VMware Remote Console to add or remove generic SCSI devices that map to physical SCSI 
devices.

Procedure

1 Access the target virtual machine in VMware Remote Console.
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2 If you want to configure a new generic SCSI device, add it to your virtual machine.

Note   Adding a generic SCSI device is not supported on macOS. The VMware Remote Console 
macOS client cannot add hardware to a virtual machine.

a Open the virtual machine settings in VMware Remote Console.

n On Windows, select VMRC > Manage > Virtual Machine Settings.

n On Linux, select Virtual Machine > Virtual Machine Settings.

b Open the Hardware tab and click Add.

c Select Generic SCSI Device and click Finish.

3 Open the settings for the target device.

n On Windows or Linux, open the Hardware tab and select the desired generic SCSI device.

n On macOS, select the desired generic SCSI device under Removable Devices.

4 Specify connection settings for the network adapter.

n To connect the network adapter immediately, select Connected (Windows or Linux) or Connect 
Generic SCSI Device (macOS).

n To connect the network adapter each time the virtual machine is powered on, select Connect at 
power on.

5 Select a physical SCSI device to which the generic SCSI device will connect.

What to do next

If you no longer need a configured generic SCSI device, you can remove it from the virtual machine.

n On Windows or Linux, select the target generic SCSI device and click Remove.

n On macOS, power off the virtual machine. Select the target generic SCSI device and click Remove 
Generic SCSI Device.
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