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1. Introduction 
When validating VMware View™ designs it is important to simulate real world usage as closely as possible. The 
Desktop Reference Architecture Workload Simulator (RAWC) can be used to simulate a user workload in a typical 
Microsoft Windows® desktop environment. 

Desktop RAWC runs on each desktop virtual machine (VM) on one or more VMware ESX™ hosts. Each target 
desktop VM is equipped to run a RAWC workload that simulates typical user behavior, running an application set 
commonly used across a broad array of desktop environments. The workload has a set of randomly executed 
functions that perform operations on a variety of applications. 

Each test is configured using the Desktop RAWC UI. The UI enables you to save and retrieve test parameters, 
create log folders, and define unique workloads based on Active Directory groups. You can use the UI to increase 
the load or adjust the user behavior, such as the number of words per minute that are typed and the delay between 
applications being launched. 

The workload configuration typically used includes Microsoft Word, Excel, PowerPoint, Outlook, Internet Explorer, 
Windows Media Player, Java, Adobe Acrobat, McAfee Virus Scan, and 7-Zip. During the execution of the workload, 
multiple applications are opened at the same time and windows are minimized and maximized as the workload 
progresses, randomly switching between each application. Individual application operations that are randomly 
performed can include: 

 Microsoft Word – Open, minimize, maximize, close, insert text, save modifications 

 Microsoft Word (Random) – Open, minimize, maximize, close, write random words/numbers, save modifications 

 Microsoft Excel – Open, minimize, maximize, close, write random numbers, insert/delete columns/rows, 
copy/paste formulas, save modifications 

 Microsoft PowerPoint – Open, minimize, maximize, close, conduct a slide show presentation 

 Microsoft Outlook – Open, minimize, maximize, close, create/send emails 

 Internet Explorer – Open, minimize, maximize, close, browse page 

 Windows Media Player – Open, close, view a video 

 Java – Compile a java project comprised of several hundred files using the JDK to create a software 
engineering type of workload 

 Adobe Acrobat Reader – Open, minimize, maximize, close, browse pages in PDF document 

 McAfee Anti-virus – Real time scanning 

 7-Zip – Open, close, compress a large file 

Depending upon the size of the test, you may use multiple ESX hosts and session launcher VMs, and as many 
target desktop VMs as you want to test. 
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Figure 1 illustrates the Desktop RAWC architecture used with VMware View. 

Figure 1. Desktop RAWC Architecture used with VMware View 

 

1.1 Requirements 
VMware Infrastructure or VMware vSphere™ should be installed and operational in a lab (non-production) 
environment. 

1.1.1 Email Server Virtual Machine 

If you do not want to run the Microsoft Outlook workload as part of the test, you can ignore this section. 

The following software is required for the provided Email Server virtual machine that supports running the Microsoft 
Outlook workload: 

 VMware ESX 3.0 (or later), or VMware VirtualCenter/vCenter 2.0 (or later) 

 15GB hard disk 

 1GB memory (more if you are running a large number of virtual desktops) 

You do not have to use the Email Server that is provided with Desktop RAWC—you can supply your own Microsoft 
Exchange server. 
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1.1.2 Desktop RAWC Controller 

The following are required for the Desktop RAWC Controller: 

 Microsoft Windows 2003 Server is required for the RAWC Controller machine that hosts the RAWC UI and 
shared network folder for log files. The RAWC Controller can be a physical or virtual machine. 

 Microsoft .NET 2.0 (or later) framework is also required. The installation program will prompt you if it is not 
already installed. You can download and install it from http://www.microsoft.com/NET/. 

1.1.3 Session Launcher VMs 

One or more session launcher VMs must be set up to support the launching of View Client sessions. Each session 
launcher VM can support up to 20 sessions. 

Requirements: 

 Windows XP with SP3 

 Microsoft .NET 2.0 

 Remote Desktop Connection 7.0 client (formerly known as Microsoft Terminal Service Client) 

 VMware View Client 4.x or later 

Note A View Client cannot exist on the same VM as a View agent, so the session launcher VM(s) cannot be 
managed by VMware View. 

1.1.4 Target Desktop VMs 

Create a target desktop VM master image and then clone the target desktop VMs you want to use in your test. 

The required target desktop VM configuration is: 

 1024MB memory 

 10GB disk space 

 Windows 7 (32- or 64-bit), or Windows XP with SP2 or SP3 

 Microsoft .NET 2.0 

 A View Agent must be installed on each target desktop VM. 

 If Microsoft Outlook is part of the workload, use a persistent desktop pool so that users will get the same 
desktop for every test. 
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1.1.5 Applications 

A set of applications comprise the workload that runs on each target desktop VM. You can select which applications 
to use for a test from the Desktop RAWC UI. 

The customer must supply software and licenses for each of the following applications they want to use in a test: 

 Internet Explorer 8 

 McAfee VirusScan Enterprise 8.7.0i 

 Microsoft Office 2007 (Word, Excel, PowerPoint, Outlook) 

Note Desktop RAWC 1.2 works only with Office 2007 programs. If you must test with Office 2003, use 
Desktop RAWC 1.0. 

7-Zip is provided and installs automatically when Desktop RAWC is installed. 

Some applications must be downloaded from vendor sites and installed or copied to particular locations. Gather the 
following applications beforehand so that they will be available when you configure Desktop RAWC: 

 Sun Java JDK 6 Update 16 (or later) 

 Windows Media Player 11 for XP or 12 for Windows 7 

 Adobe Reader 9.x 

 Video files 

1.1.5.1. Sun Java JDK 6 Update 

Download Sun Java JDK 6 Update 16 (or later) from  

        http://www.oracle.com/technetwork/java/javase/downloads/index.html 

1.1.5.2. Windows Media Player 11 or 12 

Download Windows Media Player 11 for Windows XP from  

        http://www.microsoft.com/windows/windowsmedia/player/11/default.aspx 

Download Windows Media Player 12 for Windows 7 from  

        http://windows.microsoft.com/en-US/windows7/products/features/windows-media-player-12 

1.1.5.3. Adobe Reader 

Download Adobe Reader from 

      http://get.adobe.com/reader/ 

1.1.5.4. Video Files 

1. Go to: 

http://www.microsoft.com/windows/windowsmedia/musicandvideo/hdvideo/contentshowcase.aspx 

2. Select and download the following files: 

 Super Speedway (720p) 

 The Living Sea (1080p) (Be sure to select the 1080 version.) 
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1.2 Installation Files 
The following Desktop RAWC files are provided from a download site. 

File Name Description 

DesktopRawcSetup_1.2.0.zip  Contains Desktop RAWC executables and 
workload files  

RAWC-EmailServer-VMX.zip 
Contains the Email Server virtual machine 
(use this file for any version of Desktop 
RAWC) 

 

 

1.3 Support 
For problems, enhancement requests or feedback send email to rawc‐support@vmware.com. 

Include a full description of the problem. Also, zip up and send to support the log files from the network shared 
folders Log_Folder and SessionLauncher_Share. Only the log files are needed. If input files in the network 
shared folders are also needed to troubleshoot a problem, scrub them first so that no customer proprietary 
information such as passwords are included. 
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2. Installing and Configuring Desktop RAWC 
Perform all installation and configuration tasks as Administrator. 

2.1 Workflow 
Figure 2 illustrates the Desktop RAWC installation workflow, along with requirements and high-level tasks. 

Figure 2. Desktop RAWC Installation Workflow 

 

If you are using Outlook, you can install the Email Server virtual machine before or after installing the Desktop 
RAWC Controller, but it should be set up before creating the target desktop VM master image. This enables you to 
include the address of the Email Server in the target desktop VM master image. 

The Desktop RAWC Controller must be set up before creating target desktop VMs. 

Target desktop VMs must be in place before creating session launcher VMs because you need to know the 
addresses of the target desktop VMs when you create the session launcher VMs. 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 10 of 40 

2.2 Setting Up the Environment 
Set up a VMware Infrastructure or VMware vSphere on compatible hardware in a lab (non-production) environment. 

2.3 Creating a RAWC Controller and Shared Network Folders 
Desktop RAWC requires two shared network folders: 

 Log_Folder – Workload input files are located in this folder so that they are available to target desktop VMs. 
Target desktop VMs write timing and error logs to this folder. 

 SessionLauncher_Share – Input files needed by session launcher VMs are located in this folder, and 
session launcher VMs write log files to this folder. 

To create the RAWC Controller and shared network folder 

1. Create a Microsoft Windows 2003 Server VM (or install a physical machine) to be the RAWC Controller. 

2. Create Log_Folder under the root the drive on the Desktop RAWC Controller. For example, 
C:\Log_Folder.Select the folder. 

a. Select File > Properties. 

b. Click the Sharing tab. 

c. Select Share this folder. 

d. For Share name, enter the name of the shared folder. 

e. Click Permissions. 

f. Set permissions for the Everyone group to allow Full  Control . 

g. Click the Security tab. 

h. Set permissions for the Everyone group to allow Full  Control . 

i. Click OK. 

3. Repeat Step 2 to create SessionLauncher_Share. 

2.4 Downloading and Installing the RAWC Installation Package 
Before downloading the Desktop RAWC installation packages and running the installer, set up the RAWC 
Controller. 

Download the Desktop RAWC installation package and install it on the RAWC Controller. 

 VMware Solution Providers can download RAWC and associated materials from Partner Central. 

 VMware consultants can download RAWC and associated materials from the Services Automation page on VM 
Vault. 

To download Desktop RAWC from Partner Central 

1. Log in to Partner Central. 

2. Click the Sales Tools tab. 

3. Scroll to and click Services IP. 

4. Click the Desktop tab. 

5. In the Build section, click VMware Desktop RAWC (Setup). 
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To install Desktop RAWC 

1. Download the Desktop RAWC installation package, DesktopRawcSetup_1.2.0.zip. 

2. On RAWC Controller, unzip the installation package. 

3. Run DesktopRawcControllerSetup.msi. 

4. If you have not already installed the Microsoft .NET 2.0 (or later) framework, you are prompted to do it now. 
Download it from http://www.microsoft.com/NET/ 

5. In the EULA dialog box, select I agree, and click Next. 

6. Browse to select the installation folder or accept the default. 

7. Select Everyone or Just me to specify who should have access to Desktop RAWC, and click Next. 

8. Click Next to start the installation. 

9. When the installation is complete, click Close to exit. 

2.5 Downloading and Setting Up the Email Server Virtual Machine 
If you are going to use the Microsoft Outlook workload for the test you need an email server. You can use the email 
server provided with Desktop RAWC, or use your own Microsoft Exchange server. If you do not want to use the 
Outlook workload you can skip this section. 

The Email Server virtual machine is comprised of the following software: 

 CentOS operating system 

 Dovecot 

 Sendmail 

2.5.1 Downloading and Installing the Email Server 

To install the Desktop RAWC Email Server 

1. Download the Desktop RAWC installation package, RAWC-EmailServer-VMX.zip from Partner Central (for 
partners) or VMware Vault (for VMware consultants). 

2. Use VMware vCenter™ Converter 4.x to install the Email Server on VirtualCenter 2.0 (or later), vCenter 4.0, or 
ESX 3.0 (or later). If you do not have VMware vCenter Converter, you can download it from the VMware 
Support and Downloads Web page at 
http://downloads.vmware.com/d/info/datacenter_downloads/vmware_vcenter_converter_standalone/4_0. 

VMware Converter is used to install the Email Server virtual machine because it is distributed in VMX format. 
Alternatively, you can copy the virtual machine files to a location accessible from an ESX host and add the virtual 
machine from a VI or vSphere Client as follows: 

To register the controller appliance on an ESX 3.5 host 

1. From the VI Client or vSphere Client, select the desired ESX host. 

2. Select the Configuration tab. 

3. Under Hardware, click Storage. 

4. Double-click the file system where you placed the virtual machine files and navigate to the directory where you 
placed the virtual machine files. 

5. Right-click the .vmx file 

6. Select Add to Inventory, and follow the instructions to add the virtual machine to the VI Client inventory. 
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2.5.2 Configuring the Email Server 

Prerequisites: 

 A static IP address. 

 A valid fully-qualified domain name. 

To configure the Email Server 

1. Boot the Desktop RAWC Email Server virtual machine. 

2. Use VirtualCenter/vCenter to access the console of the Email Server virtual machine and log in to the appliance 
using default credentials: 

Login: root  

Password: vmware  

3. Install VMware Tools from the menu or from the command-line: 

a. Click VM >Guest > Install/Upgrade VMware Tools. 

b. From the virtual machine command-line: 

mkdir /mnt/vmware-tools 

mount /dev/cdrom /mnt/vmware-tools 

cd /mnt/vmware-tools 

cp /mnt/vmware-tools/VMware-Tools*.tar.gz /tmp 

cd /tmp 

tar zxvf VMware-Tools*.tar.gz 

cd vmware-tools-distrib 

./vmware-install.pl (follow the prompts) 

vmware-config-tools.pl (follow the prompts) 

Reboot the virtual machine after the installation completes. 

4. Verify that the VMware Tools Suite installed correctly: 

a. In the VI Client or vSphere Client, select the virtual machine. 

b. On the right-hand pane, select the Summary tab 

c. Confirm that VMware Tools shows a status of OK. If it shows any other status, reinstall VMware Tools. 

5. Log in to the appliance again. 

6. Change directory to /root/rawc  

7. Set the static IP address and the corresponding settings by running the command: 

python ./config_appliance.pyc -i <ipaddr> -m <netmask> -g <gateway> -d 
<hostname.full-domainname> -n <dnsip1> [,<dnsip2>, ...] 

Replace <ipaddr>, <netmask>, <gateway>, <full-domainname>, <dnsip1>, and (optionally) additional DNS 
addresses with appropriate values, including the static IP address and the hostname.domainname. For 
example: 

python ./config_appliance.pyc -i 10.17.50.171 -m 255.255.254.0 -g 10.17.50.107 -d 
rawc-email-server.vdi-smtp2.rawc.local -n 10.17.50.107,10.10.18.1,10.20.10.1 
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Note To make sure that all target desktop VMs will know the address of the Email Server, on the target 
desktop master VM XP-VM-00, edit C:\windows\system32\drivers\etc\hosts and add a line 
with the domain name and IP address of the email server. For example, vdi-smtp2.rawc.  local  
10.17.50.171 . 

2.5.3 Creating User Accounts on the Email Server 

The users created by the following procedure are used by the Email Server for the email workload. (These are not 
the users that you later need to create in Active Directory which are used to log in to the target desktop VMs.) 

Because of the way the useraddition.sh script generates user accounts you have to edit and run the script 
multiple times  to generate the correct set of users if the range of IP addresses spans subnets, or if the final octet of 
the low value is two digits and the final octet of the high value is three digits. 

To create user accounts on the Email Server 

1. Determine the range of IP addresses for all VMs that will be used for the test. For this example, we use a range 
from 10.129.1.97 through 10.129.1.109. Because the final octet changes from two to three digits, you have to 
edit and run the script twice to generate the complete set of email user accounts. 

2. From the Email Server virtual machine command-line: 

 cd /root/rawc 

3. Edit the useraddition.sh script: 

a. On the line that contains start  = 2090 , change the number to the lowest number in the IP address range. 
For example, if 10.129.1.97 is the lowest IP address in the IP address range, concatenate the values in the 
third and forth segments of the IP address, and enter 197 . 

b. On the line that contains end = 2103 , change the number to the highest two-digit number in the final octet 
of the IP address range. For example, if 10.129.1.109 is the highest IP address in the IP address range, 
enter 199 . 

c. Save the file. 

d. Run useraddition.sh to generate the first set of users. 

e. Edit the useraddition.sh script: 

f. On the line that contains start  = 197 , change the number to the lowest number in the second part of the 
IP address range. For example, if 10.129.1.97 is the lowest IP address, concatenate the values in the third 
and forth segments of the IP address, and enter 1100 . 

g. On the line that contains end = 199 , change the number to the highest number in the IP address range. 
For example, if 10.129.1.109 is the highest IP address in the IP address range, enter 1109 . 

h. Save the file. 

i. Run useraddition.sh to generate the second set of users. 

The Outlook function in Desktop RAWC uses “guest” plus the third and forth segments of the IP address as the user 
name when sending an email. For example, a VM with an IP address of: 69.110.17.180 will have a user name of: 
guest17180.  

Note Though you do not normally need it, the password is defined within the useraddition.sh script. 
Default is abc123 . 
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2.5.3.1. Example Using Multiple Subnets and a Two- to Three-Digit Final Octet Range 

Your target desktop VMs have address ranges 10.129.132.50 – 10.129.132.249 and 10.129.133.60 – 
10.129.133.249. Because of the way useraddition.sh generates user accounts, giving a start value of 13250 
and an end value of 133249 would generate thousands of guest users—not the desired result! 

To properly generate guest users in this case you need to edit and run useraddition.sh four times, once for 
each of the start and end values shown in the following table. 

Start and End Value Generated Guests 

Start=13250 
End=13299 

This generates users guest13250 – guest13299. 

Start=132100 
End=132249 

This generates users guest132100 – guest132249. 

Start=13350 
End=13399 

This generates users guest13350 – guest13399. 

 

Start=133100 
End=133249 

This generates users guest133100 – guest133249. 

2.5.4 Next Step 

You still need to run Outlook Setup for every user that will run a workload and verify that email can be sent, but you 
must first clone target desktop VMs. Section 5 provides information about these final configuration tasks. 

2.6 Creating Active Directory Users 
Create one user in Active Directory for each target desktop VM you want to use in the test. Appendix A: vdiusers-v1 
Script provides a script that you can use to create these users. Alternatively, you can create users manually, or your 
customer may have procedures or scripts that you can use to create users. 

 

2.7 Creating and Configuring Desktop VMs 
You will use the first target desktop VM you create as a master image from which other target desktop VMs can be 
cloned after it is fully configured. In this guide, the target desktop VM master is named XP-VM-00. 

2.7.1 Installing Applications on XP-VM-00 

Install the applications to be used for the test on the target desktop VM, XP-VM-00. If an application path or file 
name does not match what is expected, RAWC will not work. A test script is provided for use during the pre-test 
(see Section 4) to verify that everything is in the right location. 

Some application files are provided with Desktop RAWC and others can be downloaded, but you must provide your 
own licensed copies of applications such as Microsoft Office, and McAfee AntiVirus. Resolve any licensing issues 
with the software packages. If you do not install a software package or do not want to include a particular 
application for the test, verify that the corresponding application option is not selected in the UI. 

2.7.1.1. View Agent 

A View Agent must be installed on each target desktop VM. Use a 32- or 64-bit agent depending upon whether the 
target desktop VM runs on a 32- or 64-bit OS. 
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2.7.1.2. Installing Microsoft Office 

Install Microsoft Office 2007 with the latest patches and verify the following paths: 

 Windows 7 (32-bit) or XP: C:\Program Files\Microsoft Office\OFFICE12\<application name> 

 Windows 7 (64-bit): C:\Program Files (x86)\Microsoft Office\Office12\<application name> 

Where application name is WINWORD.EXE, EXCEL.EXE, POWERPNT.EXE or OUTLOOK.EXE. 

2.7.1.3. Installing Microsoft Internet Explorer 

Install Microsoft Internet Explorer 8 with the latest patches, and verify the following path: 

 Windows 7 (32-bit) or XP: C:\Program Files\Internet Explorer\iexplore.exe 

 Windows 7 (64-bit): C:\Program Files(x86)\Internet Explorer\iexplore.exe 

Other versions of Internet Explorer might work, but have not been tested. 

2.7.1.4. Installing Windows Media Player 

1. If you have not already downloaded Windows Media Player 11 for XP, or 12 for Windows 7, go to: 

http://www.microsoft.com/windows/windowsmedia/player/11/default.aspx 

http://windows.microsoft.com/en-US/windows7/products/features/windows-media-player-12 

2.  Install Windows Media Player, and verify this path: 

 Windows 7 (32-bit) or XP: C:\Program Files\Windows Media Player\wmplayer.exe 

 Windows 7 (64-bit): C:\Program Files(x86)\ Windows Media Player\wmplayer.exe 

2.7.1.5.  Downloading and Installing Adobe Reader 

1. If you have not already downloaded Adobe Reader, go to 

http://get.adobe.com/reader/ 

Click Download. 

2. Install Adobe Reader, and verify this path:  

 Windows 7 (32-bit) or XP: C:\Program Files\Adobe\Reader 9.0\Reader\AcroRd32.exe 

 Windows 7 (64-bit): C:\Program Files(x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe 

3. Disable Adobe Updater for all users so that it does not start when you open a PDF file: 

a. Download the file http://www.adobe.com/support/acrobat/ts/documents/kb402050/disableupdates.zip. 

b. Unzip and extract the disableupdates.reg file to a local folder. 

c. Double-click disableupdates.reg. 

d. Click Yes to add the registry settings to the registry. 

For more information about disabling Adobe Reader updates, see http://kb2.adobe.com/cps/402/kb402050.html. 
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2.7.1.6. Installing McAfee AntiVirus 

Install McAfee VirusScan Enterprise 8.7.0i software and verify this path:  

 Windows 7 (32-bit) or XP: C:\Program Files\McAfee\VirusScan enterprise\scan32.exe 

 Windows 7 (64-bit): C:\Program Files(x86)\McAfee\VirusScan enterprise\scan32.exe 
 

Notes: 

 You might not want to install Virus Scan if you are not testing it because it can impact performance. 

 The Virus Scan Add-In in Microsoft Outlook causes Outlook to start up slower. If you installed it but decide to 
not test it, you can remove it by accessing Outlook and selecting Tools > Options > Advanced > Add-In 
Manager. 

 Configure VirusScan appropriately—do not allow scanning or updates to occur during testing. 

2.7.1.7. Installing Sun Java JDK 

If you have not already downloaded it, download Sun Java JDK 6 Update 16 (or later) from 
http://www.oracle.com/technetwork/java/javase/downloads/index.html. 

Install the Sun Java JDK and modify the environment variable, Path, to include the path to Java JDK bin directory. 

 To set the Path environment variable: 

1. Open Windows Explorer, right-click and select My Computer > Properties. 

2. Click the Advanced tab. 

3. Click Environment Variables. 

4. Under System variables, double-click the Path variable 

5. Append the pathname to the bin folder under the Java JDK installation location to the end of the Variable 
value. For example, C:\Program Files\Java\jdk1.6.0_18\bin. (This location varies depending upon 
the installer used.) 

6. Click OK repeatedly until all dialog boxes are closed. 

7. To confirm the path is set correctly, open a command prompt window and type javac. Usage information for 
javac should be displayed. If you get an error that indicates that javac is not recognized, try again to set the 
path. 

2.7.2 Installing Workload Files on XP-VM-00 

Most of the applications you install on the target desktop VM XP-VM-00 use provided files or files you can download 
and install for the test. This section shows how to install the RAWC workload application and download or install 
other necessary workload files. 
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2.7.2.1. Installing the Desktop RAWC Workload Application 

The files required for the following procedures were in the DesktopRawcSetup.zip file that you previously 
downloaded and unzipped. 

To install the Desktop RAWC workload application 

1. Run the workload application setup program, DesktopRawcWorkloadSetup.msi. 

2.  If you have not already installed the Microsoft .NET 2.0 (or later) framework, you are prompted to do it now. 
Download it from http://www.microsoft.com/NET/. 

3. Click Browse to select the installation folder, or accept the default. 

4. Select Everyone and click Next. 

5. Click Next to start the installation. The Shared folder location dialog box is displayed. 

Figure 3. Shared Folder Location Dialog Box 

 

6. In the Shared folder location dialog box: 

a. Shared Location Path * – Click Browse to select the Log_Folder created during RAWC Controller 
setup. 

b. Drive Letter * – Select from the drop-down menu the drive to which the Log_Folder will be mapped. 

c. User and Password – If the folder is shared to Everyone you can leave these fields empty. Some 
customer environments might require that you enter a user and password if access is needed to shared 
folders not present on the Desktop RAWC Controller. 

The installer tests share access by mapping and un-mapping the shared location using the provided 
information. This information is stored in a text file and is used to map the drive to shared folder when the 
workload is run and the user logs in. 

7. When the installation is complete, click Close to exit. 
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2.7.2.2. Copying Video Files 

To install the Video files 

1. If you have not already downloaded the video files, go to: 

http://www.microsoft.com/windows/windowsmedia/musicandvideo/hdvideo/contentshowcase.aspx 

2. Select and download the following files to the C:\Temp directory: 

 Super Speedway (720p) 

 The Living Sea (1080p) (Be sure to select the 1080 version.) 

3. Unzip the downloaded files and place them in C:\Temp\WMdownloads. 

 SuperSpeedway.exe 

 The_Living_Sea_1080.exe 

4. Verify the following paths: 

 C:\Temp\WMdownloads\SuperSpeedway.wmv 

 C:\Temp\WMdownloads\The_Living_Sea_1080.wmv 

The XP-VM-00 master is now complete, but conduct a pre-test to validate the setup before cloning to create 
additional target desktop VMs. Section 4 provides information about conducting a pre-test. 

2.7.3 Executables and File Locations on RAWC VM XP-VM-00 

To verify that executables and files are in the right locations and suppress pop-ups 

1. Login to XP-VM-00 as Administrator and stop the RAWC workload application by right-clicking on the AutoIT icon on the 
bottom-right in the status bar of the VM. The workload application starts automatically after the user logs in. 

2. Add the test users’ Active Directory group to the local Administrators group. This ensures that test users have full 
permission to run the workload. 

3. Add the test users’ Active Directory group to Remote Desktop Users to allow View sessions to these desktops 

4. To verify your setup before cloning other VMs from VM XP-VM-00, select Start > All Programs > VMware > 
VMware Desktop RAWC Workload Test Locations. This script verifies that all executables and files are in the 
proper locations. If you have installed Sun Java JDK 16 Update 16 (or later), the Test Locations script may 
give a warning message. You can safely ignore this message as later versions of the Java JDK will also work 
with the RAWC workload. 

Resolve any issues for the applications you are using for the test and re-run the script until all files are in the 
proper place. 

5. Open applications using the test user account(s) to satisfy any user-specific prompts and verify that each 
application can run without any issues:  

 Open Microsoft Word, Excel and PowerPoint, and respond to all user customization prompts. Close and 
open them again to verify that no prompts are displayed when the user runs these applications. 

 Open Internet Explorer and respond to all user customization prompts. Close and open them again to verify 
that no prompts are displayed when the user runs it. 

 Open Adobe Acrobat Reader and respond to any user or EULA prompts. Close and re-open the application 
to verify that no prompts are displayed when the user runs this application. 
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 Manually run the anti-virus software to verify that it can be opened and run without any issues. 

 Open Windows Media Player and run the race car video you downloaded to verify that Windows Media 
Player can be opened and run without any issues. 

6. Configure Group Policy Settings locally to suppress user customization pop-ups for Windows Media Player. 

a. Click Start > Run. 

b. Enter gpedit.msc, and click OK. 

c. Select Local Computer Policy > Computer Configuration > Administrative Templates > Windows 
Components > Windows Media Player, and double-click Do Not Show First Use Dialog Boxes. 

d. Select Enabled. 

e. Click OK to close window and close the group policy editor window. 

7. Configure Group Policy Settings locally to suppress user customization pop-up windows for IE8. 

a. Click Start > Run. 

b. Enter gpedit .msc , and click OK. 

c. Select Local Computer Policy > User Configuration > Administrative Templates > Windows 
Components > Internet Explorer, and double-click Prevent performance of First Run Customize 
settings. 

d. Select Enabled. 

e. From the drop-down menu under Select your choice, select Go directly to home page. 

8. Log off from the VM. 

2.7.4 Suppressing the UAC Prompt on Windows 7 Target Desktop VMs 

When a user logs into a Windows 7 target desktop VM, a User Account Control (UAC) setting sends a prompt 
asking if the Windows registry can be modified. This should be suppressed so that it does not occur during your 
test. 

To suppress the UAC prompt 

1. Select Control Panel > All Control Panel Items > User Account Control Settings.  

2. Drag the slide bar to Never notify. 

2.8 Creating Session Launcher VMs 
Set up one or more session launcher VMs to launch desktop sessions. Each session launcher VM can support up 
to 20 target desktop VMs. The session launcher VMs should be on a different ESX host than the target desktop 
VMs so that the session launcher VMs do not impact performance data. 

Install a View Client on each session launcher VM. A View Connection Server is also required. 

To install the Desktop Session Launcher 

1. On every session launcher VM, run DesktopSessionLauncherSetup.msi. (This file is included in the 
DesktopRawcSetup.zip file that you previously downloaded.) 

2. Click Browse to select the installation folder, or accept the default. 

3. Select Everyone or Just me to specify who should have access to Desktop RAWC, and click Next. 

4. Click Next to start the installation. 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 20 of 40 

5. In the Shared Folder Location dialog box: 

a. Shared Location Path * – Click Browse to select the SessionLauncher_Share created during RAWC 
Controller setup. 

b. Drive Letter * – Select from the drop-down menu the drive to which SessionLauncher_Share will be 
mapped. 

c. User and Password – If the folder is shared to Everyone you can leave these fields empty. 

The installer tests share access by mapping and un-mapping the shared location using the provided 
information. This information is stored in a text file and is used to map the drive to shared folder when the 
workload is run and the user logs in. 

6. When the installation completes, click Close to exit. 

The installer places the Desktop Session Launcher executable in the Startup folder so that desktop sessions are 
automatically launched when you log in to a session launcher VM. 

Caution You can disconnect from a session launcher VM after logging in, but do not log off. If you log off the 
sessions will close and end the test. 
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3. Configuring and Launching a Test 
Use the Desktop RAWC UI to configure and launch the pre-test and the full test. This section shows you how to use 
the UI, but you do not actually use it until you are ready to configure a pre-test or full test. 

3.1 Configuration Tab 
Use the Desktop RAWC UI Configuration tab to configure the test. Default values are populated when the UI is 
displayed. Do not change the default values if you are not using them. 

To configure a test 

1. On the RAWC Controller, double-click the icon or file name to open the Desktop RAWC UI. Figure 4 shows the 
Configuration tab. 

Figure 4. Configuration tab 
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2. Complete the General section (asterisks indicate required fields): 

 Test Name * – Enter the test name (maximum = 50 alphanumeric characters). The test name is written to 
the configuration file, and is then written to the first line in the error and timing logs. 

 Description – Enter a description of the test (200-character limit). For example, “Pre-test of a single VM.” 
The test description is written to the configuration file. 

 Log Folder * – Click Browse to find and enter the name of the log folder to be used for the test. 

  Email Server – Click Edit Settings to configure the Email Server for the test. If you are not running 
Microsoft Outlook or Outlook Setup, do not change these values. 

o Email domain name – Enter the domain name of the Email Server. 

o Incoming mail server – Enter the IP address or fully qualified domain name of the Email Server. 

o Outgoing mail server – Enter the IP address or fully qualified domain name of the SMTP server. 

o Password – Enter the password that you used when the guest users were configured (default = 
abc123). 

Click OK. 

 Application Launch Order – Select Random or Static. This determines whether application workloads 
are launched randomly or in a static order. 

o Random – This is the standard mode in RAWC. By running applications in a random order, 
applications are executed in a different (random) order on different virtual machines. When running 
applications in a random order: 

 A varying start delay is in effect, depending on number selected for Total # of VMs under test. 

 The random delay between applications (Application Launch Delay) is calculated on the fly. When 
running applications in random mode, you choose the upper limit number used in the random delay 
calculation. 

o Static – By running applications in a static order, all virtual machines run the exact same test, including 
applications running in the same order and with fixed delays between the applications. This feature 
gives you the ability to repeat a test over and over. When running applications in a static order: 

 The applications selected run in the exact same order for each iteration on each virtual machine. 

 There is no start delay in effect. A varying start delay in this situation is irrelevant as the exact same 
applications are running on each virtual machine. So, regardless of whether the test started in 1 minute 
or 12 minutes or 40 minutes, all virtual machines would start together. 

 The random delay between applications (Application Launch Delay) is now a fixed delay. When 
running applications in static order, the upper limit number that is selected becomes the actual delay 
between the applications. 

 Application Launch Delay – Select the launch delay in seconds. The application launch delay is used to 
either increase or decrease the load on the server by running the applications closer or further apart.  

o When running applications in a random order, the number selected for the application launch delay 
becomes the upper limit of a random delay that is calculated on the fly. For example, the random delay 
that is calculated could be 1 second or 119 seconds or any number in-between if 120 seconds is 
selected. 

o When running applications in a static order, the number selected for the launch delay becomes the 
actual fixed delay between applications. 
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o Typically, the greater the number of virtual machines under test, the larger a number you should select 
(above 120 seconds). 

o By selecting a lower number, you can generate a heavier load by making the applications run closer 
together. 

 Total # of VMs under test * – Select the number that is closest to the total number of target desktop VMs 
involved in the test. Default is 10 . This feature enables you to simulate a normal login scenario or create a 
more intensive boot storm.  

A normal login scenario allows virtual machines to start their workloads over a period of time. Select the 
number of virtual machines that is closest to the number of virtual machines you have under test. This 
determines the staggered start delay of the VMs as follows: 

o 10 VMs – No delay 

o 64 VMs 0-12 minute delays 

o 250 VMs 0-24 minute delays 

o 500-1000 VMs 0-54 minute delays 

A boot storm occurs when more virtual machines start their workloads closer together, thus creating a 
larger load on the server. A boot storm scenario may occur after systems have recovered from a power 
outage or when users log in first thing in the morning. A boot Storm scenario can be created by selecting a 
lesser number of virtual machines under test. For example: if you are running a 500 VM test, select 250 . 
That causes 500 virtual machines to start within 0 to 24 minutes of each other. 

 Test Mode – Select Iterations and enter the number of iterations you want the target desktop VMs to run 
(default = 3, maximum = 1000), or select Duration and enter the number of minutes (default = 120). 

o Iterations – Select the number of iterations you want the virtual machines to run. If you are interested 
in the open and close times of applications, run at least three iterations. Applications take longer to 
open the first time—by the second iteration, applications/pages have been cached and the open times 
are much shorter. 

o Duration – Select the number of minutes you want the test to run. When using duration: 

 Virtual machines do not finish at exactly the same time or exactly at the end of the specified duration. 

 Time checks are performed before and after random (or static) delays between applications. 

 Time checks are performed at certain points while an application is performing. For example: a time 
check occurs before and after an email is sent, but not during the creation of an email. A time check 
also occurs before and after the slide presentation. 

 When the duration time has elapsed, the log files are closed and the desktop is cleaned up of any open 
applications. 

If you are using Active Directory groups and running in the duration test mode, you might notice that lighter 
workloads (2-3 applications) run more iterations of the applications than a heavier workload (5+ 
applications). This is reasonably accurate as task workers are limited in the number of applications they 
run, and more often than not use these applications more often. 

 Logoff User(s) after Test Completion – Select to automatically log off desktop users after the test 
completes. Otherwise, you have to logoff every user using the View Client or Terminal Services Manger, or 
you can restart the VMs from vSphere Client 
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3. In the Workload section, configure one or more Active Directory group workloads, or a non-Active Directory 
group workload. You cannot run both Ad and non-AD group workloads at the same time. 

 To configure an Active Directory group, select AD Group, enter the Active Directory group name, and 
select the applications to run for the group.  

 To configure a non-AD group, make sure that the AD Group check box is not selected, and select the 
applications to run for the test. Leave Outlook Setup unselected as this was previously run for each user. 
The group name defaults to Non-AD Group . Only one non-AD group can be configured for a test. 

4. In the Outlook part of the Workload section, in the # of emails field, if you are running Outlook enter the 
number of emails you want to generate. Outlook opens, sends one email, and then minimizes. Outlook is 
maximized at a later point during the test and generates the number of emails specified. 

5. In the Word Doc part of the Workload section, enter the typing speed and number of random words to 
generate: 

 Typing speed – Select one of the values. 

 # of random words – If you selected Random Word Doc, select the number of random words to be 
generated. The default is 400. 

6. In the PDF part of the Workload section, in the Pages to browse field, select the number of PDF pages for 
Adobe Reader to browse. If you are not running Adobe Reader, leave it at 15  (default). 

7. When you are done configuring a group, click Save Workload Group. If you are configuring multiple AD 
groups, repeat steps 4-8 until all groups are configured and saved. 

8. When you are done setting up all of the groups you want (one non-AD group, or one or more AD groups), click 
Save Configuration to validate and save the entire configuration. 

9. After setting up all of the groups you want, click Set as active workload to copy the group and configuration 
files to the shared network folder on the RAWC Controller. 

Note Clicking Set as active workload automatically backs up any existing configuration files in the shared 
Log_Folder to a subfolder with a folder name in the format: <backup date/time>. 
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3.2 Session Launcher Tab 
Use the Session Launcher tab to create session launcher configuration files and to launch the sessions. Figure 5 
shows the Session Launcher tab. 

Figure 5. Session Launcher Tab 
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3.2.1 Creating Session Launcher Configuration Files 

To create session launcher configuration files 

1. Click the Session Launcher tab. 

2. Click Browse to select the SessionLauncher_Share folder to create session launcher configuration files. 

3. Click Create session launcher configuration files to create one or more session launcher configuration files. 

Figure 6. Create Session Launcher Configuration Files Screen 

 

 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 27 of 40 

1. Enter a session launcher host name or IP address, and click Add. The session launcher you enter is pinged to 
verify that it can be reached from the Desktop RAWC controller. If it cannot be pinged, the entry cannot be 
added. 

2. In the Section, Target Desktop VM View User Session: 

 View Desktop Name – Enter a unique name for the View desktop. 

 Domain – Enter the FQDN for the domain. 

 User Name Prefix – Enter a prefix for the user name. A numeric suffix is added to the prefix to create a full 
user name. For example, DesktopUser1, Desktop User2, and so on. 

 Suffix Begin # – Enter a value for the first user in the range of users for this user name prefix. 

 Suffix End # – Enter a value for the last user in the range of users for this user name prefix. 

 Password – Enter the password for the session launcher. 

 View Connection Server – Enter the host name or IP address of the View connection server. 

 View Connection Protocol – Select PCoIP or View RDP. This is the protocol that View client sessions will 
use to connect to target desktop VMs. 

 Session Launch Delay. – Use the drop-down menu to select a value in seconds for the launch delay 
(default = 15 seconds). This is the delay between target VM session launches from a session launcher. 

3. Click Create Configuration Files. 

Repeat this procedure for each session launcher configuration file you want to create. 

Notes: 

 If you want to use fullscreen desktop for the View Client window, in the SessionLauncher_Share folder, edit 
view-commandline.txt and add the option -desktopLayout fullscreen.  

 You can optionally add other View Client command-line options as specified in the VMware View Manager 4.x 
Administration Guide.  

3.2.2 Launching Desktop Sessions 

To launch VMware View desktop sessions 

1. On the Session Launcher tab, click Browse to select the folder SessionLauncher_Share. This reads all 
input configuration files created for each session launcher and displays the datagrids. 

2. To launch the target desktop sessions, click Open Session Launcher VMs. 

Note For View RDP, an RDP session to the session launcher VM opens in a window. To use full screen 
mode, change screen mode id: i:1  to screen mode id: i:0  in the file template.rdp under Desktop 
RAWC UI install location. 

3. Click OK on the message pop-up indicating how many sessions will be launched, or click Cancel to cancel the 
launch and return to UI. 

4. Enter user login information to open RDP sessions to the session launcher VMs. The same user information is 
used to open RDP sessions to all session launcher VMs. 
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3.2.2.1. Opening Session Launcher VMs 

Session launcher VMs are zombie VMs that are used to launch user sessions to the target desktop VMs where the 
workload is executed. On the Desktop RAWC UI Session Launcher tab, click Open Session Launcher VMs to 
open the session launcher VMs, which in turn launch user sessions on target desktop VMs. 

Figure 7. Opening Session Launcher VMs 

 

When an RDP session is opened to a session launcher VM, the session launcher is automatically executed 
because there is a shortcut to the desktop session launcher executable in the Startup folder. The session launcher 
then maps the drive to SessionLauncher_Share, reads the input file associated with each session launcher VM 
from the network share, and sequentially launches one user session to each target desktop VM. 
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4. Conducting a Pre-test 
The objective of conducting a pre-test is to: 

 Verify that log folders can be created in the shared network folder on the RAWC Controller. 

 Verify that the target desktop VM can deposit error and timing log files in the shared network folder. 

 Verify that the configuration file for a group can be created and launched. 

 Verify that the selected applications can run on the target desktop VM, including that the Email user can be set 
up, and Email can be created and sent (Email Server is functioning correctly). 

 Verify that Microsoft Word, Excel and PowerPoint can be opened without additional user-specific customization 
prompts. 

 Verify that Internet Explorer and Windows Media Player can be opened without additional user-specific 
customization prompts. 

 Verify that Adobe Acrobat Reader can be opened without any additional EULA acceptance prompts. 

 After the test is completed, verify that the error and timing log files have data. 

Always run a pre-test to verify the setup is valid before running a test.  

4.1 RAWC Controller 
Verify that the Desktop RAWC UI can create the log folders on the RAWC Controller. 

To verify that the UI can create log folders 

1. Set up the pre-test and configure the workload you want to run by selecting the appropriate applications using 
the Configuration tab. Setting up a pre-test is the same as setting up a test, but you only use one session 
launcher VM and the XP-VM-00 target desktop VM. 

2. Click Set as active workload. 

3. On the Session Launcher tab, click Open Session Launcher VMs to start the workload on XP-VM-00. 

4. Verify that the AutoIT icon (small, gray, round icon) is present on the bottom-right of the status bar for the VM. 

5. XP-VM-00 writes a text file to the started folder in the shared network folder on the RAWC Controller. The file 
is named with the IP address of the VM. The presence of <IPAddress>.txt indicates that the script has 
been started. 

6. After the configuration and group (if using groups) files have been launched from the RAWC UI, verify that the 
following test files were created in the log folder on the RAWC Controller: 

 Timinglog.IPAddress.txt – captures open, save, close times 

 Errorlog.IPAddress.txt – captures any errors 

7. Depending on the number of target desktop VMs under test, there may be a start delay on the VM. An 
Information box displays a countdown until the test starts. 

8. Close the console on XP-VM-00. 

9. Close the VM. 

Caution You can watch the test by keeping the console open, but do not perform any work or click the mouse in 
the console as this will take focus away from the application and jeopardize the test. 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 30 of 40 

4.2 Pre-test Results 
After completing an initial test run on XP-VM-00, check the following files on the RAWC Controller: 

 Errorlog.<IP address>.txt – file used to collect errors if a VM fails 

 Timinglog.<IP address>.txt – file used to capture open and close times on the applications—the timing 
that is measured is guest OS timing. 

Resolve any problems found and re-run the pre-test until everything is in place. 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 31 of 40 

 

5. Final Configuration 
After completing a successful pre-test but before running a full test, clone target desktop VMs, prepare input files for 
session launcher VMs and complete Outlook Setup. 

5.1 Cloning Target Desktop VMs 
From the XP-VM-00 master, clone as many target desktop VMs as you need for a full test. 

5.2 Completing Outlook Setup and Verifying Email Messages 
Run Outlook Setup once per user per desktop VM, and confirm that email messages are being successfully sent 
and received. This must be done after the pre-test, but before running a full test. 

Caution If Microsoft Outlook is part of the workload, use a persistent desktop pool so that users will get the 
same desktop for every test. Otherwise, Outlook Setup for users becomes unmanageable. 

To run Outlook Setup for users 

1. On the Desktop RAWC UI, click the Configuration tab. 

2. Select Outlook Setup (only). Verify that no other workloads are selected. 

3. Click Set as active workload. 

4. Click the Session Launcher tab. 

5. Click Open Session Launcher VMs. Outlook Setup is run for each user on every target desktop VM. The 
setups run in parallel. 

6. After Outlook Setup has completed on all target desktop VMs, log off the user session on each target desktop 
VM. You can use the VMware View Manager UI to disconnect user sessions. 

To verify that the Outlook workload can send email 

1. On the Desktop RAWC UI, click the Configuration tab. 

2. Select Outlook (only). Verify that no other workloads are selected. 

3. Click Set as active workload. 

4. Click the Session Launcher tab. 

5. Check the Outlook Inbox for a sampling of users to verify that messages have been received. 

6. After Outlook has completed on all target desktop VMs, log off the user session on each target desktop VM. 
You can use the VMware View Manager UI to disconnect user sessions. 
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6. Conducting a Test 
After cloning target desktop VMs and performing Outlook Setup (if you are using the Outlook workload), you can run 
a full test. 

6.1 Cloning Desktop VMs for the Test 
If the pre-test results indicate that the pre-test run was successful, shut down XP-VM-00 and use it to clone as 
many VMs as you need for a full test. 

6.2 Running the Test 
To run a test 

1. On the RAWC Controller, open the RAWC UI. 

2. Use the Configuration tab to set up the test and configure workloads. 

3. From the RAWC UI, click Open Session Launcher VMs to log in to session launcher VMs which, in turn, 
causes each session launcher VM to launch desktop sessions. 

4. On the RAWC Controller, when the test finishes review error and timing log files. 
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7. Comparing and Charting Test Results 
You can use a Microsoft Excel spreadsheet and Windows performance tools such as the System Monitor to 
compare data and graph results. 

7.1 Log Files 
The log files contain the data you need for comparisons. 

7.1.1 Error Log 

Locate the Errorlog<IPAddress>.txt file on the RAWC Controller and open it. This file includes the following 
information if the test compiles successfully: 

Line1: Group,NA, Test Name, Run 2 - August 2nd 2009 

Line2: 192.168.1.171, Date:  8/2/2009, Time:  6:44:14 PM 

Line3: Test finished:  Date:  8/2/2009, Time:  8:39:46 PM, Completed 3 iterations 
 

If the RAWC workload exited on the VM prior to completing all the iteration, line 3 is left blank. 

If an error occurs on the VM, the error is written to the Errorlog. The Errorlog is then filled with characters to create a 
3KB file and moved to the A_Error_Folder folder in the same directory, and the test program exits. Errorlogs 
with errors are now located in one folder for easier viewing.  
 

Line1:  Group,               Test  Name,  

Line2: IP Address,       Date:          Time:  (Date and time the workload on the VM was started) 

Line3:  Exiting Program – Error Code:  0       Time:                       Iteration #:   

Line4:  Return Code:  0 WinWaitActive () Timeout occurred-Window not found or not activated 

Line5: Line #:                Function:  C01_A_Open()     Command:  WinWaitActive 
 

A return code of 0 (zero) indicates that the command failed. In this case, the WinWaitActive() command failed 
to find the window it was looking for, or it found the window but could not activate it. This typically occurs when the 
system is overloaded. Additional information is provided as to the function and case number where the failure 
occurred and the iteration in which the error occurred. If the system is overloaded, errors will occur in the first 
couple of iterations for some of the VMs, while others do not fail. 

Information about interpreting esxtop statistics can be found at http://communities.vmware.com/docs/DOC-9279. 

7.1.2 Timing Log 

Locate the Timinglog.<IPAddress>.txt file on the RAWC Controller and open it. This file includes header and 
timing information from the VM. For example: 
 

Line1:  Group,              Test Name, 

Line2: IP Address,       Date:        Time:     (Date and time the workload on the VM was started) 

Line3:  Current Time,   IP Address,   Application-Operation,  Iteration #,    Host Time 

Line1: Group, NA, Test Name, Run 2 - Test August 2nd 2009 

Line2: 192.168.1.171,Date:  8/2/2009,Time:  6:44:14 PM 

Line3: Current Time, IP Address,Application-Operation,Iteration #,Host Time 

Line4: 6:45:10 PM,IP192.168.1.171,MSOutlook-Open,1,27391.1344979085 
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Line5: 6:48:00 PM,IP192.168.1.171,PDF-Open,1,6934.88948726298 

Line6: 6:49:36 PM,IP192.168.1.171,MSWord-Doc01-Open,1,2077.19432206999 

Line7: 6:49:39 PM,IP192.168.1.171,MSWord-Doc02-Open,1,1140.30020289056 

Line8: 6:49:43 PM,IP192.168.1.171,MSIntExplorer-Open,1,2815.07249855973 

Line9: 6:49:59 PM,IP192.168.1.171,MSPowerPT-Open,1,1858.84360794529 

Line10: 6:50:08 PM,IP192.168.1.171,MSExcel-Open,1,3139.62444405481 

Line11: 6:52:14 PM,IP192.168.1.171,MSExcel-Save_1,1,420.779655837487 

Line12: 7:08:39 PM,IP192.168.1.171,MSWord-Doc01-Save_1,1,113.148008416201 

Line13: 7:16:02 PM,IP192.168.1.171,MSWord-Doc02-Save_1,1,84.1901219848208 

Line14: 7:16:04 PM,IP192.168.1.171,MSMediaPlayer1-Open,1,851.031559752524 

Line15: 7:18:14 PM,IP192.168.1.171,MSMediaPlayer1-Close,1,484.792674899181 

Line16: 7:18:57 PM,IP192.168.1.171,PDF-Close,1,407.337935024923 

Line17: 7:19:04 PM,IP192.168.1.171,MSWord-Doc01-Close,1,498.902556421111 

Line18: 7:19:12 PM,IP192.168.1.171,MSWord-Doc02-Close,1,254.819589710192 

Line19: 7:19:29 PM,IP192.168.1.171,MSIntExplorer-Close,1,442.595853017058 

Line20: 7:19:44 PM,IP192.168.1.171,MSOutlook-Close,1,424.457078876838 

Line21: 7:22:16 PM,IP192.168.1.171,MSPowerPT-Close,1,45.959218495604 

Line22: 7:22:40 PM,IP192.168.1.171,MSExcel-Save_2,1,83.4779099767052 

Line23: 7:22:42 PM,IP192.168.1.171,MSExcel-Close,1,30.0663557347895 

Line24:  Test finished:  Date:  8/2/2009,  Time:  7:22:42 PM,  Completed 1 iterations 

This data was selected from a timing log file to show a majority of the functions that are part of the test. To perform 
additional analysis and comparisons, this data can be moved into an Excel spreadsheet so that you can manipulate 
it, depending on the comparisons you want to do. 

To compare like applications and operations, and chart the timing log 

1. Open a timinglog file on the RAWC Controller. 

2. Open an empty Excel spreadsheet. 

3. Copy and paste all data from the timinglog into an Excel spreadsheet. 

4. Close the timinglog file. 

5. Repeat this process for each VM, either into the same or a different Excel spreadsheet. 

6. In the Excel spreadsheet, delete line 1 containing the IP address, date and time. This information is not part of 
the header information and cannot be parsed. Also, delete the last line ending at iteration number ##, or do not 
include this line when converting text to columns. 

7. Select all the data and select Data > Text to Columns to convert to columns. 

a. Select the file type that best describes your data: Delimited. 

b. Click Next. 

c. Select the appropriate delimiters: Comma. 

d. Click Next. 

e. Click Finish. 

8. Widen columns to view the data. 
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9. Select all of the data and select Data > Sort to perform a sort. 

a. Sort by: Application-Operation (ascending order). 

b. Then, sort by: Iteration # (ascending order). 

c. Click OK. 

10. Optional: Insert a column and formula to convert the Host Time (in milliseconds) to seconds by dividing the Host 
Time by 1000. (=SUM(E2/1000) 

11. Insert a blank line between the various applications and operations such as; Explorer-Open, Explorer-Close, 
MSWord-Open, 7-Zip-Compress, and so on. 

12. Copy and paste the header information into each blank line. 

13. To chart, select only the Host Time header and timings you want to chart and select: Insert > Chart. 

a. Select the chart type you want: Line. 

b. Select Next. 

c. Review the data range and select Next. 

d. Change the titles as necessary: 

 Chart Title: Explorer Close – 32 VMs – Run 1 

 Category (X) axis: Number of Iterations 

 Value (Y) axis: Seconds (or milliseconds, if you did not add the formula) 

e. Click Next. 

f. Select the chart placement, either As new sheet or As object in. 

g. Click Finish. 

h. Repeat these steps for each separate application and operation. 

This is just one way to chart the data. After the data is in a spreadsheet you can manipulate it, including finding the 
average of a particular application operation. 

7.2 Graphing Results 
You can use the Microsoft System Monitor to graph results. The following procedure shows how to graph the data, 
using disk usage as an example. 

To graph test results 

1. Click Start > Control Panel > Administrative Tools > Performance to bring up the System Monitor. 

2. Click in the graph window and press Ctrl-l (l as in load) to bring up the System Monitor Properties window. 

3. On the Source tab, select Log Files. 

4. Click Add. 

5. In the Select Log file dialog box, select the source log file and click Open. 

6. Click Time Range to display the time range and verify that it corresponds to the time period during which the 
test was run. 

7. Click the Data tab, then click Add. 
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8. Select the data you want to graph: 

a. In the Add Counters dialog box Performance object section, select Physical Disk. 

b. Select Select counters from list. 

c. Select MBytes Read/sec and click Add. 

d. Select MBytes Written/sec and click Add. 

e. Click Select instances from list:  

f. Select DEV-vmhba1:0:0 (for example) and click Add. 

g. Select DEV-vmhba32:0:0 (for example) and click Add. 

h. Click Close. 

9. On the Data tab, remove any counters that are not needed. 

10. Select the Graph tab and enter title and parameters: 

a. In the Title field, enter a title for the graph. For example, 4 VM Test  Disk Usage (Run_09_11_09) . 

b. In the Vertical axis field, specify a value for the vertical axis. For example, 100 . 

c. In the Maximum field, specify a maximum value for the vertical scale. For example, 15 . 

d. In the Minimum field, specify a minimum value for the vertical scale. For example, 0 . 

e. Click OK. 

f. Click File > Save As and save the graph with a descriptive name (for example 4 VM Test  Disk Usage 
(Run_09_11_09).msc) as a Microsoft Management Console file (.msc). 

g. Right-click and select Save Data As, enter a descriptive file name, select Text File [Comma 
delimited][*.csv], and click Save to save the data as a comma-separated values (.csv) file. 

7.2.1 Graphing Other Data 

The following shows the types of counters and instances you should add to graph various performance objects: 

 Performance Object: Physical CPU 

o Counter: % Processor Time  

o Instances: Select All instances 

 Performance Object: Physical Disk 

o Counters: MBytes Read/sec, Mbytes Written/sec (total reads, total writes - add formula) 

o Instance: DEV-vmhba32:0:0 (for example) 

 Performance Object: Memory 

o Counters: PShare Shared, PShare Savings 

o Instances: n/a 

 Performance Object: Memory 

o Counter: PShare Common 

o Instances: n/a 



 
VMware Desktop RAWC 

Installation and User Guide 

 

© 2010 VMware, Inc. All rights reserved.  

Page 37 of 40 

 Performance Object: Memory 

o Counters: Memctl Current, Memctl Max, Memctl Target 

o Instances: n/a 

 Performance Object: Memory 

o Counters: Swap MBytes Read/sec, Swap MBytes Write/sec 

o Instances: n/a 

 Performance Object: Memory 

o Counters: Swap Used, Swap Target 

o Instances: n/a 
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Appendix A: vdiusers-v1 Script 

add-vdiusers-v1.ps1 
This add-vdiusers script creates users in Active Directory for test purposes. The script and a sample add-
users.csv file are provided with Desktop RAWC. 

This script requires the following software: 

 Windows PowerShell 

 QAD cmdlets 

The following is a printout of the add-vdiusers-v1.ps1 script: 

#-- This script automatically creates, configures and enables users in Active Directory for the VMware VDI Testing Tool Kit 

#-- The script depends on PowerShell and QAD cmdlets from Qwest both are free tools – download from 

#-- 

#-- PowerShell from Microsoft - http://www.microsoft.com/windowsserver2003/technologies/management/powershell/download.mspx 

#-- PowerShell Commands for AD - http://www.quest.com/powershell/activeroles-server.aspx 

#-- 

#-- Both will need to be installed on a Windows host that has access to the AD controller in your VMware Testing Environment 

#-- Environment specific variables can be changed to handle any deviations from the VDI testing standard and examples 

#-- This script uses the vdi-adusers.csv file provided for input parameters when creating each VDI test users the most common object attributes 
have already been set. These can easily be changed for environment specific situations 

 

#-- Set Environment specific variables  

$ADserver='192.168.1.21:389' 

$vdiOU="DC=wadingdog,DC=com“ 

$vdiusers="CN=VDI Users,CN=Users,DC=wadingdog,DC=com" 

 

#-- Read user information from the vdi-adusers.csv file 

$userinfo = Import-csv "C:\vdi-adusers.csv" 

$userinfo |foreach { 

 

#-- Create the new users in Active Directory 

New-QADUser -Service $ADserver -ParentContainer $vdiOU -Name $_.Name -UserPrincipalName $_.UserPrincipalName -UserPassword 
$_.UserPassword -FirstName $_.givenName -LastName $_.sn -PhoneNumber $_.PhoneNumber -PostalCode $_.PostalCode -
SamAccountName $_.samaccountname -StateOrProvince $_.StateorProvince -StreetAddress $_.StreetAddress -DisplayName $_.CN 

 

#-- Enable the users, set additional attributes and set passwords 

Enable-QADUser $_.Name -Service $ADserver | Set-QADUser -objectattributes @{mail=$_.emailaddress} -UserPassword 'vditest' 

 

#-- Add each user to the restricted vdi-users group 

add-QADGroupmember -identity $vdiusers -Service $ADserver -Member $_.Name 

 

} 
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Figure 8 shows an add-vdiusers.csv file that provides data to the script (see the included sample script for 
details). 

Figure 8. Sample add-vdiusers.csv File 
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Appendix B: Optimizing a VMware View Test Environment 
Some of the following tips may be useful. 

Master Desktop VM 

On the target desktop VM from which you clone other VMs: 

 If you want to see system failures and send an administrative alert when they occur: select Control Panel > 
System >Advanced >Startup and Recovery >Settings and, in the System failure section, select Send an 
administrative alert and deselect Automatically restart. 

 Check that VMs have proper memory size: usually 512MB or 1024MB. 

 Upgrade VM Tools on VMs, if needed. 

 Modify Windows registry settings as needed, such as disk timeout value (how long OS will wait for a hard disk 
to respond to a command before generating errors). Recommended value is 180 . 

  HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/Disk/TimeOutValue 

 Update Golden Master image with patches (OS, IE, Java), virus scan definitions, other software updates. 

 Disable unneeded services such as automatic updates, remote registry, Secondary Logon, SSDP Discovery 
Service, Wireless Zero, and so on. 

 Turn off System Restore. 

 Set virtual memory size properly. Click Control Panel > System > Advanced. Then, under Performance, click 
Advanced, and under Virtual Memory, click Change and specify virtual memory values. Usually, the Initial 
size and Maximum size values should be the same. A good starting point for a VM is to set it equal to the 
memory size. Increasing this value makes the Linked Clones grow in size, so it should be set to the smallest 
value that provides adequate virtual memory for the guest OS. 

VMware vCenter 

 Enable the DRS cluster setting before powering on VMs. If DRS has trouble meeting requirements for VMs it 
will move them around if DRS is set to fully automated. 

 Make sure VMs are balanced across the ESX settings if you are not using aggressive DRS setting. Migrate 
VMs to a different ESX host, if necessary. 

 Increase the ESX host console memory, if necessary. A user report indicates that a value of 800MB helps to 
stabilize the environment. On vCenter, select Configuration > Memory > Properties. This change requires an 
ESX host reboot. 

Other Optimization 

Before deploying the virtual images, the master target desktop VM image from which the desktops are created 
should be tuned and optimized. Additional optimizations are discussed in the following documents. 

 Windows XP Deployment Guide 

 Optimized XP Virtual Machine for VDI Template Checklist 


