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Notice

Copyright
Copyright 2014 Nutanix, Inc.

Nutanix, Inc.
1740 Technology Drive, Suite 150
San Jose, CA 95110

All rights reserved. This product is protected by U.S. and international copyright and intellectual property
laws. Nutanix is a trademark of Nutanix, Inc. in the United States and/or other jurisdictions. All other marks
and names mentioned herein may be trademarks of their respective companies.

License

The provision of this software to you does not grant any licenses or other rights under any Microsoft
patents with respect to anything other than the file server implementation portion of the binaries for this
software, including no licenses or any other rights in any hardware or any devices or software that are used
to communicate with or in connection with this software.

Conventions

Convention Description

variable_value The action depends on a value that is unique to your environment.

ncli> command The commands are executed in the Nutanix nCLI.

user@host$ command The commands are executed as a non-privileged user (such as nutanix)
in the system shell.

root@host# command The commands are executed as the root user in the hypervisor host
(vSphere or KVM) shell.

> command The commands are executed in the Hyper-V host shell.

output The information is displayed as output from a command or in a log file.

Default Cluster Credentials

Interface Target Username Password

Nutanix web console Nutanix Controller VM admin admin

vSphere client ESXi host root nutanix/4u
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Interface Target Username Password

SSH client or console ESXi host root nutanix/4u

SSH client or console KVM host root nutanix/4u

SSH client Nutanix Controller VM nutanix nutanix/4u

Version

Last modified: August 27, 2014 (2014-08-27 15:06:33 GMT-7)
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1

vCenter Configuration
VMware vCenter enables the centralized management of multiple ESXi hosts. The Nutanix cluster in
vCenter must be configured according to Nutanix best practices.

Using an Existing vCenter Server

Before you begin: If the Nutanix vCenter VM is running, shut it down.

1. Create a new cluster entity within the existing vCenter inventory and configure its settings based on
Nutanix best practices by following Creating a Nutanix Cluster in vCenter on page 5.
The cluster must be configured according to Nutanix specifications given in vSphere Cluster Settings on
page 11.

2. Add the Nutanix hosts to this new cluster by following Adding a Nutanix Node to vCenter on page 6.

3. Configure HA and DRS by following Configuring HA and DRS in vCenter on page 8.

Creating a Nutanix Cluster in vCenter

1. Log on to vCenter with the vSphere client.

2. If you want the Nutanix cluster to be in its own datacenter or if there is no datacenter, click File > New >
Datacenter and type a meaningful name for the datacenter, such as NTNX-DC. Otherwise, proceed to the
next step.
You can also create the Nutanix cluster within an existing datacenter.

3. Right-click the datacenter node and select New Cluster.

4. Type a meaningful name for the cluster in the Name field, such as NTNX-Cluster.

5. Select the Turn on vSphere HA check box and click Next.

6. Select Admission Control > Enable.

7. Select Admission Control Policy > Percentage of cluster resources reserved as failover spare
capacity and enter the percentage appropriate for the number of Nutanix nodes in the cluster the click
Next.

Hosts (N+1) Percentage Hosts (N+2) Percentage Hosts (N+3) Percentage Hosts (N+4) Percentage

1 N/A 9 23% 17 18% 25 16%

2 N/A 10 20% 18 17% 26 15%

3 33% 11 18% 19 16% 27 15%
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Hosts (N+1) Percentage Hosts (N+2) Percentage Hosts (N+3) Percentage Hosts (N+4) Percentage

4 25% 12 17% 20 15% 28 14%

5 20% 13 15% 21 14% 29 14%

6 18% 14 14% 22 14% 30 13%

7 15% 15 13% 23 13% 31 13%

8 13% 16 13% 24 13% 32 13%

8. Click Next on the following two pages to accept the default values.

• Virtual Machine Options
• VM monitoring

9. If the cluster will contain nodes with different processor classes, enable EVC with the lower feature set
as the baseline. Otherwise, accept the default value and proceed to the next step.

a. Click Enable EVC for Intel Hosts.

b. In the VMware EVC Mode menu, select the lowest processor class that is present in the cluster.
For an indication of the processor class of a node, see the Block Serial field on the Diagram or
Table view of the Hardware Dashboard in the Nutanix web console.

c. Click Next.

10. Verify that Store the swapfile in the same directory as the virtual machine (recommended) is
selected and click Next.

11. Review the settings and then click Finish.

What to do next: Add all Nutanix nodes to the vCenter cluster inventory by following Adding a Nutanix
Node to vCenter on page 6.

Adding a Nutanix Node to vCenter

Before you begin: The cluster must be configured according to Nutanix specifications given in Creating a
Nutanix Cluster in vCenter on page 5 and vSphere Cluster Settings on page 11.

Tip:  Refer to Default Cluster Credentials on page 2 for the default credentials of all cluster
components.

1. Log on to vCenter with the vSphere client.

2. Right-click the cluster and select Add Host.

3. Type the IP address of the ESXi host in the Host field.

4. Enter the ESXi host logon credentials in the Username and Password fields.

5. Click Next.
If a security or duplicate management alert appears, click Yes.

6. Review the Host Summary page and click Next.

7. Select a license to assign to the ESXi host and click Next.

8. Ensure that the Enable Lockdown Mode check box is left unselected and click Next.
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Lockdown mode is not supported.

9. Click Finish.

10. Select the ESXi host and click the Configuration tab.

11. Configure DNS servers.

a. Click DNS and Routing > Properties.

b. Select Use the following DNS server address.

c. Type DNS server addresses in the Preferred DNS Server and Alternate DNS Server fields and
click OK.

12. Configure NTP servers.

a. Click Time Configuration > Properties > Options > NTP Settings > Add.

b. Type the NTP server address.
Add multiple NTP servers if required.

c. Click OK in the NTP Daemon (ntpd) Options and Time Configuration windows.

d. Click Time Configuration > Properties > Options > General.

e. Select Start automatically under Startup Policy.

f. Click Start

g. Click OK in the NTP Daemon (ntpd) Options and Time Configuration windows.

13. Click Storage and confirm that NFS datastores are mounted.

14. Set the Controller VM to start automatically when the ESXi host is powered on.

a. Click the Configuration tab.

b. Click Virtual Machine Startup/Shutdown in the Software frame.

c. Select the Controller VM and click Properties.

d. Ensure that the Allow virtual machines to start and stop automatically with the system check
box is selected.

e. If the Controller VM is listed in Manual Startup, click Move Up to move the Controller VM into the
Automatic Startup section.
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f. Click OK.

15. (NX-2000 only) Click Host Cache Configuration and confirm that the host cache is stored on the local
datastore.
 

 

If it is not correct, click Properties to update the location.

What to do next: Configure HA and DRS settings by following Configuring HA and DRS in vCenter on
page 8.

Configuring HA and DRS in vCenter

Before you begin: Add the node or nodes to vCenter by following Adding a Nutanix Node to vCenter on
page 6.

1. Log on to vCenter with the vSphere client.
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2. Right-click the Nutanix cluster node and select Edit Settings.

3. If vSphere HA and DRS are not enabled, select them on the Cluster Features page. Otherwise,
proceed to the next step.

Note:  vSphere HA and DRS must be configured even if the customer does not plan to use
the features. The settings will be preserved within the vSphere cluster configuration, so if the
customer later decides to enable the feature, it will be pre-configured based on Nutanix best
practices.

 

 

4. Configure vSphere HA.

a. Select vSphere HA > Virtual Machine Options.

b. Change the VM restart priority of all Controller VMs to Disabled.

Tip:  Controller VMs include the phrase CVM in their names. It may be necessary to expand
the Virtual Machine column to view the entire VM name.

c. Change the Host Isolation Response setting of all Controller VMs to Leave Powered On.
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d. Select vSphere HA > VM Monitoring

e. Change the VM Monitoring setting for all Controller VMs to Disabled.
 

 

5. Configure datastore monitoring.

a. Select vSphere HA > Datastore Heartbeating (for vCenter 5.1) or vSphere HA > Advanced
Options (for vCenter 5.0).

b. Click Select only from my preferred datastores and select the Nutanix datastore (NTNX-NFS).

c. (vCenter 5.1/5.5 only) If the cluster has only one datastore as recommended, click Advanced
Options, add an Option named das.ignoreInsufficientHbDatastore with Value of true, and click
OK.

6. If the cluster does not use vSphere HA, disable it on the Cluster Features page. Otherwise, proceed to
the next step.

7. Configure vSphere DRS.

a. Select vSphere DRS > Virtual Machine Options.

b. Change the Automation Level setting of all Controller VMs to Disabled.
 

 

c. Select vSphere DRS > Power Management.
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d. Confirm that Off is selected as the default power management for the cluster.

8. If the cluster does not use vSphere DRS, disable it on the Cluster Features page. Otherwise, proceed
to the next step.

9. Click OK to close the cluster settings window.

vSphere Cluster Settings

Certain vSphere cluster settings are required for Nutanix clusters.

vSphere HA and DRS must be configured even if the customer does not plan to use the feature. The
settings will be preserved within the vSphere cluster configuration, so if the customer later decides to
enable the feature, it will be pre-configured based on Nutanix best practices.

vSphere HA Settings

Enable host monitoring

Enable admission control and use the percentage-based policy with a value based on the
number of nodes in the cluster.

Set the VM Restart Priority of all Controller VMs to Disabled.

Set the Host Isolation Response of all Controller VMs to Leave Powered On.

Disable VM Monitoring for all Controller VMs.

Enable Datastore Heartbeating by clicking Select only from my preferred datastores and
choosing the Nutanix NFS datastore.

If the cluster has only one datastore, add an advanced option
das.ignoreInsufficientHbDatastore=true.

vSphere DRS Settings

Disable automation on all Controller VMs.

Leave power management disabled (set to Off).

Other Cluster Settings

Store VM swapfiles in the same directory as the virtual machine.

(Mixed processor class clusters only) Enable EVC for the lowest processor class in the cluster.

(NX-2000 only) Store host cache on the local datastore.



vCenter Configuration | vSphere Administration Guide |  NOS  | 12

Failover Reservation Percentages

Hosts (N+1) Percentage Hosts (N+2) Percentage Hosts (N+3) Percentage Hosts (N+4) Percentage

1 N/A 9 23% 17 18% 25 16%

2 N/A 10 20% 18 17% 26 15%

3 33% 11 18% 19 16% 27 15%

4 25% 12 17% 20 15% 28 14%

5 20% 13 15% 21 14% 29 14%

6 18% 14 14% 22 14% 30 13%

7 15% 15 13% 23 13% 31 13%

8 13% 16 13% 24 13% 32 13%
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2

VM Management

VM Migration

You can live migrate a VM to an ESXi host in a Nutanix cluster. Usually this is done in the following cases:

• Migrate VMs from existing storage platform to Nutanix.
• Keep VMs running during disruptive upgrade or other downtime of Nutanix cluster.

In migrating VMs between vSphere clusters, the source host and NFS datastore are the ones presently
running the VM. The target host and NFS datastore are the ones where the VM will run after migration. The
target ESXi host and datastore must be part of a Nutanix cluster.

To accomplish this migration, you have to mount the NFS datastores from the target on the source. After
the migration is complete, you should unmount the datastores and block access.

Migrating a VM to Another Cluster

Before you begin: Both the source host and the target host must be in the same vSphere cluster. Allow
NFS access to NDFS by adding the source host and target host to a whitelist, as described in Configuring
a Filesystem Whitelist in the Web Console Guide.

To migrate a VM back to the source from the target, perform this same procedure with the target as the
new source and the source as the new target.

1. Sign in to the Nutanix web console.

2. Log on to vCenter with the vSphere client.

3. Mount the target NFS datastore on the source host and on the target host.
You can mount NFS datastores in the vSphere client by clicking Add Storage on the Configuration >
Storage screen for a host.
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Note:  Due to a limitation with VMware vSphere, a temporary name and the IP address of a
controller VM must be used to mount the target NFS datastore on both the source host and the
target host for this procedure.

Parameter Value

Server IP address of the Controller VM on the target ESXi host

Folder Name of the container that has the target NFS datastore (typically /
nfs-ctr)

Datastore Name A temporary name for the NFS datastore (e.g., Temp-NTNX-NFS)

a. Select the source host and go to Configuration > Storage.

b. Click Add Storage and mount the target NFS datastore.

c. Select the target host and go to Configuration > Storage.

d. Click Add Storage and mount the target NFS datastore.

4. Change the VM datastore and host for each VM that you want to live migrate to the target.

Note:  This step (creating a temporary datastore) assume you are doing a live migration. If you
are doing a cold migration, you can change both the host and datastore at the same time (see
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the following step). Therefore, you can skip this step in a cold migration because a temporary
datastore is not needed.

a. Right-click the VM and select Migrate.

b. Select Change datastore and click Next.

c. Select the temporary datastore and click Next then Finish.
The VM storage is moved to the temporary datastore on the target host.

d. Right-click the VM and select Migrate.

e. Select Change host and click Next.

f. Select the target host and click Next.

g. Ensure that High priority is selected and click Next then Finish.
The VM keeps running as it moves to the target host.

h. Right-click the VM and select Migrate.

i. Select Change datastore and click Next.

j. Select the target datastore and click Next then Finish.
The VM storage is moved to the target datastore on the target host.

5. If you are not doing a live migration (and did not do the previous step), perform a cold migration.

a. Power off the VMs to migrate and repeat the following steps for each VM.

b. Right click the powered off VM.

c. Select "Migrate..."

d. Select "Change both host and datastore" and then click Next.

e. Select the destination host and then click Next.

f. Select the resource pool and then click Next.

g. Select the destination datastore and then click Next.

h. Review the summary and then click Finish.

i. Power on the VM.

6. Unmount the datastores in the vSphere client.

Warning:  Do not unmount the NFS datastore with the IP address 192.168.5.2.

a. Select the source host and go to Configuration > Storage

b. Right click the temporary datastore and select Unmount.

c. Select the target host and go to Configuration > Storage

d. Right click the temporary datastore and select Unmount.
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What to do next: NDFS is not intended to be used as a general use NFS server. Once the migration is
complete, disable NFS access by removing the source host and target host from the whitelist, as described
in Configuring a Filesystem Whitelist.

vStorage APIs for Array Integration

To improve the vSphere cloning process, Nutanix provides a vStorage APIs for Array Integration (VAAI)
plugin. This plugin is installed by default during the Nutanix factory process.

Without the Nutanix VAAI plugin, the process of creating a full clone takes a significant amount of time
because all the data that comprises a VM is duplicated. This duplication also results in an increase in
storage consumption.

The Nutanix VAAI plugin efficiently makes full clones without reserving space for the clone. Read requests
for blocks that are shared between parent and clone are sent to the original vDisk that was created for the
parent VM. As the clone VM writes new blocks, the Nutanix file system allocates storage for those blocks.
This data management occurs completely at the storage layer, so the ESXi host sees a single file with the
full capacity that was allocated when the clone was created.

Cloning a VM

 

 

1. Log on to vCenter with the vSphere client.

2. Right-click the VM and select Clone.

3. Follow the wizard to enter a name for the clone, choose a cluster, and choose a host.

4. Select the datastore that contains source VM and click Next.

Note:  If you choose a datastore other than the one that contains the source VM, the clone
operation will use the VMware implementation and not the Nutanix VAAI plugin.

5. If desired, set the guest customization parameters. Otherwise, proceed to the next step.

6. Click Finish.
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Uninstalling the VAAI Plugin

Because the VAAI plugin is in the process of certification, the security level is set to allow community-
supported plugins. Organizations with strict security policies may need to uninstall the plugin if it was
installed during setup.

Perform this procedure on each ESXi host in the Nutanix cluster.

1. Log on to the ESXi host with SSH.

2. Uninstall the plugin.

root@esx# esxcli software vib remove --vibname nfs-vaai-plugin

This command should return the following message:
Message: The update completed successfully, but the system needs to be rebooted for the
 changes to be effective.

3. Disallow community-supported plugins.

root@esx# esxcli software acceptance set --level=PartnerSupported

4. Restart the node by following Restarting a Node on page 22.

Migrating vDisks to NFS

The Nutanix Virtual Computing Platform supports three types of storage for vDisks: VMFS, RDM, and NFS.
Nutanix recommends NFS for most situations. You can migrate VMFS and RDM vDisks to NFS.

Before migration, you must have an NFS datastore. You can determine if a datastore is NFS in
the vSphere client. NFS datastores have Server and Folder properties (for example, Server:
192.168.5.2, Folder: /ctr-ha). Datastore properties are shown in Datastores and Datastore Clusters >
Configuration > Datastore Details in the vSphere client.

 

 

To create a datastore, use the Nutanix web console or the datastore create nCLI command.

The type of vDisk determines the mechanism that you use to migrate it to NFS.

• To migrate VMFS vDisks to NFS, use storage vMotion by following Migrating VMFS vDisks to NFS on
page 18.

This operation takes significant time for each vDisk because the data is physically copied.
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• To migrate RDM vDisks to NFS, use the Nutanix migrate2nfs.py utility by following Migrating RDM
vDisks to NFS on page 18.

This operation takes only a small amount of time for each vDisk because data is not physically copied.

Migrating VMFS vDisks to NFS

Before you begin: Log on to vCenter with the vSphere client.

Perform this procedure for each VM that is supported by a VMFS vDisk. The migration takes a significant
amount of time.

1. Right-click the VM and select Migrate.

2. Click Change datastore and click Next.

3. Select the NFS datastore and click Next.
 

 

4. Click Finish.
The vDisk begins migration. When the migration is complete, the vSphere client Tasks & Events tab
shows that the Relocate virtual machine task is completed.

Migrating RDM vDisks to NFS

The migrate2nfs.py utility is available on Controller VMs to rapidly migrate RDM vDisks to an NFS
datastore. This utility has the following restrictions:

• Guest VMs can be migrated only to an NFS datastore that is on the same container where the RDM
vDisk resides. For example, if the vDisk is in the ctr-ha container, the NFS datastore must be on the
ctr-ha container.

• ESXi has a maximum NFS vDisk size of in NFS is 2 TB - 512 B. To migrate vDisks to NFS, the
partitions must be smaller than this maximum. If you have any vDisks that exceed this maximum, you
have to reduce the size in the guest VM before using this mechanism to migrate it. How to reduce the
size is different for every operating system.

The following parameters are optional or are not always required.

--truncate_large_rdm_vmdks
Specify this switch to migrate vDisks larger than the maximum after reducing the size of the partition
in the guest operating system.

--filter=pattern
Specify a pattern with the --batch  switch to restrict the vDisks based on the name, for example
Win7* . If you do not specify the --filter parameter in batch mode, all RDM vDisks are included.
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--server=esxi_ip_addr and --svm_ip=cvm_ip_addr
Specify the ESXi host and Controller VM IP addresses if you are running the migrate2nfs.py script
on a Controller VM different from the node where the vDisk to migrate resides.

1. Log on to any Controller VM in the cluster with SSH.

2. Specify the logon credentials as environment variables.

nutanix@cvm$ export VI_USERNAME=root
nutanix@cvm$ export VI_PASSWORD=esxi_root_password

3. If you want to migrate one vDisk at a time, specify the VMX file.

nutanix@cvm$ migrate2nfs.py /vmfs/volumes/datastore_name/vm_dir/vm_name.vmx nfs_datastore

• Replace datastore_name with the name of the datastore, for example NTNX_datastore.
• Replace vm_dir/vm_name with the directory and the name of the VMX file.

4. If you want to migrate multiple vDisks at the same time, run migrate2nfs.py in batch mode.
Perform these steps for each ESXi host in the cluster.

a. List the VMs that will be migrated.

nutanix@cvm$ migrate2nfs.py --list_only --batch --server=esxi_ip_addr --
svm_ip=cvm_ip_addrsource_datastorenfs_datastore

• Replace source_datastore with the name of the datastore that contains the VM .vmx file, for
example NTNX_datastore.

• Replace nfs_datastore with the name of the NFS datastore, for example NTNX-NFS.

b. Migrate the VMs.

nutanix@cvm$ migrate2nfs.py --batch --server=esxi_ip_addr --
svm_ip=cvm_ip_addrsource_datastorenfs_datastore

Each VM takes approximately five minutes to migrate.

What to do next: Migrating the vDisks changes the device signature, which causes certain operating
systems to mark the disk as offline. How to mark the disk online is different for every operating system.
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3

Node Management

Shutting Down a Node in a Cluster (vSphere)

Before you begin: Shut down guest VMs, including vCenter and the vMA, that are running on the node, or
move them to other nodes in the cluster.

Caution:  You can only shut down one node for each cluster. If the cluster would have more than
one node shut down, shut down the entire cluster.

1. Log on to vCenter (or to the ESXi host if vCenter is not available) with the vSphere client.

2. Right-click the host and select Enter Maintenance Mode.

3. Right-click the Controller VM and select Power > Shut Down Guest.

Note:  Do not Power Off or Reset the Controller VM. Shutting down the Controller VM as a
guest ensures that the cluster is aware that Controller VM is unavailable.

4. In the Confirm Maintenance Mode dialog box, uncheck Move powered off and suspended virtual
machines to other hosts in the cluster and click Yes.
The host is placed in maintenance mode, which prevents VMs from running on the host.

5. Right-click the node and select Shut Down.
Wait until vCenter shows that the host is not responding, which may take several minutes.
 

 

If you are logged on to the ESXi host rather than to vCenter, the vSphere client will disconnect when the
host shuts down.
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Starting a Node in a Cluster (vSphere)

1. If the node is turned off, turn it on by pressing the power button on the front. Otherwise, proceed to the
next step.

2. Log on to vCenter (or to the node if vCenter is not running) with the vSphere client.

3. Right-click the ESXi host and select Exit Maintenance Mode.

4. Right-click the Controller VM and select Power > Power on.
Wait approximately 5 minutes for all services to start on the Controller VM.

5. Log on to another Controller VM in the cluster with SSH.

6. Confirm that cluster services are running on the Controller VM.

nutanix@cvm$ ncli cluster status | grep -A 15 cvm_ip_addr

Output similar to the following is displayed.
    Name                      : 10.1.56.197
    Status                    : Up
    Zeus                      : up
    Scavenger                 : up
    ConnectionSplicer         : up
    Hyperint                  : up
    Medusa                    : up
    Pithos                    : up
    Stargate                  : up
    Cerebro                   : up
    Chronos                   : up
    Curator                   : up
    Prism                     : up
    AlertManager              : up
    StatsAggregator           : up
    SysStatCollector          : up

Every service listed should be up.

7. Right-click the ESXi host in the vSphere client and select Rescan for Datastores. Confirm that all
Nutanix datastores are available.

8. Verify that all services are up on all Controller VMs.

nutanix@cvm$ cluster status

If the cluster is running properly, output similar to the following is displayed for each node in the cluster:

CVM: 172.16.8.167 Up, ZeusLeader
             Zeus   UP   [3148, 3161, 3162, 3163, 3170, 3180]
        Scavenger   UP   [3333, 3345, 3346, 11997]
 ConnectionSplicer  UP   [3379, 3392]
         Hyperint   UP   [3394, 3407, 3408, 3429, 3440, 3447]
           Medusa   UP   [3488, 3501, 3502, 3523, 3569]
 DynamicRingChanger  UP  [4592, 4609, 4610, 4640]
           Pithos   UP   [4613, 4625, 4626, 4678]
         Stargate   UP   [4628, 4647, 4648, 4709]
          Cerebro   UP   [4890, 4903, 4904, 4979]
          Chronos   UP   [4906, 4918, 4919, 4968]
          Curator   UP   [4922, 4934, 4935, 5064]
            Prism   UP   [4939, 4951, 4952, 4978]
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     AlertManager   UP   [4954, 4966, 4967, 5022]
  StatsAggregator   UP   [5017, 5039, 5040, 5091]
 SysStatCollector   UP   [5046, 5061, 5062, 5098]

Restarting a Node

Before you begin:  Shut down guest VMs, including vCenter, that are running on the node, or move them
to other nodes in the cluster.

1. Log on to vCenter (or to the ESXi host if the node is running the vCenter VM) with the vSphere client.

2. Right-click the host and select Enter Maintenance Mode.
In the Confirm Maintenance Mode dialog box, uncheck Move powered off and suspended virtual
machines to other hosts in the cluster and click Yes.
The host is placed in maintenance mode, which prevents VMs from running on the host.

3. Right-click the Controller VM and select Power > Shut Down Guest.

Note:  Do not Power Off or Reset the Controller VM. Shutting down the Controller VM as a
guest ensures that the cluster is aware that Controller VM is unavailable.

4. Right-click the node and select Reboot.
Wait until vCenter shows that the host is not responding and then is responding again, which may take
several minutes.

If you are logged on to the ESXi host rather than to vCenter, the vSphere client will disconnect when the
host shuts down.

5. Right-click the ESXi host and select Exit Maintenance Mode.

6. Right-click the Controller VM and select Power > Power on.
Wait approximately 5 minutes for all services to start on the Controller VM.

7. Log on to the Controller VM with SSH.

8. Confirm that cluster services are running on the Controller VM.

nutanix@cvm$ ncli cluster status | grep -A 15 cvm_ip_addr

Output similar to the following is displayed.
    Name                      : 10.1.56.197
    Status                    : Up
    Zeus                      : up
    Scavenger                 : up
    ConnectionSplicer         : up
    Hyperint                  : up
    Medusa                    : up
    Pithos                    : up
    Stargate                  : up
    Cerebro                   : up
    Chronos                   : up
    Curator                   : up
    Prism                     : up
    AlertManager              : up
    StatsAggregator           : up
    SysStatCollector          : up
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Every service listed should be up.

9. Right-click the ESXi host in the vSphere client and select Rescan for Datastores. Confirm that all
Nutanix datastores are available.

Patching ESXi Hosts in a Cluster

Use the following procedure when you need to patch the ESXi hosts in a cluster without service
interruption.

Perform the following steps for each ESXi host in the cluster.

1. Shut down the node by following Shutting Down a Node in a Cluster (vSphere) on page 20, including
moving guest VMs to a running node in the cluster.

2. Patch the ESXi host using your normal procedures with VMware Update Manager or otherwise.

3. Start the node by following Starting a Node in a Cluster (vSphere) on page 21.
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4

vSphere Upgrade
Nutanix nodes may be upgraded to later versions of vSphere after installation. Systems running NOS have
specific requirements for upgrading vSphere.

These procedures contain the steps that are unique to systems running NOS. Refer to the vSphere
Upgrade Guide at https://www.vmware.com/support/pubs/vsphere-esxi-vcenter-server-pubs.html for
information on standard vSphere procedures.

Because vSphere hosts with different versions can coexist in a single Nutanix cluster, upgrading vSphere
does not require cluster downtime.

• If you want to avoid cluster interruption, you must complete upgrading a host and ensure that it is
running before upgrading any other host. When two hosts in a cluster are down at the same time, some
data will be unavailable.

• If you want to minimize the duration of the upgrade activities and cluster downtime is acceptable, you
can stop the cluster and upgrade all hosts at the same time.

Warning:  The Nutanix cluster can only tolerate a single node down at any time.

• Never shut down or restart multiple Controller VMs or hosts simultaneously.
• Always run the cluster status command to verify that all Controller VMs are up before

performing a Controller VM or host shutdown or restart.

Upgrading vSphere on a Host

Before you begin: 

• Upgrade vCenter to the target vSphere version or create a new vCenter server with the target version.
• If you are upgrading all nodes in the cluster at once, shut down all guest VMs and stop the cluster with

the cluster stop command.
• If you are upgrading the nodes while keeping the cluster running, ensure that all nodes are up by

logging on to a Controller VM and running the cluster status command. If any nodes are not running,
start them before proceeding with the upgrade. Shut down all guest VMs on the node or migrate them to
other nodes in the cluster.

• Disable email alerts in the web console under Email Alert Services or with the nCLI command alerts
update-alert-config enable=false .

Perform these steps once for each ESXi host in the cluster.

1. Prepare for the upgrade by following Preparing to Upgrade vSphere on a Host on page 25.

2. Upgrade the host by following the product-specific steps.

→ Upgrading vSphere on a Host (NX-1000/3050/6000 with 16 GB DOM) on page 25
→ Upgrading vSphere on a Host (NX-1000/3050/6000 with 64 GB DOM) on page 27
→ Upgrading vSphere on a Host (NX-2000) on page 28
→ Upgrading vSphere on a Host (NX-3000) on page 29
→ Upgrading vSphere on a Host (NX-7000) on page 31

https://www.vmware.com/support/pubs/vsphere-esxi-vcenter-server-pubs.html
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3. Configure the upgraded host by following Completing vSphere Upgrade on page 33.

Preparing to Upgrade vSphere on a Host

1. Ensure that the active adapters are up on the ESXi hosts. If an active adapter has failed over to a
standby adapter, the ESXi upgrade will fail.

2. If the cluster has iSCSI LUNs, set the ESXi hosts to avoid all paths down.

To check if the cluster has iSCSI LUNs, log on to an ESXi host as root and run esxcfg-scsidevs -m . If
any output other than the node local datastore is returned, log on to each ESXi host in the cluster and
enable the FailVolumeOpenIfAPD option.

root@esx# esxcfg-advcfg -s 1 /VMFS3/FailVolumeOpenIfAPD

This setting prevents the ESXi hosts from entering the all paths down (APD) state, which causes VMs
to stop responding and requires restarting ESXi hosts. For more information, see VMware KB article
1016626 at http://kb.vmware.com.

If the option is enabled, the host will display the following status.
Value of FailVolumeOpenIfAPD is 1

3. Open /etc/vmware/config and ensure that required parameters are set in the ESXi configuration.
This file should contain the following parameters:

libdir = "/usr/lib/vmware" 
authd.proxy.vim = "vmware-hostd:hostd-vmdb" 
authd.proxy.nfc = "vmware-hostd:ha-nfc" 
authd.proxy.nfcssl = "vmware-hostd:ha-nfcssl" 
authd.proxy.vpxa-nfcssl = "vmware-vpxa:vpxa-nfcssl" 
authd.proxy.vpxa-nfc = "vmware-vpxa:vpxa-nfc" 
authd.fullpath = "/sbin/authd" 
authd.soapServer = "TRUE" 
vmauthd.server.alwaysProxy = "TRUE"

If any of these lines are not present in /etc/vmware/config, add them.

4. Log on to the Controller VM with SSH.

5. If the cluster is running, place the node in maintenance mode for NOS.

nutanix@cvm$ ncli host edit id=host_id enable-maintenance-mode="true"

Replace host_id with the ID of the host .

6. Copy the offline bundle to a Nutanix NFS container mounted by all the ESXi hosts in the cluster.

Upgrading vSphere on a Host (NX-1000/3050/6000 with 16 GB DOM)

Before you begin: 

• Prepare the host for upgrade by following Preparing to Upgrade vSphere on a Host on page 25.
• Confirm the size of the DOM with the following command:

root@esx# esxcfg-scsidevs -c -d $(basename $(ls /dev/disks/t10* | head -1))

If the Size is not approximately 16 GB, do not use this procedure. Instead, follow Upgrading vSphere on
a Host (NX-1000/3050/6000 with 64 GB DOM) on page 27.

http://kb.vmware.com
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• Back up to a remote location the following files and directories on the vSphere host:

/etc/rc.local (ESXi 5.0)
/etc/rc.local.d/local.sh (ESXi 5.1 and later)
/bootbank/Nutanix
/bootbank/svmboot.tar.gz

• Download the local NFS server VIB from http://download.nutanix.com/releases/congo-3.5/
pynfs_congo-3.5.vib to a temporary location outside the cluster. After the ESXi upgrade you need to
copy this file to the host.

1. Configure the local NFS server.
Perform these steps once for each host in the cluster.

a. Log on to the ESXi host with SSH.

b. Ensure that the bootbanks are configured correctly.

root@esx# ls -ld /altbootbank/Nutanix /altbootbank/svmboot.tar.gz

If /altbootbank/Nutanix or /altbootbank/svmboot.tar.gz exist, move it to /bootbank. Otherwise,
proceed to the next step.

root@esx# mv /altbootbank/Nutanix /bootbank
root@esx# mv /altbootbank/svmboot.tar.gz /bootbank

c. Remove the pynfs VIB.

root@esx# esxcli software vib remove -n pynfs -f

d. Save the host configuration.

root@esx# /sbin/auto-backup.sh

2. Log on to any Controller VM in the cluster and upgrade all hosts.

Warning:

• Do not upgrade by attaching the ISO to the host.
• Do not patch or run another upgrade on the ESXi host until the entire upgrade procedure is

completed. Multiple upgrades performed at this point in the procedure could cause Nutanix-
specific data to be deleted.

nutanix@cvm$ for i in `hostips`; do echo $i && ssh root@$i "esxcli software vib \
 install -d /vmfs/volumes/datastore_name/offline_bundle_name"; done

• Replace datastore_name with the path to the datastore where you uploaded the offline bundle.
• Replace offline_bundle_name with the name of the offline bundle (for example, VMware-

ESXi-5.5.0-1331820-depot.zip).

Note:  If the ESXi hosts have custom VIBs installed, reinstall the VIBs after installing the newer
ESXi version and restarting the hosts.

Alternatively, you can upgrade the hosts with VUM.

If you upgrade using VUM and the host is part of an HA cluster, upgrade may fail with this message .

Software or system configuration on host host_name is incompatible. Check scan results
 for details.

For instructions on resolving this known issue with ESXi, see VMware KB article 2034945 at http://
kb.vmware.com.

3. Configure the host and start the Controller VM.

http://download.nutanix.com/releases/congo-3.5/pynfs_congo-3.5.vib
http://download.nutanix.com/releases/congo-3.5/pynfs_congo-3.5.vib
http://kb.vmware.com
http://kb.vmware.com
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Perform these steps once for each host in the cluster. Ensure that the Controller VM on the host is
running before restarting the next host.

a. Log on to vCenter with the vSphere client, right-click the ESXi host, and select Reboot.

b. Log on to the ESXi host with SSH.

c. Check the bootbanks.

root@esx# ls -ld /bootbank/Nutanix /altbootbank/Nutanix
root@esx# ls -ld /bootbank/svmboot.tar.gz /altbootbank/svmboot.tar.gz

If these files or directories do not exist, restore the backup that you made before the upgrade to /
bootbank.

d. Copy the pynfs VIB file from your temporary download location to /var/tmp on the host as
pynfs.vib.

e. Install the plugin.

root@esx# esxcli software vib install -v /var/tmp/pynfs.vib -f

The installation command should return the following message:
Message: Operation finished successfully. 

f. Save the host configuration.

root@esx# /sbin/auto-backup.sh

g. In vCenter, right-click the ESXi host and select Reboot. After the host starts, right-click the Controller
VM and select Power > Power on.
Wait until the Controller VM has finished starting before proceeding to the next host.

What to do next: Complete the upgrade by following Completing vSphere Upgrade on page 33.

Upgrading vSphere on a Host (NX-1000/3050/6000 with 64 GB DOM)

Before you begin: 

• Prepare the host for upgrade by following Preparing to Upgrade vSphere on a Host on page 25.
• Confirm the size of the DOM with the following command:

root@esx# esxcfg-scsidevs -c -d $(basename $(ls /dev/disks/t10* | head -1))

If the Size is not approximately 64 GB, do not use this procedure. Instead, follow Upgrading vSphere on
a Host (NX-1000/3050/6000 with 16 GB DOM) on page 25.

• Back up to a remote location the following files and directories on the vSphere host:

/etc/rc.local (ESXi 5.0)
/etc/rc.local.d/local.sh (ESXi 5.1 and later)

1. Log on to any Controller VM in the cluster and upgrade all hosts.

Warning:

• Do not upgrade by attaching the ISO to the host.
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• Do not patch or run another upgrade on the ESXi host until the entire upgrade procedure is
completed. Multiple upgrades performed at this point in the procedure could cause Nutanix-
specific data to be deleted.

nutanix@cvm$ for i in `hostips`; do echo $i && ssh root@$i "esxcli software vib \
 install -d /vmfs/volumes/datastore_name/offline_bundle_name"; done

• Replace datastore_name with the path to the datastore where you uploaded the offline bundle.
• Replace offline_bundle_name with the name of the offline bundle (for example, VMware-

ESXi-5.5.0-1331820-depot.zip).

Note:  If the ESXi hosts have custom VIBs installed, reinstall the VIBs after installing the newer
ESXi version and restarting the hosts.

Alternatively, you can upgrade the hosts with VUM.

If you upgrade using VUM and the host is part of an HA cluster, upgrade may fail with this message .

Software or system configuration on host host_name is incompatible. Check scan results
 for details.

For instructions on resolving this known issue with ESXi, see VMware KB article 2034945 at http://
kb.vmware.com.

2. Restart each host.
If you are upgrading while the cluster is running, restart one host at a time. Wait until the Controller
VM has started on the host before proceeding to the next host. If the Controller VM does not start
automatically with the host, power on the Controller VM once the host is back online. If the Controller
VM does not start, see step 1 on page 33 for a possible resolution.

What to do next: Complete the upgrade by following Completing vSphere Upgrade on page 33.

Upgrading vSphere on a Host (NX-2000)

Before you begin: 

• Prepare the host for upgrade by following Preparing to Upgrade vSphere on a Host on page 25.
• For upgrade to ESXi 5.1, create a customized ESXi installation image by following Creating a

customized ESXi Installer ISO or Offline Bundle (NX-2000/ESXi 5.1) on page 36.

For upgrade to later versions, use the standard installation image from VMware.

• Back up to a remote location the following files and directories on the vSphere host:

/etc/rc.local (ESXi 5.0)
/etc/rc.local.d/local.sh (ESXi 5.1 and later)

1. Log on to any Controller VM in the cluster and upgrade all hosts.

Warning:

• You must use the customized image to upgrade NX-2000 systems to ESXi 5.1. For other
products and versions, you can use the standard ESXi image.

• Do not upgrade by attaching the ISO to the host.

http://kb.vmware.com
http://kb.vmware.com
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• Do not patch or run another upgrade on the ESXi host until the entire upgrade procedure is
completed. Multiple upgrades performed at this point in the procedure could cause Nutanix-
specific data to be deleted.

nutanix@cvm$ for i in `hostips`; do echo $i && ssh root@$i "esxcli software vib \
 install -d /vmfs/volumes/datastore_name/offline_bundle_name"; done

• Replace datastore_name with the path to the datastore where you uploaded the offline bundle.
• Replace offline_bundle_name with the name of the offline bundle (for example, VMware-

ESXi-5.5.0-1331820-depot.zip).

Note:  If the ESXi hosts have custom VIBs installed, reinstall the VIBs after installing the newer
ESXi version and restarting the hosts.

Alternatively, you can upgrade the hosts with VUM.

If you upgrade using VUM and the host is part of an HA cluster, upgrade may fail with this message .

Software or system configuration on host host_name is incompatible. Check scan results
 for details.

For instructions on resolving this known issue with ESXi, see VMware KB article 2034945 at http://
kb.vmware.com.

2. Restart each host.
If you are upgrading while the cluster is running, restart one host at a time. Wait until the Controller
VM has started on the host before proceeding to the next host. If the Controller VM does not start
automatically with the host, power on the Controller VM once the host is back online. If the Controller
VM does not start, see step 1 on page 33 for a possible resolution.

What to do next: Complete the upgrade by following Completing vSphere Upgrade on page 33.

Upgrading vSphere on a Host (NX-3000)

Before you begin: 

• Prepare the host for upgrade by following Preparing to Upgrade vSphere on a Host on page 25.
• Back up to a remote location the following files and directories on the vSphere host:

/etc/rc.local (ESXi 5.0)
/etc/rc.local.d/local.sh (ESXi 5.1 and later)
/bootbank/Nutanix
/bootbank/svmboot.tar.gz

• Download the local NFS server VIB from http://download.nutanix.com/releases/congo-3.5/
pynfs_congo-3.5_nx3000.vib to a temporary location outside the cluster. After the ESXi upgrade you
need to copy this file to the host.

• Ensure that Boot > Boot Option #1 in the BIOS is STEC STEC USB 2.0 3300 .
 

 

1. Configure the local NFS server.

http://kb.vmware.com
http://kb.vmware.com
http://download.nutanix.com/releases/congo-3.5/pynfs_congo-3.5_nx3000.vib
http://download.nutanix.com/releases/congo-3.5/pynfs_congo-3.5_nx3000.vib
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Perform these steps once for each host in the cluster.

a. Log on to the ESXi host with SSH.

b. Ensure that the bootbanks are configured correctly.

root@esx# ls -ld /altbootbank/Nutanix /altbootbank/svmboot.tar.gz

If /altbootbank/Nutanix or /altbootbank/svmboot.tar.gz exist, move it to /bootbank. Otherwise,
proceed to the next step.

root@esx# mv /altbootbank/Nutanix /bootbank
root@esx# mv /altbootbank/svmboot.tar.gz /bootbank

c. Remove the pynfs VIB.

root@esx# esxcli software vib remove -n pynfs -f

d. Save the host configuration.

root@esx# /sbin/auto-backup.sh

2. Log on to any Controller VM in the cluster and upgrade all hosts.

Warning:

• Do not upgrade by attaching the ISO to the host.
• Do not patch or run another upgrade on the ESXi host until the entire upgrade procedure is

completed. Multiple upgrades performed at this point in the procedure could cause Nutanix-
specific data to be deleted.

nutanix@cvm$ for i in `hostips`; do echo $i && ssh root@$i "esxcli software vib \
 install -d /vmfs/volumes/datastore_name/offline_bundle_name"; done

• Replace datastore_name with the path to the datastore where you uploaded the offline bundle.
• Replace offline_bundle_name with the name of the offline bundle (for example, VMware-

ESXi-5.5.0-1331820-depot.zip).

Note:  If the ESXi hosts have custom VIBs installed, reinstall the VIBs after installing the newer
ESXi version and restarting the hosts.

Alternatively, you can upgrade the hosts with VUM.

If you upgrade using VUM and the host is part of an HA cluster, upgrade may fail with this message .

Software or system configuration on host host_name is incompatible. Check scan results
 for details.

For instructions on resolving this known issue with ESXi, see VMware KB article 2034945 at http://
kb.vmware.com.

3. Configure the host and start the Controller VM.
Perform these steps once for each host in the cluster. Ensure that the Controller VM on the host is
running before restarting the next host.

a. Log on to vCenter with the vSphere client, right-click the ESXi host, and select Reboot.

b. Log on to the ESXi host with SSH.

c. Recreate the scratch directory.

root@esx# scratch_uuid=$(esxcfg-scsidevs -f | grep "mpx.vmhba[0-9][0-9]:C0:T0:L0:2" \
 | awk '{print $3}') && echo "/vmfs/volumes/$scratch_uuid 1" > \
 /etc/vmware/locker.conf && auto-backup.sh

http://kb.vmware.com
http://kb.vmware.com
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d. Disable the RSTe driver.

root@esx# esxcfg-module -d rste 
root@esx# esxcfg-module -g rste 

The output from the final command should be rste enabled = 0 options = ''.

e. Check the bootbanks.

root@esx# ls -ld /bootbank/Nutanix /altbootbank/Nutanix
root@esx# ls -ld /bootbank/svmboot.tar.gz /altbootbank/svmboot.tar.gz

If these files or directories do not exist, restore the backup that you made before the upgrade to /
bootbank.

f. Copy the pynfs VIB file from your temporary download location to /var/tmp on the host as
pynfs.vib.

g. Install the plugin.

root@esx# esxcli software vib install -v /var/tmp/pynfs.vib -f

The installation command should return the following message:
Message: Operation finished successfully. 

h. Save the host configuration.

root@esx# /sbin/auto-backup.sh

i. In vCenter, right-click the ESXi host and select Reboot. After the host starts, right-click the Controller
VM and select Power > Power on.
Wait until the Controller VM has finished starting before proceeding to the next host.

What to do next: Complete the upgrade by following Completing vSphere Upgrade on page 33.

Upgrading vSphere on a Host (NX-7000)

Before you begin: 

• Prepare the host for upgrade by following Preparing to Upgrade vSphere on a Host on page 25.
• Download the Nvidia VIB for the target version of vSphere from Nvidia.
• Back up to a remote location the following files and directories on the vSphere host:

/etc/rc.local (ESXi 5.0)
/etc/rc.local.d/local.sh (ESXi 5.1 and later)

1. Log on to any Controller VM in the cluster and upgrade all hosts.

Warning:

• Do not upgrade by attaching the ISO to the host.
• Do not patch or run another upgrade on the ESXi host until the entire upgrade procedure is

completed. Multiple upgrades performed at this point in the procedure could cause Nutanix-
specific data to be deleted.

nutanix@cvm$ for i in `hostips`; do echo $i && ssh root@$i "esxcli software vib \
 install -d /vmfs/volumes/datastore_name/offline_bundle_name"; done

• Replace datastore_name with the path to the datastore where you uploaded the offline bundle.
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• Replace offline_bundle_name with the name of the offline bundle (for example, VMware-
ESXi-5.5.0-1331820-depot.zip).

Note:  If the ESXi hosts have custom VIBs installed, reinstall the VIBs after installing the newer
ESXi version and restarting the hosts.

Alternatively, you can upgrade the hosts with VUM.

If you upgrade using VUM and the host is part of an HA cluster, upgrade may fail with this message .

Software or system configuration on host host_name is incompatible. Check scan results
 for details.

For instructions on resolving this known issue with ESXi, see VMware KB article 2034945 at http://
kb.vmware.com.

2. Restart each host.
If you are upgrading while the cluster is running, restart one host at a time. Wait until the Controller
VM has started on the host before proceeding to the next host. If the Controller VM does not start
automatically with the host, power on the Controller VM once the host is back online. If the Controller
VM does not start, see step 1 on page 33 for a possible resolution.

3. Right-click the host and select Enter Maintenance Mode.
In the Confirm Maintenance Mode dialog box, uncheck Move powered off and suspended virtual
machines to other hosts in the cluster and click Yes.
The host is placed in maintenance mode, which prevents VMs from running on the host.

4. Upgrade the Nvidia driver.

a. Copy the new Nvidia VIB to a temporary location such as /var/tmp on the host.

b. Determine the name of the old Nvidia VIB.

root@esx# esxcli software vib list | grep -i nvidia

c. Remove the existing VIB.

root@esx# esxcli software vib remove -n old_nvidia_vib_name

If the removal fails with an error like Output: rm: can't remove '/tardisks/NVIDIA_V.v00': Device
or resource busy, stop the Xorg service with the command /etc/init.d/xorg stop  and attempt to
remove the VIB again.

d. Install the new VIB.

root@esx# esxcli software vib install -v new_nvidia_vib_path -f

e. Save the host configuration.

root@esx# /sbin/auto-backup.sh

5. Right-click the ESXi host and select Reboot.
Wait to proceed until the host has finished starting.

6. Right-click the ESXi host and select Exit Maintenance Mode.

What to do next: Complete the upgrade by following Completing vSphere Upgrade on page 33.

http://kb.vmware.com
http://kb.vmware.com
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Completing vSphere Upgrade

Before you begin: 

• Follow the product-specific upgrade steps.
• If you are upgrading any Nutanix product except the NX-2000 line to ESXi 5.5, download the updated

IXGBE driver from https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-INTEL-
IXGBE-3214&productId=353.

1. If the Controller VM did not start and you are upgrading from vSphere 5.0 to a later version, ensure the
Controller VM is configured correctly.

a. Log on to the ESXi host with SSH.

b. Check for a deprecated parameter in the Controller VM VMX file.

root@esx# grep sched.mem.prealloc /vmfs/volumes/NTNX-local-ds-*/ServiceVM*/*.vmx

If the VMX file contains the sched.mem.prealloc parameter, open the VMX file and remove the
parameter.

Warning:  Because this setting does not exist in ESXi 5.1 and above, the Controller VM will
not start after upgrade if it is present in the VMX file.

c. Right-click the Controller VM and select Remove from Inventory .

d. Select the host and go to Configuration > Storage.

e. Right-click the local datastore and select Browse Datastore.

f. Go to the directory that contains the Controller VM VMX file, right-click the VMX file, and select Add
to Inventory.

g. Right-click the Controller VM and select Power > Power on.

2. Configure the Controller VM.

a. Select the Controller VM and go to the Console tab.

b. If the Virtual Machine Question appears, select I moved it and click OK.
 

 

c. Right-click the Controller VM and select Edit Settings.

d. Go to Resources > Memory, ensure that Reserve all guest memory is selected, and click OK.

https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-INTEL-IXGBE-3214&productId=353
https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-INTEL-IXGBE-3214&productId=353
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3. Configure the vSphere host.

a. Log on to the ESXi host with SSH.

b. Open /etc/rc.local.d/local.sh in a text editor

c. Remove the following lines if they exist.

# Nutanix SVM START
if [ -d /altbootbank/Nutanix -a ! -d /bootbank/nutanix ]; then
  mv /altbootbank/Nutanix /bootbank/
fi
tar -C / -xzf /bootbank/nutanix/pynfs.tar.gz
# Retry 12 times in a minute, if uuid cannot be obtained.
count=1
while [ $count -le 12 ]; do
  uuid=$(localcli system uuid get)
  if [ -z "$uuid" ]; then
    echo "Failed to start nfs server due to nil uuid ($count)" >/pynfs/pynfs.log
    count=$((count+1))
    sleep 5
  else
    nohup sh -c "/pynfs/nfs_server.py -t /bootbank/nutanix/svmboot.tar.gz -e /$uuid >/
dev/null 2>&1" >/dev/null 2>&1 &
    break
  fi
done
# Nutanix SVM END

# Nutanix VM autostart START
(sleep 60; vim-cmd hostsvc/autostartmanager/autostart) &
# Nutanix VM autostart END

d. (NX-2000 only) Add the following lines (after the first line #!/bin/sh  and before the line exit 0  if it is
present).

#added to support multiextent                                         
localcli system module load -m multiextent
#end of adding
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e. Add the following lines (after the first line #!/bin/sh  and before the line exit 0  if it is present) to
configure the Controller VM to start with the host.

MAX_RETRIES=50

# Make sure that the local CVM is started.
vm_id=""
retries=0
while [ "$vm_id" == "" ]; do
  if [ $retries -eq $MAX_RETRIES ]
  then
    echo "Failed to get all VMs on the local host"
    exit 1
  fi
  sleep 5
  vm_id=$(vim-cmd vmsvc/getallvms | grep ServiceVM | awk '{ print $1 }')
  let retries=$retries+1
done

power_state=""
retries=0
while [ "$power_state" == "" ]; do
  if [ $retries -eq $MAX_RETRIES ]
  then
    echo "Failed to power on SVM on the local host"
    exit 0
  fi
  sleep 5
  if [ "$power_state" == "" ]; then
    vim-cmd vmsvc/power.on $vm_id
  fi
  power_state=$(vim-cmd vmsvc/power.getstate $vm_id | grep 'Powered on')
  let retries=$retries+1
done

f. (ESXi 5.5, NX-1000/3000/6000/7000 only) Copy the new IXGBE driver VIB to a temporary location
such as /var/tmp on the host and install the new VIB.

root@esx# esxcli software vib install -n new_ixgbe_vib_path

g. Save the host configuration.

root@esx# /sbin/auto-backup.sh

h. Restart the ESXi host.

root@esx# reboot

Wait to proceed until the host has finished starting.

4. Rejoin the node to the cluster.

a. Log on to a Controller VM in the cluster other than the Controller VM on the host that was just
upgraded.

b. Take the node out of maintenance mode for NOS.

nutanix@cvm$ ncli host edit id=host_id enable-maintenance-mode="false"

Replace host_id with the ID of the host .

c. Confirm that cluster services are running on the Controller VM.

nutanix@cvm$ ncli cluster status | grep CVM:

Every Controller VM listed should be Up.
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5. In vCenter, disable APD for NFS.

a. Select the node and go to Configuration > Software > Advanced settings.

b. Go to Misc and set Misc.APDHandlingEnable to 0.

c. Go to NFS and set NFS.HeartbeatFrequency to 40.

d. Set NFS.HeartbeatTimeout to 30.

e. Click OK.

6. Log on to the ESXi host with SSH.

7. Save the host configuration.

root@esx# /sbin/auto-backup.sh

What to do next: Reenable email alerts in the web console under Email Alert Services or with the nCLI
command alerts update-alert-config enable=true .

Creating a customized ESXi Installer ISO or Offline Bundle (NX-2000/ESXi 5.1)

Upgrading an NX-2000 series system to ESXi 5.1 requires that you create a customized installer ISO
that contains drivers for the Mellanox network interface. You do not need to create an image to upgrade
NX-2000 to ESXi 5.5, nor to upgrade any other Nutanix product. In these cases, use the standard ISO
provided by VMware.

Before you begin: 

• Install the latest version of VMware PowerCLI on your workstation.
• Download the Mellanox 10GbE driver for ESXi from http://download.nutanix.com/sre/mlx4_en-

mlnx-1.6.1.2-471530.zip to a temporary location on your workstation and extract it.

If you need assistance in downloading or using this bundle, please contact Nutanix support.

1. On your workstation, open a VMware PowerCLI session.

2. Add the VMWare software depot.

> Add-EsxSoftwareDepot `
 https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

3. Add the Mellanox 10GbE driver as a software depot.

> Add-EsxSoftwareDepot path/mlx4_en-mlnx-1.6.1.2-offline_bundle-471530.zip

Replace path with the location where you extracted the Mellanox driver.

4. Create a new custom image profile using one of the stock ESXi profiles in the depot as a template.

> New-EsxImageProfile -CloneProfile ESXi-5.1.0-20130402001-standard -Vendor `
 "Nutanix, Inc." -Name "Nutanix-51u1-with-MLX-driver"

If you are unsure which image profile to use as CloneProfile, you can list them.

> Get-EsxImageProfile | Select Name

http://download.nutanix.com/sre/mlx4_en-mlnx-1.6.1.2-471530.zip
http://download.nutanix.com/sre/mlx4_en-mlnx-1.6.1.2-471530.zip
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5. Add the Mellanox driver to the Nutanix custom image profile.

> $mlxdrv = Get-EsxSoftwarePackage -Name net-mlx4-en -Vendor Mellanox
> Add-EsxSoftwarePackage -ImageProfile Nutanix-51u1-with-MLX-driver `
 -SoftwarePackage $mlxdrv

6. Create an ISO or offline bundle and save it to a directory.

→ Offline bundle for use with esxcli

> Export-EsxImageProfile -ImageProfile Nutanix-51u1-with-MLX-driver -ExportToBundle `
 path\Nutanix-51u1-offline-bundle-with-MLX-driver.zip 

→ ISO for use with VUM

> Export-EsxImageProfile -ImageProfile Nutanix-51u1-with-MLX-driver -ExportToISO `
 path\Nutanix-51u1-with-MLX-driver.iso

Replace path with the location where you want to save the ISO.

What to do next: Use the ISO you created when following Upgrading vSphere on a Host (NX-2000) on
page 28.
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Storage Replication Adapter for Site Recovery Manager
Note:  The Nutanix SRA is currently undergoing certification by VMware. For more information on
support and current status of the Nutanix SRA for SRM, please contact Nutanix support.
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