2 Replies Latest reply on Aug 8, 2007 1:38 AM by Svenand

    FYI - Ubuntu 7.04 and VMware Tools

    synapco Enthusiast

      It has been years since I last tried Linux. So I downloaded Ubuntu 7.04 and started searching this site on how to install VMware's Tools. While there is documentation spread through several threads, I ran across a review at www.macintouch.com/reviews/vmware.html that had a very good explanation as to installing Tools. Part of this I am copying for quick review. To review the entire article - cut and paste the link above.

       

      Worked like a charm for me and I hope it can help others.

      ____________________________________

      Linux Support

       

      VMware Fusion supports several major Linux distributions and includes generic support for Linux 2.2, 2.4 and 2.6 kernels. (Linux kernel 2.2.0 was released in January 1999, so VMware should work with pretty much every Linux currently in use.)

      We tested Ubuntu, a popular Linux distribution, downloading both 7.04, the latest version, and 6.06.1, which is a long-term supported version. (Both are considered current.) Fusion's Setup Assistant knows about Ubuntu and configures a VM for either version, but you'll have to manually intervene in a few places to get full integration for version 7, and we discovered that version 6.06.1 doesn't integrate without a lot of work.

      We started Ubuntu 7.04 from an ISO CD image (another nice Fusion feature) and ran the installer. It installed, then restarted... and started from CD again. We explored Fusion's menus and window icons until we discovered that "Use Physical Disk Drive" in the CD icon's popup menu served to "eject" the virtual CD ISO image. This done, the new Ubuntu install started up properly.

      Unlike with Windows, VMware Fusion doesn't automatically install the VMware Tools for Ubuntu 7.04; you must do it yourself. The process is roughly as follows:

      start the Terminal app (Applications menu -> Accessories -> Terminal)

      type tar xvfz /media/cdrom0/VMwareTools-e.x.p-51348.tar.gz

      type cd vmware-tools-distrib

      type sudo ./vmware-install.pl

      accept all defaults

      exit shell, restart Ubuntu

      This is not too difficult, but someone not already familiar with installing software from a Unix command line and with Ubuntu's style of mounting removable media could be completely stymied. On the other hand, even without the VMware Tools installed, Ubuntu runs fine. But the different mouse speed, and having to press a special key sequence to exit the Ubuntu window, is inconvenient.

      We could not install VMware Tools on Ubuntu 6.06.1. The default Ubuntu 6 install does not include development tools, and this meant that VMware Tools couldn't find support libraries it required, so this is a task more suited to Linux experts.

      Once installed, VMware Tools provide drag-and-drop file exchange between Ubuntu and Mac OS X, plus clipboard synchronization and clock synchronization. We dragged Mac Word documents to the Ubuntu desktop and double-clicked: OpenOffice fired right up. If you stick with the latest version of your Linux distribution, we expect things will go fairly smoothly.