1 2 Previous Next 20 Replies Latest reply on Nov 30, 2018 9:38 AM by user_8472

    Disable power-related keyboard shortcuts

    TheParanoidOne Lurker

      Is there currently any way to disable the keyboard shortcuts related to power (Ctrl-E = Power Off, etc)?

       

      I connect to various linux machines and routinely use the keyboard shortcuts Ctrl+R to do reverse command searches on the command line and Ctrl-Z to suspend running applications or undo commands. If the focus is on VMWare rather than inside the VM, these shortcuts will of course restart and suspend the VM, respectively.

       

      This can be very frustrating. I don't understand why these fairly major features are even assigned keyboard shortcuts.

       

      Is there some way to disable them or at the very least, throw up a warning message?

       

      I have searched the forums for this problem and have found threads going back as far as 2003 . Most of them have either been unanswered[2] or answered by telling people to change their behaviour (eg. "Use F5 to reload web pages, not Ctrl-R") which I don't think is a reasonable solution.

       

      Any information would be greatly appreciated.

       

      http://www.vmware.com/community/thread.jspa?messageID=5060#5060

      http://www.vmware.com/community/thread.jspa?messageID=493738��

      http://www.vmware.com/community/thread.jspa?messageID=641031��

        • 1. Re: Disable power-related keyboard shortcuts
          nick.couchman Champion

          I'm guessing if you haven't already found a solution, one probably doesn't exist.  As you state, if you have your cursor and keyboard focused inside the VM, the keys behave as they would inside the guest O/S and don't affect power state, etc., of the VM.  It's only when you remove focus from the VM but still have the Console as your active window that it becomes a problem.

           

          It would be nice if VMware would allow you to adjust the shortcut keys used for these features - maybe you could post a feature request in the feature request forum?

          • 2. Re: Disable power-related keyboard shortcuts
            landtuna Novice

            Gaah!  This one kills me, too.  I can't tell you how many times I've tried to type Ctrl-R in emacs for a reverse search and rebooted the machine.  At least most versions of Linux use a journaling filesystem these days!

            • 3. Re: Disable power-related keyboard shortcuts
              gen000 Lurker

              This gotcha just caught me too.  I'm using VMWare Server, and I was able to work around this be checking the box at:

              Edit -> Preferences -> Input -> Grab keyboard and mouse input on key press.

               

              This seems to redirect any keypresses to the Guest, even when your mouse is over the VMWare Console window.

               

              Maybe it'll work on Workstation too?

              • 4. Re: Disable power-related keyboard shortcuts
                zyx100 Enthusiast

                I agree with you! Simular thing pisses me off for long long time already. Somehow it keeps sending my emails unfinished when I press accidentally some key combinations. Same thing messed up my TV Tuner screen when I work on computer. I would so much appreciate if someone could write a keyboard driver intercepting all ctlr-something and alt-something combinations and such... Any time I was bringing it up people would just laugh at me and think I am some sort of idiot who cannot use keyboard properly. I can understand your frustration.

                • 5. Re: Disable power-related keyboard shortcuts
                  msteiner Novice

                  Given how long this obvious problem is not addressed, the hope that it will get ever fixed is probably nil.  However, this ``feature'' is REALLY annoying and it is a mystery to me why this is not made configurable, something which seems to me a trivial change ...

                  • 6. Re: Disable power-related keyboard shortcuts
                    msteiner Novice

                     

                    This is actuallly more part of the problem than the solution: automatic keyboard/mouse grab when entering a window works only with vmware tools, meaning that if your guest does not have a vmware tools installed (e.g., because they do not exist ...) then the focus still stays with vmware and all the short-cuts are interpreted by vmware.   So, depending on whether you have vmware tools or not in a guest, the behaviour changes drastically ...

                     

                     

                    -michael-

                     

                     

                    • 7. Re: Disable power-related keyboard shortcuts
                      msteiner Novice

                      For linux/gnome, the solution turned out actually pretty easy: Gnome allows you to redefine any keyboard short cut by simply selecting a menu item and hitting some character combination (to define/redefine it) or backspace (to delete it)!

                      • 8. Re: Disable power-related keyboard shortcuts
                        hfofo Lurker

                        same problem. this is immensely annoying. CTRL-Z and others are very widely used shortcuts that has no place in something as time intensive as shutting the machine down. i'll be undoing in photoshop and i see the dreaded "suspending machine" message atleast 3 times per day. GAH.

                         

                         

                        no config file fixes?

                        • 9. Re: Disable power-related keyboard shortcuts
                          mcclmark Lurker

                           

                          Thank you for this tip.

                           

                           

                          It blows me away that such a mature application has such poor shortcut/menu design.  I don't know how many times I've lost work because of ctrl+E shutting things down inadvertently.  Apparently someone at VMware doesn't understand basic GUI design -- Use an ellipsis on the menu text and CONFIRM the user really wants to shut down.

                           

                           

                          Mark

                           

                           

                          • 10. Re: Disable power-related keyboard shortcuts
                            D503 Lurker

                            I keep accidentally using CTRL+S to save the Virtual Machine state... very annoying. How do I disable it?

                            • 11. Re: Disable power-related keyboard shortcuts
                              username1234 Lurker

                              The thread that spans more than 3 years.  And yet Workstation 7.1.3 still has no fix for this issue?

                              • 12. Re: Disable power-related keyboard shortcuts
                                wdeviers Lurker

                                Sooooo...  5 years.  Any fix for this?

                                • 13. Re: Disable power-related keyboard shortcuts
                                  serviznie Novice

                                  Estaré fuera de la oficina hasta el próximo 11 de Enero, con acceso restringido al correo.

                                   

                                  Un saludo

                                  • 14. Re: Disable power-related keyboard shortcuts
                                    deatech Lurker

                                    Found a way to deal with this for VMware 9 on Linux (may work on older Linux versions).

                                     

                                    There is a "shortcuts" file in your ".vmware" directory, it appears this file is created/updated whenever you exit VMware.

                                     

                                    This file contains all of the current keyboard hot key settings for VMware, but they are all commented out with a semi-colon.  If you edit this file to change the values to the empty string for the power off, suspend, and reset hot keys (and anything else that irritates you), remove the semi-colon at the start of each of these lines, and save the file, when you restart VMware, these settings will override the defaults.

                                     

                                    Example line:

                                     

                                       ; (gtk_accel_path "<Actions>/App/vm-power-off" "<Control>e")

                                     

                                    changed to this:

                                     

                                       (gtk_accel_path "<Actions>/App/vm-power-off" "")

                                     

                                     

                                    Attached is a copy of my current shortcuts file which disables power-off, reset, and suspend hotkeys, though it may have other differences from your shortcuts file as well.

                                     

                                     

                                    Things to note:

                                     

                                    All of the irritating power keys have at least two menu entries, so you will need to edit all related entries.

                                     

                                    Changes to this file appear to be preserved when it is updated by VMware, but you might want to keep a backup copy of the changes just in case.

                                     

                                    NOTE TO VMware:  Adding the power-off and reset hot key settings as the default configuration is quite possibly the stupidest idea ever implemented in VMware (and I have been a user since BEFORE the 1.0 release).

                                    1 2 Previous Next