2 Replies Latest reply on Jun 22, 2007 8:10 AM by dmaster

    Problem with Migrating from local datastores to iSCSI datastores

    dmaster Expert
    vExpertVMware Employees

      Hello,

       

      I have an ESX 3.0.1 server with all patches installed.

       

      I have 2 local datastores and 2 iSCSI datastores.

       

      when i migrate a virtual machine from local storage to iSCSI storage, i get a strange error message when migration is at 100% ? The same error i get when i deploy a new template (located at local storage) to an iSCSI datastore. manual copy from the console works fine ? anybody an idea or hint how to fix this problem ? (i am using the virtual iSCSI adapter)

       

      error message i get at 100%:

      relocate virtual machine storage --> invalid configuration for device '0'

       

      when i try to migrate the same virtual machine for a second time from local datastorage to iSCSI datastore i get the following error at 100%

       

      relocate virtual machine storage --> The specified key, name or identiefier already exists.

        • 1. Re: Problem with Migrating from local datastores to iSCSI datastores
          Paul Lalonde Master

          Does the virtual machine or template have any dependencies on local ISO files or floppy disk images?  Can you verify that the virtual floppy and CD-ROM are mapped to Client Device prior to cloning?

           

          If all else fails, "remove" the VM from inventory and try to re-add it.  If that fails, delete the .vmx and re-create the virtual machine using existing vmdk disk and try the clone again.

           

          Paul

          • 2. Re: Problem with Migrating from local datastores to iSCSI datastores
            dmaster Expert
            VMware EmployeesvExpert

            have changed floppy and cdrom to client device

             

            it's looks like i've got now a bit further but another error pops in..

             

            the virtualcenter server is unable to decrypte passwords stored in the customization specification

             

            is this a familiar error for you ?

             

            i will try to another deploy without the customization specification file...

             

            i post the results..

             

            first problem solved.. you are right about changing floppy and cdrom to client device.. thnxx for the tip..

             

            I also found a workaround about the encrypted password error message.. but i am stil interested how to use the encrypted passwords .. i will start a new topic for that..

             

            Re: Unable to decrypt passwords in customization spec

            Posted: 18-mei-2007 18:20    in response to: RobMokkink       Reply 

             

             

            I didn't update my post.

             

            The workaround i use is to export the customization template:

             

            where you can change Password01 to your needs.

             

            This error comes up random. On some sites it works oke and some it don't.

             

            Message was edited by:

                    dmaster