1 2 3 4 5 Previous Next 74 Replies Latest reply on Jun 23, 2012 12:42 AM by Cantoris Go to original post
      • 30. Re: Vista "Unidentified Network" Issue
        CiscoKid Hot Shot

        Wow WesleyWex, you may have discovered a huge security breach with VMware's Workstation.  VMware...you may want to revisit this one.  Anyone else confirm the same behavior?

        • 31. Re: Vista "Unidentified Network" Issue
          Zenrin Novice

          I believe that I have fixed this finally. It's been so irritating. What I did was I changed both interfaces to use dhcp under Vista. I then modified the vmnetdhcp.conf file in the \Users\All Users\VMware directory to point the host interface default route to the .254 address (default dhcp server address). This forces windows to go into Local Only mode as that IP doesn't route anywhere. Other things I did that may have helped before this worked was I changed the domain-name from local to vmnetX.internal. You may be able to accomplish the same thing by using .254 for the gateway address instead of modifying DHCP, but I haven't tried that.

           

          My config file is attached for reference.

           

          Message was edited by: Zenrin  - Removed config file text and attached it instead as it was reformatted.

          • 32. Re: Vista "Unidentified Network" Issue
            WesleyWex Novice

             

            I was hoping this resolved my issue but I guess this will only work if SP1 is not installed.

             

             

            I've followed it, tried 10.10.10.254, 10.10.10.200 and 10.10.10.2 (my network is 10.10.10.0 as you may notice... hehe), but nothing worked to un-unidentify my VMnet8... I guess I'll have to live with disabling all vm interfaces and access the VM by the forwarded ports...

             

             

            • 33. Re: Vista "Unidentified Network" Issue
              Zenrin Novice

              Non-SP1 worked for me by setting the default gateway address to the same as the interface address as described earlier in this thread.  The bottom line appears that the network has to appear to Vista as Local only, or at least non-internet accessible.  I only have IPV4, File and Printer Sharing, and Client for Microsoft networks enabled for these adapters.  I've turned off VMware Bridge, IPv^ and Link-Layer Topology Discovery options.  I also unchecked the Register this connections... in the DNS tab of advanced options.

              • 34. Re: Vista "Unidentified Network" Issue
                WesleyWex Novice

                 

                I'm not a network expert, just a developer. I wonder what is making vista tag the network as unidentified if it behaves exactly like a normal network (with DHCP and Gateway working) if the previous version worked well...

                 

                 

                • 35. Re: Vista "Unidentified Network" Issue
                  simdoc Novice

                  I opened a support incident on this case with VMWare for Vista with SP1. They basically acted as if they were totally unaware of this issue (even the issues with pre-SP1---don't they try to use their own product and read their own communities?)!!!!

                   

                  They basically told us that they could do nothing to get around this issue. They want US (not them) to check with Microsoft to see if there is a way to get the pre-SP1 behavior in post-SP1. I thought this was their product. Why should I waste my time on fixing their problems? Haven't we already wasted enough of our time.

                   

                   

                  I think that VMWare needs to stop stating that VMWare Workstation 6.0 is Vista compatible with this problem. It is not very useful in this state as it imposes far too many network restrictions.

                   

                   

                  • 36. Re: Vista "Unidentified Network" Issue
                    WesleyWex Novice

                     

                    This is just ridiculous... I've called Microsoft support a few weeks ago about this and they said to me that they could not help me with this issue because they cannot reproduce the scenario there, of course, they can only solve problems if they see what's going on there too.

                     

                     

                    VMware should contact Microsoft and ask what causes SP1 to tag a network unidintified, and then solve it.

                     

                     

                    If we could solve this ourselves we would be hacking VMware's code... hehe

                     

                     

                    • 37. Re: Vista "Unidentified Network" Issue
                      richv Novice

                      I just love being stuck between two software companies like this and no one seems to want to resolve the actual problem!  VMWare...   Talk to Microsoft!  Microsoft, talk to VMWare!

                      • 38. Re: Vista "Unidentified Network" Issue
                        richv Novice

                        Just submitted another support request for this...  Anyone else want to submit a support request!  Maybe if we make enough noise, they will hear that this is an issue and we can move forward!

                        • 39. Re: Vista "Unidentified Network" Issue
                          CiscoKid Hot Shot

                          I downloaded the 6.5 beta for Workstation and sorry all...problem still exists in 6.5.

                          • 40. Re: Vista "Unidentified Network" Issue
                            richv Novice

                             

                            Hey WesleyWex...

                             

                             

                            Do you have a support case number?

                             

                             

                             

                             

                             

                            I have VMWare support on the phone currently and am running through the issue with them...  If I have a case number, we could get the details of your case and escalate from there...

                             

                             

                            • 41. Re: Vista "Unidentified Network" Issue
                              WesleyWex Novice

                               

                              I have it, but I doubt this can help, first I've contacted Microsoft, not VMware, and second, I live in Brasil, so I used the local support.

                               

                               

                              Anyway, the number is 1062038015.

                               

                               

                              • 42. Re: Vista "Unidentified Network" Issue
                                simdoc Novice

                                Our case number is 1109780851.  It is hard to believe, but it appears that they are completely ignorant of this issue--especially if nothing has changed in the 6.5 beta.  I run Vista on my system and primarily because of this issue I do not run VMWare.  I have a strong need to but this problem is too much to overcome.

                                • 43. Re: Vista "Unidentified Network" Issue
                                  richv Novice

                                   

                                  Hey folks...  Concerning the unidentified network issue...

                                   

                                   

                                  Talked with the VMWare Support team (actually not the entire team   )

                                   

                                   

                                  Anyway, they gave me a solution which seems to have worked it about, at least at a visual level.  I'm not sure if this resolves the underlying issues you are running into, give it a try and hopefully it resolves that also.

                                   

                                   

                                  Here is the deal.

                                   

                                   

                                  Run regedit ->

                                  HKLM\SYSTEM\ControlSet001\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\

                                   

                                   

                                  Under here, you will find a list of 0000 to 0017 (at least in my case)

                                   

                                   

                                  Next, run through the 00xx keys until you find the key that says VMNet with a value of either "\DosDevices\VMnet8" or  "\DosDevices\VMnet1" (or whichever VMNet device you are having problems with).

                                   

                                   

                                  Add the key "*NdisDeviceType"   with a DWORD value of 1.

                                   

                                   

                                  Then disable/enable the VMWare NICs (VMNet 1 and VMNet 8 in my case) and reboot and you should be good.

                                   

                                   

                                   

                                   

                                   

                                  • 44. Re: Vista "Unidentified Network" Issue
                                    spyordie007 Lurker

                                    According to the MSDN article (http://msdn2.microsoft.com/en-us/library/bb201634.aspx) setting the NDISDeviceType to 1 sets the device to an Endpoint Mapper, which are ignored when Vista does network identification.  In theory this should take care of the problem (I dont have time to test now, but I'm sure others are already hot on it)!

                                     

                                    What I dont understand is why they had you do it on ControlSet1 rather than the CurrentControlSet.  If anyone notices that it doesnt work under ControlSet1 changing the setting under CurrentControlSet may solve the problem.

                                     

                                    I'll probably test this evening & try to report back my findings.

                                     

                                    Cheers,

                                    Erik