3 Replies Latest reply on Apr 10, 2007 10:03 AM by EMR

    Boot Camp support for a Mac Pro where Windows is in its own physical disk

    EMR Enthusiast

      I've just installed VMware Fusion Beta 3 thrilled at the news it would detect my Boot Camp. As far as I can tell, it didn't. I have a Mac Pro with two physical hard drives. One of them is a native GUID-partitioned with one single HFS+ partition for Mac OS X Tiger 10.4.9. The second hard drive actually came from a PC and it is a MBR-partitioned disk with two partitions. One of them is NTFS for Windows XP Professional SP 2; the other one is a 32Gb FAT32 partition for sharing purposes between Windows and OS X.

       

      I tried this same setup with Parallels and it entirely messed up my Boot Camp disk. I had to physically extract the disk from my Mac Pro, put it in a SATA USB-2 box, attach it to a PC and restore an Acronis backup I had made just in case.

       

      What am I supposed to do so that Fusion will detect my Boot Camp installation? Can it be hand-tuned with the expectation that it will be more benign than Parallel's disastrous behaviour?

        • 1. Re: Boot Camp support for a Mac Pro where Windows is in its own physical disk
          rcardona2k Champion

          I would describe your second disk as more of a raw disk configuration.  Does Boot Camp actually detect and let you use XP on this disk?  Because this doesn't appear to be a 'normal' Boot Camp partition created by the Boot Camp Assistant, I wouldn't doubt that this would not work.

           

          VMware may not comment on raw disk support, if that is not in their plans for the final 1.0 release.

          • 2. Re: Boot Camp support for a Mac Pro where Windows is in its own physical disk
            bgertzfield Master

            Hi EMR,

             

            If you didn't use Boot Camp to create this partition, VMware Fusion won't currently detect your disk.

             

            This is unsupported, but you may be able to directly create a raw disk .vmdk from your MBR-partitioned disk using the tool "/Library/Application Support/VMware Fusion/vmware-rawdiskCreator".

             

            You can then add this .vmdk to a virtual machine and see if it boots.  You may have to manually unmount your Windows partition from Mac OS using Disk Utility before this works.

            • 3. Re: Boot Camp support for a Mac Pro where Windows is in its own physical disk
              EMR Enthusiast

              Thank you both, rcardona and bgetzfield. Yes, you are indeed right. My present Windows disk wasn't created by Boot Camp as such. As I said, it originally came from a PC, but it was empty. I tried using Boot Camp 1.1.2 (not 1.2) to create a single GUID partition for NTFS and I even installed Windows XP SP2 from scratch, but there were two problems with that:

              1) I couldn't write from Mac OS X into anything "Windoze"; I felt I needed an extra FAT32 partition and I didn't want to buy a third disk.

              2) My Windows backup utility, Acronis True Image (the simple, 'Home' version 9) didn't recognise my GUID partition, so I couldn't possibly make a backup.

               

              That's why I finally decided to erase the disk and then MBR-partition it using DiskUtility. I created two partitions: a big one for NTFS, and a small one for FAT32. The Windows install process saw to it that the newly created large partition was formatted for NTFS; the small one remained FAT32.

               

              Now, as for vmware-rawdiskCreator, I've read the basic instructions appearing on a Terminal window. Are there any further instructions I might read? If I run the 'mount' command, it will tell me something like this:

              /dev/disk0s1 on /Volumes/Windows (local, read-only)

              /dev/disk0s2 on /Volumes/FAT32 (local)

              The problem with that is this: In my experience  with Parallels, not always is my Windows disk identified as /dev/disk0s1. I may have done something wrong when trying this with Parallels, but having to manually "finetune" the disk identity each time I wanted to unsuccessfully run Windows from Parallels was a big nuisance, and it ended up messing my entire Windows installation.

               

              It would be far more convenient if the syntax of vmware-rawdiskCreator create command was something like

              vmware-rawdiskCreator create

               

              If so, perhaps I could enter a command like this:

              vmware-rawdiskCreator create Windows ~/users/EMR/Documents/BootCampVirtualMachine ide

              or something like that

               

              What I'm particularly concerned about is the installation of vmware tools on Boot Camp. It was precisely the failed attempt to install Parallels Tools on my Boot Camp partition what fouled my Windows system. You see, a dialog box appeared announcing a minor error and I was supposed to click on the OK button, but I had no keyboard or mouse control!

               

              I would appreciate any advice you can give on a foolproof method to try this.

               

              Thanks for a promising product.