4 Replies Latest reply on Aug 7, 2009 7:08 AM by mpinheiro

    unable to access VM consoles

    kipz Novice

      hello,

       

      one day i discovered that my ESX does not allow to open VM consoles anymore. if i select "Open Console" VI client hangs for couple of minutes and then returns error message:

       

      Error connecting: Could not create lock for vmware-vmkauthd...

       

      the same situation is with VM's console tab and console via web interface. i did some research in KB but did not find any usable hints. does anyone have any idea?

       

      regards,

       

      kaido

        • 1. Re: unable to access VM consoles
          kitcolbert Expert
          VMware Employees

          Sounds like something happened to ole' vmkauthd.  You should check /var/log/secure to look for any more error messages.  Also, you can run 'ps auxwww | grep vmkauthd' to see if vmkauthd is actually running.  If so, you can just kill it with 'kill '.  If there is only one such file, you should safely be able to delete it.

           

          Once you've done both those things, you can try connecting again.

          • 2. Re: unable to access VM consoles
            kipz Novice

            hi,

             

            thanks for your hints. i took a look to /var/run/vmware but there is not file similar to authd_.

             

            but i found such messages in /var/log/secure when i tried to open console:

             

            Feb 15 15:10:38 blsesx1 vmware-authd\[5550]: Found vmkauthd: /usr/lib/vmware/bin/vmware-vmkauthd-start

            Feb 15 15:12:54 blsesx1 vmware-authd\[5550]: Failed to spawn vmkauthd (path='/usr/lib/vmware/bin/vmware-vmkauthd-start', loader='(null)')

            Feb 15 15:12:54 blsesx1 vmware-authd\[5550]: Failed to redirect mks: failed to spawn vmware-vmkauthd.

             

            i did new search from KB and found following topic:

             

            http://www.vmware.com/community/message.jspa?messageID=508452

             

            i added also this parameter to config file and restarted vmkauthd daemon but nothing changed. unfortunately i can restart whole server now. maybe that helps. before that i tried restarting several times and this did not help.

             

            kaido

            • 3. Re: unable to access VM consoles
              marccrowther Lurker

              I had a problem this week with the same error. We were not able to Open VM Consoles using either the VI Client or Web Interface and were not able to add the affected servers into VC 2.0.1 SP2. All 6 Hosts affected had all the lastest Critical Patches prior to the issue.

               

              After searching and finding nothing that would fix this, I checked the VAR\LOG partition and found it full. It seems an unused volume was removed from the SAN (Drives pulled out) and the ESX server tried to re-establish a path to the LUN, whilst logging this over and over again until the LOG partition was full.

               

              I removed the large log files, rescanned the HBA to remove the LUN and its all good now. It seems adding a Host to VC or opening up the console, requires log file access for writing, or it fails.

               

              This did not affect any of the VM's on the 6 ESX Hosts affected luckily.

              • 4. Re: unable to access VM consoles
                mpinheiro Lurker

                 

                Marc,

                 

                 

                Tks for your tip!!!  Your post was very helpful for me.

                 

                 

                Regards.