3 Replies Latest reply on Oct 12, 2020 10:42 AM by anniepeachie

    Virtual Machine won't boot or repair after upgrade from Fusion 8 to 11.5.5

    anniepeachie Lurker

      Hi there.  I don't expect an easy solution, if any at all, but it seems my Virtual Machine finally crapped out.  I was running a Windows 7 machine so that I could use 3 pretty archaic small apps (one of them which locks you out when you install it on a new computer without deauthorizing it first!).  Since I'm still on Mohave, and was planning to upgrade to Catalina or Big Sur eventually, I figured I might as well upgrade to Fusion 11.  Before doing anything I backed up the whole machine to the cloud, backed up docs and files to multiple HD's and cloud services, had a small snafu where I stupidly deleted the original parent Virtual Disk, but then recovered it from a local backup.  I got the machine up and running again, did all my snapshot cleanups (reducing it from 3 to 2 in the interest of disk space), verified my various backups, and installed Fusion 11.5.  I ran it, it upgraded the compatibility of my VM, booted it just fine.  I tested everything, and I think I may have tried to run some MS Windows software updates that always failed anyway, and they still failed.  So nothing new there, and I shut everything down to get back to work in those apps at a later date.

       

      Ten days later, and Windows 7 won't boot up.  It runs disk repair and cannot repair.  Error is Missing OSLoader.  My 16 yr old wizkid son did a bunch of digging in the terminal, looking through the tree, etc.  He says it's corrupt.  I downloaded the cloud backup of the VM from 10 days ago, tried to run it off an external drive, and same problem.  I tried a fresh copy, downgraded it to hardware v. 12, opened it in Fusion 8.1, and same disk Missing OSLoader failure, no repair possible.  I have a ~1 yr old copy on my regular Time Machine backup, but I don't know if that will give me the same problem and I'm exhausted at this point.

       

      So is this it? Is this machine/HD recoverable in the slightest?  Thank you .

        • 1. Re: Virtual Machine won't boot or repair after upgrade from Fusion 8 to 11.5.5
          dlhotka Virtuoso

          So cloud and time machine backups of virtual machines are really problematic, and it looks like you've probably run into the issue.

           

          What happens is that a virtual machine is made up of multiple large files, so backup systems like time machine will start aging out pieces of the VM at different times, resulting in the instability or corruption you've run into.  That's even more true when there's snapshots involved, as there's many more pieces that can get corrupted.

           

          Unless you have a local backup - i.e. a finder copy to an external drive, you may be out of luck.  One of the other folks here might be able to help you mount the virtual disk to extract the data, but that's probably the best option.

           

          For future reference, when upgrading Fusion, especially for a big jump like that, it's best to remove all snapshots and shut the VM down completely.  Then make a local backup, do the fusion upgrade, and do the VM upgrade.  I leave the backup hanging around for a few weeks to make sure it's all stable.  Oh, and definitely exclude the VM from cloud and time machine backups - there's not much point in wasting the bandwidth/disk space - doing a local backup is the only real option.  On that note, there's a program that wila has developed that does reliable backups of VM's.

          • 2. Re: Virtual Machine won't boot or repair after upgrade from Fusion 8 to 11.5.5
            continuum Guru
            vExpertCommunity Warriors

            Next troubleshooting step:

            boot the VM as it is into a Windows 7 LiveCD or original installer ISO.

            Get a commandline and try:

            - list the content of the Windows partition

            - start a checkdisk run against the Windows partition with all options: chkdsk.exe /f /x /r DRIVELETTER:

             

            Report results  - next steps depend on it ...

            • 3. Re: Virtual Machine won't boot or repair after upgrade from Fusion 8 to 11.5.5
              anniepeachie Lurker

              Thanks for the replies!  Last night I actually successfully recovered the VM with my last ditch effort of going into my Time Machine local drive.  I've always wanted to externally backup snapshots once every few months or so, but at some point I realized once I exclude, every copy ends up deleted.  I remember years ago when I first realized what I was doing to my backup HD with all the VM's, I did figure out some convoluted way to selectively delete snapshots one by one, but that wasn't anything I've wanted to do again.

               

              SO, since my time machine drive was put in service last August '19, I restored the original copy to another external drive, I didn't take any chances with Fusion 11 and opened it in a newly downloaded 8.1 and perfect!  Then I started dragging over the most current copies of the data files that I had been using (from iDrive, first time it's ever been useful for anything, I'm so done with it).  I now see I have backups of various versions of the files scattered all over every cloud service in existence, and I really need to clean all that up.

               

              Yes, I think my biggest mistake was not making a local copy of the VM in another location before upgrading to 11.  For such a data paranoid person, it was a stupid step to skip, as I know I've done it in the past.  Now I'm working off this external drive my husband chucked to me from his stash, which I probably should have requested sooner instead of fretting about my lack of onboard free space.

               

              I think I'm going to start moving away from virtual machines at this point.  Too much stress for me in the past 10 years, for 3 stupid apps that no one would care about except for me.  I just got a Surface 3 off eBay, and my slacker son should have a blast rolling it back to Windows 8.  I'll see how my apps run on it.

               

              Thanks again, and sorry for not attempting the command line troubleshooting stuff, I'm so pooped.