0 Replies Latest reply on Aug 16, 2020 5:00 PM by JustinGDen

    USB Bug - Devices Failing to Load

    JustinGDen Lurker

      I am seeing a new and serious issue with VMWare Workstation and USB. This may have only occurred with the latest update, as I did not notice this problem until now.

       

      When a new USB device is connected while a virtual machine is running, the device driver fails to successfully load. For instance, my headphones report a driver error of: "There are no compatible drivers for this device." This does NOT occur when a virtual machine is not running.

       

      This also appears to affect other types of devices. I tried to move my keyboard and mouse to different USB ports and then those drivers no longer worked and I could no longer control my host machine at all.

       

      I was not trying to connect these devices to the virtual machine and even have tried switching to automatically assigning devices to the host and still have the issue.

       

      Here are the environment's details:

       

      VMWare Workstation Player v 15.5.6 build-16341506

       

      Windows 10 v 10.0.19041 Build 19041

       

      Hopefully, this bug report helps.

       

      Thank you,

       

      Justin