1 Reply Latest reply on Jul 27, 2020 5:56 PM by khamilton2

    Visual Studio 2019 - Cannot check for updated license

    khamilton2 Lurker

      I am getting an error when trying to use Visual Studio 2019 community version on our VM/appstacks.

      I am able to run VS2019 on our physical machines without having this issue.  This is after a fresh install.

       

      Windows 10 x64 1909

      View agent 7.12 & vcenter 7

      Appvol agent 2.18.4

       

      I did use the VMware OSOT which disabled NCSI.  I re-enabled that and set the reg keys in HKLM\Software\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator back to 0.  I thought maybe the issue with Windows thinking it had no internet access was the issue but even with the taskbar icon showing Connect & Internet Access now I still get the same error when trying to update the visual studio license.

       

      I can sign in fine and it recognizes my account, but trying to "update license" always results in the same error "We could download a license, check internet connection and proxy settings"

       

      Has anyone else had this or similar issue?  Is there some other network setting I may need to re-enabled that was turned off using the OSOT?

       

      I have not tried to install it on a fresh plain base image yet but that will be next on the list for tomorrow.

        • 1. Re: Visual Studio 2019 - Cannot check for updated license
          khamilton2 Lurker

          A bit of follow up.

           

          I went ahead and installed it on the base Image.  It works fine there.

           

          I also was able to use it without any errors while it was being provisioned on the appprov machine.  As in I updated the appstack, while it was provisioning opened VS2019, signed in and grabed the license without issues.  However when I captured it again and attached it to a pool it was still giving the original error.

           

          That leads me to believe its something related to appvolumes but I am not sure what right now.  We previously had VS2017 working on a appvol 2.15 appstack and windows 1803.