0 Replies Latest reply on Jul 25, 2020 4:47 AM by dr_ska

    Workstation 15.5.6 will not install on Ubuntu 18.04.4 LTS

    dr_ska Lurker

      my kernel is 5.4.0-42-generic

       

      VMware-Player-15.5.6-16341506.x86_64.bundle (the free version) installer aborts as follows:

       

      Extracting VMware Installer...done.

      /tmp/tmp4t3ofyjx.vmis.env:4: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses

        import imp

      /tmp/vmis.GCBpAm/install/vmware-installer/vmis-launcher: error while loading shared libraries: libcrypto.so.1.0.2: cannot open shared object file: No such file or directory

       

       

      In fact I am trying to update after 15.5.0 gave up on me.  MAKE reports

      2020-07-25T12:59:05.861+02:00| host-16114| I125+ make[2]: *** [/tmp/modconfig-3reCBk/vmnet-only/userif.o] Error 1

      2020-07-25T12:59:05.861+02:00| host-16114| I125+ make[2]: *** Waiting for unfinished jobs....

      2020-07-25T12:59:05.861+02:00| host-16114| I125+ make[1]: *** [/tmp/modconfig-3reCBk/vmnet-only] Error 2

      2020-07-25T12:59:05.861+02:00| host-16114| I125+ make: *** [vmnet.ko] Error 2

      2020-07-25T12:59:05.861+02:00| host-16114| I125+ Unable to install all modules.  See log for details.

       

      Make fails after 6 errors building the kernel, similar to [full log attached]

      error: ‘skb_frag_t {aka const struct bio_vec}’ has no member named ‘size’