13 Replies Latest reply on Jul 24, 2020 3:38 PM by ourbaseisunderattack

    wmrun vmware player 15

    ourbaseisunderattack Novice

      Hi,

      I'm using Debian 10, I've installed VMware Player 15 free and using latest version of gns3

      when I want to use my vm machines os VMware gns3 is looking for vmrun

      where can I find or download it?

      thanks

        • 1. Re: wmrun vmware player 15
          scott28tt Guru
          Community WarriorsUser ModeratorsVMware Employees

          Moderator: Thread moved to the Workstation Player area.

          • 2. Re: wmrun vmware player 15
            scott28tt Guru
            VMware EmployeesCommunity WarriorsUser Moderators

            Please clear on which OS is generating the error/message - the host OS on your PC or the guest OS in your VM?

             

            And what you do to cause the error/message to appear.

             

            Screenshots are useful if you can post those.

            • 3. Re: wmrun vmware player 15
              ourbaseisunderattack Novice

              Thanks for reply and moving this thread to the correct place, and I'm sorry for opening this thread in a wrong place.

              Actually I'm using GNS3 which suggested to use VMware VMs for PC emulators, In GNS3 preferences > VMware, when I click on VMware VMs it tries to show VM list and it makes an error that

              it cannot find vmrun.

              there is a Path to vmrun in it settings but I don't have any vmrun

              I searched about it and I found I should install VIX API (which has vmrun) but there is no VIX API for VMware Player 15, now I don't know what should I do.

              My host OS is Debian 10

              • 4. Re: wmrun vmware player 15
                wila Guru
                vExpertCommunity WarriorsUser Moderators

                Hi,

                 

                Look at the "Move Like this" pane on your right hand side in this thread.

                It has been discussed a few times on this forum.

                Basically you download an earlier version and then edit a config file to make it work with Workstation Player 15.5

                 

                --

                Wil

                | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                | Vimalin : Automated backups for VMware Fusion and VMware Workstation and Player
                | More info at https://www.vimalin.com
                | Twitter @wilva
                | VMware Wiki at http://www.vi-toolkit.com
                • 5. Re: wmrun vmware player 15
                  ourbaseisunderattack Novice

                  you're right, but in those threads they use VMware VIX 1.17 which I cannot install it

                  I get this error when I'm going to install it

                  Extracting VMware Installer...done.

                  Traceback (most recent call last):

                    File "/tmp/tmpx4c0c9b8.vmis.env", line 132, in <module>

                      exec(fileObj.read(), mod.__dict__)

                    File "<string>", line 265

                      except OSError, e:

                                    ^

                  SyntaxError: invalid syntax

                  • 6. Re: wmrun vmware player 15
                    scott28tt Guru
                    VMware EmployeesUser ModeratorsCommunity Warriors

                    So you have Debian 10 installed and running on your PC, you’ve installed Workstation Player on Debian, and are running GNS3 inside a VM?

                     

                    Is the VM the pre-built one? https://www.gns3.com/software/download-vm

                    • 7. Re: wmrun vmware player 15
                      ourbaseisunderattack Novice

                      Not actually, I'm using Debian and running on my PC, I've installed Workstation Player on my Debian and I've also installed GNS3 on my Debian.

                      In GNS3 you should simulate PCs, which you can install an OS on your VM and add it your GNS3 as your Simulated PC.

                      In GNS3 there are options that you can determine where your simulated PCs come, for example, you can say my PCs are in Docker, VirtualBox and VMware(which is recommended)

                      so in GNS3 I say I want to use an OS which is installed in my VMware, then when I want to select the OS, GNS3 is goining to show all OS installed in my VMware and when it tries to do that it raises an error that it cannot find vmrun.

                      Actually, GNS3 needs vmrun to get list of operating systems installed in VMware.

                      • 8. Re: wmrun vmware player 15
                        wila Guru
                        vExpertUser ModeratorsCommunity Warriors

                        Hi,

                         

                        Take a look at this post:

                        VMware VIX  + Debian 10 Buster install problem

                         

                        --

                        Wil

                        | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                        | Vimalin : Automated backups for VMware Fusion and VMware Workstation and Player
                        | More info at https://www.vimalin.com
                        | Twitter @wilva
                        | VMware Wiki at http://www.vi-toolkit.com
                        • 9. Re: wmrun vmware player 15
                          ourbaseisunderattack Novice

                          Unfortunately, it didn't work for me.

                          • 10. Re: wmrun vmware player 15
                            wila Guru
                            vExpertUser ModeratorsCommunity Warriors

                            Hi,

                             

                            Perhaps try posting at the section of the forum where that link was as down there you have the team behind VIX watching and helping out.

                             

                            Also note that as a tip, next time tell exactly what you tried and mention any errors or problems you saw.

                            A "it doesn't work" type of reply is very hard for us to provide help with.

                             

                            --

                            Wil

                            | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                            | Vimalin : Automated backups for VMware Fusion and VMware Workstation and Player
                            | More info at https://www.vimalin.com
                            | Twitter @wilva
                            | VMware Wiki at http://www.vi-toolkit.com
                            • 11. Re: wmrun vmware player 15
                              ourbaseisunderattack Novice

                              Thanks, you're right.

                              Actually, these paths don't exist in my system

                              /usr/lib/vmware-tools/lib32/libconf or /usr/lib/vmware-tools/lib64/libconf

                              also this file

                               

                              vmware-uninstall-tools.pl

                               

                              • 12. Re: wmrun vmware player 15
                                wila Guru
                                User ModeratorsCommunity WarriorsvExpert

                                Hi,

                                 

                                Hmm.. my bad. Seems I didn't read that reply well and was swayed by the vmware employee logo.

                                 

                                It's weird to see a /usr/lib/vmware-tools path mentioned when we are installing something on the host??

                                So that doesn't sound like it ever could be a viable answer.

                                 

                                In the meantime what I did here was set up a box with debian buster and installed VMware Player so that I could experiment a bit.


                                Then I tried to locate VMware VIX .. and it looks like that VMware has broken the download link. Not sure if that is by accident or intentional, but it sure isn't helping.

                                 

                                After some googling I managed to locate VIX 1.14 ...which doesn't install.

                                 

                                Can you tell me what version of VIX you are trying to install? (and where did you download it from?)

                                 

                                Also can you say how did you try to install it?

                                Did you try using:

                                 

                                sudo vmware-installer -i <vix-bundle>

                                 

                                or another way?

                                 

                                In the meantime let me suggest an alternative route that should work without trouble (I'm still curious for an answer to the above questions though)

                                 

                                If you install the full suite: VMware Workstation Professional then it installs both VMware Player as well as VIX alongside with the professional GUI.

                                VMware Player will continue working after the Professional trial runs out.

                                 

                                --

                                Wil

                                | Author of Vimalin. The virtual machine Backup app for VMware Desktop Products
                                | Vimalin : Automated backups for VMware Fusion and VMware Workstation and Player
                                | More info at https://www.vimalin.com
                                | Twitter @wilva
                                | VMware Wiki at http://www.vi-toolkit.com
                                • 13. Re: wmrun vmware player 15
                                  ourbaseisunderattack Novice

                                  Thank you for your time and consideration.

                                  I've just installed VMware Workstation Professional as you said and it works fine.

                                  and I guess it's the free version issue.

                                   

                                  I downloaded the VIX 1.17 from this link https://download3.vmware.com/software/player/file/VMware-VIX-1.17.0-6661328.x86_64.bundle

                                  however, it is not in the VMware VIX download page, I found this link from google.

                                  first I tried this

                                  sudo ./VMware-VIX-1.17.0-6661328.x86_64.bundle

                                  and you know what the problem was

                                  then I tried this

                                  sudo vmware-installer -i VMware-VIX-1.17.0-6661328.x86_64.bundle

                                  and I got this error

                                  Component vmware-vix 1.17.0 has unsatisfied dependency: vmware-installer=2.1.0

                                   

                                  (my vmware-installer version was 3.0.0)

                                   

                                  and finally your last solution just worked fine.

                                  thank you very much.